aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-10-25 14:33:55 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-10-28 18:54:13 +0200
commit6fca0e337ba1b8deaac9b6c0fa41a485e5bf5013 (patch)
treec46108c7618b5dd6a37d8e43eaf1a1172ce959b3
parent09f4a09bd2cdb5631dab707c38fdcc746e339ce7 (diff)
qtbase: add openssl PACKAGECONFIG for native nativesdk
Add PACKAGECONFIG option to enable openssl for qtbase-native and nativesdk-qtbase recipes, since some build tools require openssl to be enabled. Change-Id: Ic213e70b3983f99245e6ea7668eb48369ac5e61d Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 74672bf3..e3d4c3b4 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -77,6 +77,7 @@ DEBIAN_NOAUTONAME_${PN} = "1"
PACKAGECONFIG ?= ""
PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
+PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
QT_CONFIG_FLAGS += " \
-shared \
@@ -111,7 +112,6 @@ do_configure() {
-no-sql-mysql \
-no-sql-sqlite \
-no-opengl \
- -no-openssl \
-no-xcb \
-no-feature-bearermanagement \
-no-icu \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index a144689f..8bcea45c 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -59,6 +59,7 @@ XPLATFORM ?= "linux-oe-g++"
PACKAGECONFIG ?= ""
PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
+PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl"
QT_CONFIG_FLAGS = " \
-sysroot ${STAGING_DIR_NATIVE} \
@@ -74,7 +75,6 @@ QT_CONFIG_FLAGS = " \
-no-sql-psql \
-no-opengl \
-no-vulkan \
- -no-openssl \
-no-xcb \
-no-icu \
-verbose \