aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-08-18 16:22:26 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2019-08-22 16:15:15 +0000
commit725c87da81a5bfb6e838f7fb53f14bb2c06cf81a (patch)
tree3a89c8ecdf7bd0d8f400576fac0a587a9e9ebcca
parenta41cd9eded4bd661a71c86a2d6080094f8a77069 (diff)
qtwayland: do not reference private modules in cmake Qt5WaylandClient
The files referenced are not installed causing trouble in projects using Qt5WaylandClientConfig.cmake: | CMake Error at /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/liri-shell/0.9.0+gitAUTOINC+42bd7f4610-r0/recipe-sysroot/usr/lib/cmake/Qt5WaylandClient/Qt5WaylandClientConfig.cmake:110 (find_package): | Could not find a package configuration file provided by | "Qt5LinuxAccessibilitySupport" (requested version 5.13.0) with any of the | following names: | | Qt5LinuxAccessibilitySupportConfig.cmake | qt5linuxaccessibilitysupport-config.cmake Fixes: QTBUG-76042 [1] Upstream-Status: Applied [2] [1] https://bugreports.qt.io/browse/QTBUG-76042 [2] https://code.qt.io/cgit/qt/qtwayland.git/commit/?id=f4636b934f90b2a07b09f1925a86440cf1944d08 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwayland/0001-Fix-use-of-private-dependency.patch36
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-Fix-use-of-private-dependency.patch b/recipes-qt/qt5/qtwayland/0001-Fix-use-of-private-dependency.patch
new file mode 100644
index 00000000..3cf195db
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-Fix-use-of-private-dependency.patch
@@ -0,0 +1,36 @@
+From f4636b934f90b2a07b09f1925a86440cf1944d08 Mon Sep 17 00:00:00 2001
+From: Pier Luigi Fiorini <pierluigi.fiorini@liri.io>
+Date: Wed, 24 Jul 2019 23:40:55 +0200
+Subject: [PATCH] Fix use of private dependency
+
+With 0761173a, Linux SPI Accessibility bridge was added to
+the Wayland QPA plugin, but this had a bad side-effect to
+QtWaylandClient.
+
+Linux Accessibility support is a private module, this means we have
+to link to it with QT_PRIVATE not QT, otherwise CMake and pkg-config
+files for Qt5WaylandClient will depend on it.
+
+Change-Id: I6182267f97adc2cd5bd66895df148a6a45614f45
+Fixes: QTBUG-76042
+Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
+---
+ src/client/client.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/client/client.pro b/src/client/client.pro
+index db91bd69..4233ac95 100644
+--- a/src/client/client.pro
++++ b/src/client/client.pro
+@@ -20,7 +20,7 @@ qtConfig(xkbcommon) {
+ }
+
+ qtHaveModule(linuxaccessibility_support_private): \
+- QT += linuxaccessibility_support_private
++ QT_PRIVATE += linuxaccessibility_support_private
+
+ QMAKE_USE += wayland-client
+
+--
+2.21.0
+
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 8a6f38f6..cd55b43b 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -13,6 +13,8 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
+SRC_URI += "file://0001-Fix-use-of-private-dependency.patch"
+
PACKAGECONFIG ?= " \
wayland-client \
wayland-server \