aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-07-25 12:30:39 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2019-07-29 12:15:34 +0000
commitcd9256718be8b28fff9d6e0d69dc819830c5cc20 (patch)
tree8e00f146969f44dc4aa701906afc429a9191ede2
parent708be171f67ed6d63247f4fb7a83d6f858d42fbd (diff)
qt5-creator: update to v4.9.2
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch (renamed from recipes-qt/qt5/qt5-creator/0003-Link-with-libexecinfo-on-musl.patch)6
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-botan-Always-define-BOTAN_ARCH_SWITCH-when-cross-bui.patch26
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-botan.pro-pass-QMAKE_AR.patch80
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb14
4 files changed, 9 insertions, 117 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0003-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch
index 9b225a57..214a4034 100644
--- a/recipes-qt/qt5/qt5-creator/0003-Link-with-libexecinfo-on-musl.patch
+++ b/recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch
@@ -1,4 +1,4 @@
-From 88afa7173c7d0c97e15d9ee9c58e8c0364799bb7 Mon Sep 17 00:00:00 2001
+From 33299724b8719d53b26c9055a76a61c358270110 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 16 Jan 2018 13:26:57 +0000
Subject: [PATCH] Link with libexecinfo on musl
@@ -10,10 +10,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+)
diff --git a/src/plugins/debugger/debugger.pro b/src/plugins/debugger/debugger.pro
-index f5a34aa0d5..4a1359dd5c 100644
+index acbf5136b9..159139eb2b 100644
--- a/src/plugins/debugger/debugger.pro
+++ b/src/plugins/debugger/debugger.pro
-@@ -141,3 +141,4 @@ include(console/console.pri)
+@@ -139,3 +139,4 @@ include(console/console.pri)
include(analyzer/analyzer.pri)
include(shared/shared.pri)
diff --git a/recipes-qt/qt5/qt5-creator/0001-botan-Always-define-BOTAN_ARCH_SWITCH-when-cross-bui.patch b/recipes-qt/qt5/qt5-creator/0001-botan-Always-define-BOTAN_ARCH_SWITCH-when-cross-bui.patch
deleted file mode 100644
index eebda742..00000000
--- a/recipes-qt/qt5/qt5-creator/0001-botan-Always-define-BOTAN_ARCH_SWITCH-when-cross-bui.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 766e5b37a42b440b66823262eb553f9981940115 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 27 Sep 2018 20:48:17 -0700
-Subject: [PATCH] botan: Always define BOTAN_ARCH_SWITCH when cross-building
-
-this helps in compiling botan for non-x86 architectures
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/libs/botan/botan.pro | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/libs/botan/botan.pro b/src/libs/botan/botan.pro
-index 0c939b2a30..6e1a85fe84 100644
---- a/src/libs/botan/botan.pro
-+++ b/src/libs/botan/botan.pro
-@@ -18,6 +18,7 @@ else: clang: BOTAN_CC_TYPE = clang
- else: BOTAN_CC_TYPE = gcc
- contains(QT_ARCH, i386): BOTAN_ARCH_SWITCH = "--cpu=x86"
- else: contains(QT_ARCH, x86_64): BOTAN_ARCH_SWITCH = "--cpu=x86_64"
-+else: BOTAN_ARCH_SWITCH = --cpu=$$QT_ARCH
- BOTAN_MODULES = aes aes_ssse3 auto_rng bigint block cbc ctr des dh dsa ec_group ecdh ecdsa entropy \
- filters hmac mode_pad pubkey rsa sha1 sha1_sse2 sha1_x86 sha2_32 sha2_32_x86 \
- sha2_64 simd system_rng,emsa_pkcs1,pbes2,pbkdf2
--- 2.19.0
-
diff --git a/recipes-qt/qt5/qt5-creator/0002-botan.pro-pass-QMAKE_AR.patch b/recipes-qt/qt5/qt5-creator/0002-botan.pro-pass-QMAKE_AR.patch
deleted file mode 100644
index 26262299..00000000
--- a/recipes-qt/qt5/qt5-creator/0002-botan.pro-pass-QMAKE_AR.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From cd006f4a79b3c1435a8a8321b5af9191f104bbb3 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Wed, 26 Sep 2018 21:14:06 +0000
-Subject: [PATCH] botan.pro: pass QMAKE_AR
-
-* otherwise AR from environment sets it with cqs params, e.g.:
- x86_64-oe-linux-ar cqs
- from QMAKE_AR = ${OE_QMAKE_AR} cqs
-
- but then botan's Makefile will add "crs" after it causing:
- http://errors.yoctoproject.org/Errors/Details/194653/
-
- x86_64-oe-linux-ar cqs crs libbotan-2.a build/obj/lib/botan_all.o build/obj/lib/botan_all_ssse3.o
- x86_64-oe-linux-ar: libbotan-2.a: No such file or directory
- Makefile:79: recipe for target 'libbotan-2.a' failed
- make[4]: *** [libbotan-2.a] Error 1
-
-* add --ar-options parameter to botan configure and respect the
- value when set (before cc.ar_options and osinfo.ar_options)
- then use this to pass empty ar_options as we already include
- the options in ar_command
-
-Upstream-Status: Pending
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- src/libs/3rdparty/botan/configure.py | 13 ++++++++++++-
- src/libs/botan/botan.pro | 1 +
- 2 files changed, 13 insertions(+), 1 deletion(-)
-
-diff --git a/src/libs/3rdparty/botan/configure.py b/src/libs/3rdparty/botan/configure.py
-index b09f07bb5e..2b5b9c6417 100755
---- a/src/libs/3rdparty/botan/configure.py
-+++ b/src/libs/3rdparty/botan/configure.py
-@@ -321,6 +321,9 @@ def process_command_line(args): # pylint: disable=too-many-locals
- target_group.add_option('--ar-command', dest='ar_command', metavar='AR', default=None,
- help='set path to static archive creator')
-
-+ target_group.add_option('--ar-options', dest='ar_options', metavar='crs', default='crs',
-+ help='set options for static archive creator')
-+
- target_group.add_option('--msvc-runtime', metavar='RT', default=None,
- help='specify MSVC runtime (MT, MD, MTd, MDd)')
-
-@@ -1786,6 +1789,14 @@ def create_template_vars(source_paths, build_paths, options, modules, cc, arch,
-
- return osinfo.ar_command
-
-+ def ar_options():
-+ if options.ar_options:
-+ return options.ar_options
-+ if cc.ar_options:
-+ return cc.ar_options
-+
-+ return osinfo.ar_options
-+
- def choose_endian(arch_info, options):
- if options.with_endian != None:
- return options.with_endian
-@@ -1938,7 +1949,7 @@ def create_template_vars(source_paths, build_paths, options, modules, cc, arch,
- 'post_link_cmd': '',
-
- 'ar_command': ar_command(),
-- 'ar_options': cc.ar_options or osinfo.ar_options,
-+ 'ar_options': ar_options(),
- 'ar_output_to': cc.ar_output_to,
-
- 'link_to': ' '.join(
-diff --git a/src/libs/botan/botan.pro b/src/libs/botan/botan.pro
-index 0c939b2a30..e8082c4bbb 100644
---- a/src/libs/botan/botan.pro
-+++ b/src/libs/botan/botan.pro
-@@ -46,6 +46,7 @@ configure.variable_out = BOTAN_MAKEFILE
- configure.commands = cd $$BOTAN_BUILD_DIR_FOR_SHELL && \
- python $$CONFIGURE_FILE_PATH_FOR_SHELL \
- --cc=$$BOTAN_CC_TYPE --cc-bin=$$shell_quote($$QMAKE_CXX) \
-+ --ar-command=$$shell_quote($$QMAKE_AR) --ar-options=$$shell_quote(' ') \
- $$BOTAN_ARCH_SWITCH $$BOTAN_OS_SWITCH $$OTHER_FLAGS
- QMAKE_EXTRA_COMPILERS += configure
-
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 6a8887ed..107fee53 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -18,17 +18,15 @@ DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qtto
DEPENDS_append_toolchain-clang = " clang llvm-common"
DEPENDS_append_libc-musl = " libexecinfo"
-SRCREV = "8768e39d3c8e74e583eca3897cc6de53a99c3dde"
-PV = "4.7.1+git${SRCPV}"
+SRCREV = "8181363fa90eb651591bf71e1a840e1c998429f4"
+PV = "4.9.2+git${SRCPV}"
-# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.7.1
-# 4.7.1.meta-qt5.1
+# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2
+# 4.9.2.meta-qt5.1
SRC_URI = " \
- git://code.qt.io/qt-creator/qt-creator.git;branch=4.7 \
- file://0002-botan.pro-pass-QMAKE_AR.patch \
- file://0001-botan-Always-define-BOTAN_ARCH_SWITCH-when-cross-bui.patch \
+ git://code.qt.io/qt-creator/qt-creator.git;branch=4.9 \
"
-SRC_URI_append_libc-musl = " file://0003-Link-with-libexecinfo-on-musl.patch"
+SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"
S = "${WORKDIR}/git"