aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-02 13:32:54 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2019-09-03 09:41:28 +0000
commitdc502d57586634744b640465796ba7dc4d262a00 (patch)
treec7c38087f0afbfbf7f02e71bdfcc47d864b22ce8
parent8799d3b71cc9463316a0377913ae707540568e69 (diff)
qtwebengine: Fix compile failure with 5.2+ kernel headers
Fixes error: 'SIOCGSTAMP' was not declared in this scope Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch29
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch
new file mode 100644
index 00000000..bdab820a
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch
@@ -0,0 +1,29 @@
+From: Jiri Slaby <jslaby@suse.cz>
+Date: Thu, 11 Jul 2019 09:35:13 +0200
+Subject: fix build after y2038 changes in glibc
+Patch-mainline: submitted on 2019/07/11
+References: QTBUG-76963
+
+SIOCGSTAMP is defined in linux/sockios.h since kernel 5.2. Include that
+file wherever needed.
+
+Signed-off-by: Jiri Slaby <jslaby@suse.cz>
+---
+Upstream-Status: Pending
+
+ chromium/third_party/webrtc/rtc_base/physical_socket_server.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/chromium/third_party/webrtc/rtc_base/physical_socket_server.cc
++++ b/chromium/third_party/webrtc/rtc_base/physical_socket_server.cc
+@@ -67,6 +67,7 @@ typedef void* SockOptArg;
+ #endif // WEBRTC_POSIX
+
+ #if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__)
++#include <linux/sockios.h>
+
+ int64_t GetSocketRecvTimestamp(int socket) {
+ struct timeval tv_ioctl;
+--
+2.21.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index d36b972f..009d2529 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -157,6 +157,7 @@ SRC_URI += " \
file://chromium/0004-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
file://chromium/0006-chromium-aarch64-skia-build-fix.patch;patchdir=src/3rdparty \
+ file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\