aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-15 08:29:53 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-15 08:46:49 +0000
commitfc3f8ff4c82796a7708640f110aef66f421846a5 (patch)
tree81e2492f3873e3beaa2913216f05ca31319fefd9
parent5fdfbec8369f990bd4b9def1294ade6bbf60e143 (diff)
qtwebengine: allow build for musl libc
Change-Id: I5a772ff58ba1f1315a6b3b7b42b5a43db8f9d8bd Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch23
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch b/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
new file mode 100644
index 00000000..3047230c
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
@@ -0,0 +1,23 @@
+From a1c248259f3d8561d6e2c75a56edf4a72c393843 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Thu, 15 Aug 2019 07:52:53 +0300
+Subject: [PATCH] musl: allow build without glibc
+
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ mkspecs/features/configure.prf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
+index cc84182b..f1310f75 100644
+--- a/mkspecs/features/configure.prf
++++ b/mkspecs/features/configure.prf
+@@ -75,7 +75,7 @@ defineTest(runConfigure) {
+ return(false)
+ }
+
+- !qtConfig(webengine-system-glibc) {
++ false:!qtConfig(webengine-system-glibc) {
+ skipBuild("A suitable version >= 2.27 of libc could not be found.")
+ return(false)
+ }
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 5d6f7b7f..54026cfa 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -143,6 +143,7 @@ SRC_URI += " \
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
file://0003-musl-link-against-libexecinfo.patch \
+ file://0004-musl-allow-build-without-glibc.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/73-based