aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2019-12-30 11:44:21 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-13 23:27:14 +0100
commit254576f9b4b2a6271b4ed25df335c625bd6ef885 (patch)
tree907fb356de0e4fd0832cea161d501095a374c5dc
parent47399df989db21bbc628db6c23c82290d4d82fa5 (diff)
qt-kiosk-browser: Add recipe
The Qt Kiosk Browser provides a simple browser which offers a nice set of features for use on a Kiosk device. It supports: - Out of box screen saver - Virtual Keyboard - Highly configurable Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf5
-rw-r--r--recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb32
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf
new file mode 100644
index 00000000..4f4849b5
--- /dev/null
+++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser/qt-kiosk-browser.conf
@@ -0,0 +1,5 @@
+{
+ "URL": "http://github.com/OSSystems/qt-kiosk-browser",
+ "RestartTimeout": 0,
+ "ScreenSaverTimeout": 0
+}
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
new file mode 100644
index 00000000..f196ae03
--- /dev/null
+++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Qt Kiosk Browser"
+DESCRIPTION = "Provides a simple but highly configurable browser for use on Kiosk devices"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
+LICENSE = "GPLv3"
+
+DEPENDS = "qtwebengine"
+
+SRC_URI = " \
+ git://github.com/OSSystems/qt-kiosk-browser;protocol=https \
+ file://${BPN}.conf \
+"
+
+PV = "0.0+git${SRCPV}"
+SRCREV = "d42b7d9050b5445e2b9430022a46d5d583581631"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+EXTRA_QMAKEVARS_PRE += "PREFIX=${prefix}"
+
+do_install_append() {
+ install -Dm 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
+}
+
+RDEPENDS_${PN} += " \
+ liberation-fonts \
+ qtdeclarative-qmlplugins \
+ qtquickcontrols-qmlplugins \
+ qtvirtualkeyboard \
+ qtwebengine-qmlplugins \
+"