aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-11-16 09:57:46 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2020-11-20 11:40:44 +0200
commit545be38961a2e287c64f2ae607569e88da4bfa8b (patch)
treecb8def142c1583d1b9c2f7b0f48310f0665bf3e6
parent72459ce0639eb3ce408558a7abede945e1f8ddc9 (diff)
coin: move test configs to separate file
Separate test-configs.inc allows easy local build setup to match the CI build configuration. Change-Id: I64930c88ea1cba3f9f039881dc0ba947feeb9a34 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--.gitattributes1
-rw-r--r--coin/module_config.yaml89
-rw-r--r--coin/test-configs.inc83
3 files changed, 84 insertions, 89 deletions
diff --git a/.gitattributes b/.gitattributes
index f6a86105..cb2381c0 100644
--- a/.gitattributes
+++ b/.gitattributes
@@ -1,3 +1,2 @@
-/coin export-ignore
# linguist overrides
recipes-*/**/*.inc linguist-language=BitBake
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index c851022a..39283baa 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -55,93 +55,6 @@ build_instructions:
userMessageOnFailure: "Could not mount yocto cache."
- type: WriteFile
fileContents: |
- # https://github.com/shr-project/jenkins-jobs/blob/master/jenkins-job.sh
- INHERIT += "reproducible_build_simple"
- # need space for dunfell build
- INHERIT += "rm_work"
- # We want musl and glibc to share the same tmpfs, so instead of appending default "-${TCLIBC}" we append "fs"
- TCLIBCAPPEND = "fs"
- PREFERRED_PROVIDER_udev = "systemd"
- PREFERRED_PROVIDER_virtual/fftw = "fftw"
- # use gold
- DISTRO_FEATURES_append = " ld-is-gold"
- # use ptest
- DISTRO_FEATURES_append = " ptest"
- # use systemd
- DISTRO_FEATURES_append = " systemd"
- DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
- VIRTUAL-RUNTIME_init_manager = "systemd"
- VIRTUAL-RUNTIME_initscripts = ""
- # use opengl
- DISTRO_FEATURES_append = " opengl"
- # use wayland to fix building weston and qtwayland
- DISTRO_FEATURES_append = " wayland"
- PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
- PREFERRED_PROVIDER_jpeg-native = "libjpeg-turbo-native"
- PREFERRED_PROVIDER_gpsd = "gpsd"
- PREFERRED_PROVIDER_e-wm-sysactions = "e-wm"
- ESYSACTIONS = "e-wm-sysactions"
- # don't pull libhybris unless explicitly asked for
- PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
- PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
- PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
- PREFERRED_PROVIDER_virtual/egl ?= "mesa"
- # to fix fsoaudiod, alsa-state conflict in shr-image-all
- VIRTUAL-RUNTIME_alsa-state = ""
- # to prevent alsa-state being pulled into -dev or -dbg images
- RDEPENDS_${PN}-dev_pn-alsa-state = ""
- RDEPENDS_${PN}-dbg_pn-alsa-state = ""
- # to fix dependency on conflicting x11-common from packagegroup-core-x11
- VIRTUAL-RUNTIME_xserver_common ?= "xserver-common"
- RDEPENDS_${PN}-dev_pn-x11-common = ""
- RDEPENDS_${PN}-dbg_pn-x11-common = ""
- # to fix apm, fso-apm conflict in shr-image-all
- VIRTUAL-RUNTIME_apm = "fso-apm"
- # require conf/distro/include/qt5-versions.inc
- # QT5_VERSION = "5.4.0+git%"
- # for qtwebkit etc
- # see https://bugzilla.yoctoproject.org/show_bug.cgi?id=5013
- # DEPENDS_append_pn-qtbase = " mesa"
- PACKAGECONFIG_append_pn-qtbase = " icu gl accessibility freetype fontconfig"
- # qtwayland doesn't like egl and xcomposite-glx enabled at the same time
- # http://lists.openembedded.org/pipermail/openembedded-devel/2016-December/110444.html
- PACKAGECONFIG_remove_pn-qtwayland = "xcomposite-egl xcomposite-glx"
- # for webkit-efl
- PACKAGECONFIG_append_pn-harfbuzz = " icu"
- inherit blacklist
- # PNBLACKLIST[samsung-rfs-mgr] = "needs newer libsamsung-ipc with negative D_P: Requested 'samsung-ipc-1.0 >= 0.2' but version of libsamsung-ipc is 0.1.0"
- PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds"
- PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much"
- PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much"
- PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
- PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
- PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much"
- PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/"
- # enable reporting
- # needs http://patchwork.openembedded.org/patch/68735/
- #ERR_REPORT_SERVER = "errors.yoctoproject.org"
- #ERR_REPORT_PORT = "80"
- #ERR_REPORT_USERNAME = "Martin Jansa"
- #ERR_REPORT_EMAIL = "Martin.Jansa@gmail.com"
- #ERR_REPORT_UPLOAD_FAILURES = "1"
- #INHERIT += "report-error"
- # needs patch with buildstats-summary.bbclass
- INHERIT += "buildstats buildstats-summary"
- # be more strict with QA warnings, turn them all to errors:
- ERROR_QA_append = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
- WARN_QA_remove = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
- # enable thumb for broader test coverage (oe-core autobuilder doesn't have thumb enabled)
- PREFERRED_ARM_INSTRUCTION_SET ?= "thumb"
- ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}"
- # use musl for qemux86 and qemux86copy
- TCLIBC_qemux86 = "musl"
- TCLIBC_qemux86copy = "musl"
- # limit parallel make to avoid OOM
- PARALLEL_MAKE_pn-qtwebkit = "-j 8"
- filename: "{{.BuildDir}}/world_fixes.inc"
- fileMode: 420
- - type: WriteFile
- fileContents: |
#!/bin/bash -xe
git clone git://git.yoctoproject.org/poky --reference /mnt/yocto-cache/mirror/poky.git
(cd poky; git checkout ${POKY_SHA1})
@@ -159,7 +72,7 @@ build_instructions:
bitbake-layers add-layer ../meta-python2
bitbake-layers add-layer ${SOURCE_DIR}
- echo 'require ../world_fixes.inc' >> conf/local.conf
+ echo "require ${SOURCE_DIR}/coin/test-configs.inc" >> conf/local.conf
# EXCLUDE_FROM_WORLD
rm -f ${SOURCE_DIR}/recipes-qt/examples/qt5-opengles2-test_git.bb
diff --git a/coin/test-configs.inc b/coin/test-configs.inc
new file mode 100644
index 00000000..5fbc1d55
--- /dev/null
+++ b/coin/test-configs.inc
@@ -0,0 +1,83 @@
+# https://github.com/shr-project/jenkins-jobs/blob/master/jenkins-job.sh
+INHERIT += "reproducible_build_simple"
+# need space for dunfell build
+INHERIT += "rm_work"
+# We want musl and glibc to share the same tmpfs, so instead of appending default "-${TCLIBC}" we append "fs"
+TCLIBCAPPEND = "fs"
+PREFERRED_PROVIDER_udev = "systemd"
+PREFERRED_PROVIDER_virtual/fftw = "fftw"
+# use gold
+DISTRO_FEATURES_append = " ld-is-gold"
+# use ptest
+DISTRO_FEATURES_append = " ptest"
+# use systemd
+DISTRO_FEATURES_append = " systemd"
+DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
+VIRTUAL-RUNTIME_init_manager = "systemd"
+VIRTUAL-RUNTIME_initscripts = ""
+# use opengl
+DISTRO_FEATURES_append = " opengl"
+# use wayland to fix building weston and qtwayland
+DISTRO_FEATURES_append = " wayland"
+PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
+PREFERRED_PROVIDER_jpeg-native = "libjpeg-turbo-native"
+PREFERRED_PROVIDER_gpsd = "gpsd"
+PREFERRED_PROVIDER_e-wm-sysactions = "e-wm"
+ESYSACTIONS = "e-wm-sysactions"
+# don't pull libhybris unless explicitly asked for
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
+PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
+PREFERRED_PROVIDER_virtual/egl ?= "mesa"
+# to fix fsoaudiod, alsa-state conflict in shr-image-all
+VIRTUAL-RUNTIME_alsa-state = ""
+# to prevent alsa-state being pulled into -dev or -dbg images
+RDEPENDS_${PN}-dev_pn-alsa-state = ""
+RDEPENDS_${PN}-dbg_pn-alsa-state = ""
+# to fix dependency on conflicting x11-common from packagegroup-core-x11
+VIRTUAL-RUNTIME_xserver_common ?= "xserver-common"
+RDEPENDS_${PN}-dev_pn-x11-common = ""
+RDEPENDS_${PN}-dbg_pn-x11-common = ""
+# to fix apm, fso-apm conflict in shr-image-all
+VIRTUAL-RUNTIME_apm = "fso-apm"
+# require conf/distro/include/qt5-versions.inc
+# QT5_VERSION = "5.4.0+git%"
+# for qtwebkit etc
+# see https://bugzilla.yoctoproject.org/show_bug.cgi?id=5013
+# DEPENDS_append_pn-qtbase = " mesa"
+PACKAGECONFIG_append_pn-qtbase = " icu gl accessibility freetype fontconfig"
+# qtwayland doesn't like egl and xcomposite-glx enabled at the same time
+# http://lists.openembedded.org/pipermail/openembedded-devel/2016-December/110444.html
+PACKAGECONFIG_remove_pn-qtwayland = "xcomposite-egl xcomposite-glx"
+# for webkit-efl
+PACKAGECONFIG_append_pn-harfbuzz = " icu"
+inherit blacklist
+# PNBLACKLIST[samsung-rfs-mgr] = "needs newer libsamsung-ipc with negative D_P: Requested 'samsung-ipc-1.0 >= 0.2' but version of libsamsung-ipc is 0.1.0"
+PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds"
+PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much"
+PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much"
+PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
+PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
+PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much"
+PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/"
+# enable reporting
+# needs http://patchwork.openembedded.org/patch/68735/
+#ERR_REPORT_SERVER = "errors.yoctoproject.org"
+#ERR_REPORT_PORT = "80"
+#ERR_REPORT_USERNAME = "Martin Jansa"
+#ERR_REPORT_EMAIL = "Martin.Jansa@gmail.com"
+#ERR_REPORT_UPLOAD_FAILURES = "1"
+#INHERIT += "report-error"
+# needs patch with buildstats-summary.bbclass
+INHERIT += "buildstats buildstats-summary"
+# be more strict with QA warnings, turn them all to errors:
+ERROR_QA_append = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
+WARN_QA_remove = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
+# enable thumb for broader test coverage (oe-core autobuilder doesn't have thumb enabled)
+PREFERRED_ARM_INSTRUCTION_SET ?= "thumb"
+ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}"
+# use musl for qemux86 and qemux86copy
+TCLIBC_qemux86 = "musl"
+TCLIBC_qemux86copy = "musl"
+# limit parallel make to avoid OOM
+PARALLEL_MAKE_pn-qtwebkit = "-j 8"