aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-08 09:18:57 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-08 13:07:17 +0200
commit79029e538cebb72972e80b79dc596c122ad8c15b (patch)
tree987104cbb19fcd7d1d89fc1e08f545f40afd4ee9
parent60c8b35f13f0969a2244e5ab06333fc3994ed221 (diff)
parentd6fe20e6083d421cc6091892e1d302c46e2d075d (diff)
Merge remote-tracking branch 'meta-qt5/master' into HEAD
* meta-qt5/master: qtwebengine: enable ARMv7VE support Add .gitignore to ignore .pyc/.pyo files gdb: include readline in default PACKAGECONFIG libconnman-qt5: update to 1.0.98 qtwebkit: backport patch to fix linking with qtwebkit libconnman-qt5: remove blacklist qtbase: fix up pkgconfig replacements Conflicts: recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch Change-Id: I7dfa3f9828a9ef587676d4ce21e676679abc98ec
-rw-r--r--.gitignore2
-rw-r--r--recipes-devtools/gdb/gdb_%.bbappend2
-rw-r--r--recipes-qt/libconnman-qt/libconnman-qt5_git.bb6
-rw-r--r--recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch66
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
-rw-r--r--recipes-qt/qt5/qtwebkit/0004-Fix-linking-with-libpthread.patch33
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
7 files changed, 71 insertions, 40 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 00000000..52e4e611
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pyc
+*.pyo
diff --git a/recipes-devtools/gdb/gdb_%.bbappend b/recipes-devtools/gdb/gdb_%.bbappend
index 41592c41..3e663e71 100644
--- a/recipes-devtools/gdb/gdb_%.bbappend
+++ b/recipes-devtools/gdb/gdb_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG ??= "python"
+PACKAGECONFIG ??= "readline python"
diff --git a/recipes-qt/libconnman-qt/libconnman-qt5_git.bb b/recipes-qt/libconnman-qt/libconnman-qt5_git.bb
index 71c04df8..c9a81404 100644
--- a/recipes-qt/libconnman-qt/libconnman-qt5_git.bb
+++ b/recipes-qt/libconnman-qt/libconnman-qt5_git.bb
@@ -5,9 +5,9 @@ HOMEPAGE = "https://git.merproject.org/mer-core/libconnman-qt"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
DEPENDS += "qtbase qtdeclarative"
-PV = "1.0.97+git${SRCPV}"
+PV = "1.0.98+git${SRCPV}"
-SRCREV = "4cca434935fa4d70d6841a2c20717eecb0beafa8"
+SRCREV = "8d4580a55ca02b84fc3db374c6530e39c94e0d92"
SRC_URI = "git://git.merproject.org/mer-core/libconnman-qt.git;protocol=https"
S = "${WORKDIR}/git"
@@ -15,5 +15,3 @@ S = "${WORKDIR}/git"
inherit pkgconfig
RDEPENDS_${PN} += "connman"
-
-PNBLACKLIST[libconnman-qt5] ?= "BROKEN: QA Issue: connman-qt5.pc failed sanity test (tmpdir)"
diff --git a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch b/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
index d82fef21..4807df09 100644
--- a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
+++ b/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
@@ -1,7 +1,7 @@
-From 9d880bebf7efc83495487f8ea9a434956fe98eb0 Mon Sep 17 00:00:00 2001
+From db746d1ca0c41fe3da103d09fc240a0df9db5404 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 27 Apr 2013 23:15:37 +0200
-Subject: [PATCH] qt_module: Fix pkgconfig and libtool replacements
+Subject: [PATCH 04/10] qt_module: Fix pkgconfig and libtool replacements
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@@ -26,7 +26,7 @@ Content-Transfer-Encoding: 8bit
* qmake does not prefix them with QT_SYSROOT when using them
so e.g. when building qtdeclarative we get -L/usr/lib to LINKAGE
variable, which is unsafe for cross-compilation
-* writing QT_SYSROOT in .prl files is dangerous for sstate when
+* writting QT_SYSROOT in .prl files is dangerous for sstate when
builds are in different directories, so we need
SSTATE_SCAN_FILES += "*.pri *.prl"
to make them relocateble
@@ -61,11 +61,36 @@ Content-Transfer-Encoding: 8bit
Change-Id: Ie1c94b15f2a4e736b65b4d0924d99eb2a7d92a6c
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+Signed-off-by: Jonathan Liu <net147@gmail.com>
---
+ mkspecs/features/qt.prf | 13 +++++++++++++
mkspecs/features/qt_common.prf | 2 +-
- mkspecs/features/qt_module.prf | 11 +++++++++++
- 2 files changed, 12 insertions(+), 1 deletion(-)
+ 2 files changed, 14 insertions(+), 1 deletion(-)
+diff --git a/mkspecs/features/qt.prf b/mkspecs/features/qt.prf
+index f62b6bb..91be8b3 100644
+--- a/mkspecs/features/qt.prf
++++ b/mkspecs/features/qt.prf
+@@ -321,6 +321,19 @@ contains(TEMPLATE, .*app) {
+ QTPLUGIN = $$manualplugs $$autoplugs
+ }
+
++contains(TEMPLATE, .*lib) {
++ pkgconfig_prefix_replace.match = "prefix=$$[QT_SYSROOT]"
++ pkgconfig_prefix_replace.replace = "prefix="
++ pkgconfig_prefix_replace.CONFIG = path
++ QMAKE_PKGCONFIG_INSTALL_REPLACE += pkgconfig_prefix_replace
++
++ # drop -L/usr/lib in .prl files
++ prl_replace.match = "-L\$${libdir}"
++ prl_replace.replace = ""
++ prl_replace.CONFIG = path
++ QMAKE_PRL_INSTALL_REPLACE += prl_replace
++}
++
+ QT_PLUGIN_VERIFY = DEPLOYMENT_PLUGIN
+ contains(QT_CONFIG, static) {
+ QT_PLUGIN_VERIFY += QTPLUGIN
diff --git a/mkspecs/features/qt_common.prf b/mkspecs/features/qt_common.prf
index 38602f6..f9c401f 100644
--- a/mkspecs/features/qt_common.prf
@@ -79,35 +104,6 @@ index 38602f6..f9c401f 100644
}
lib_replace.CONFIG = path
QMAKE_PRL_INSTALL_REPLACE += lib_replace
-diff --git a/mkspecs/features/qt_module.prf b/mkspecs/features/qt_module.prf
-index fdce486..8e7a650 100644
---- a/mkspecs/features/qt_module.prf
-+++ b/mkspecs/features/qt_module.prf
-@@ -259,6 +259,11 @@ load(qt_targets)
- pclib_replace.replace = $$QMAKE_PKGCONFIG_LIBDIR
- pclib_replace.CONFIG = path
- QMAKE_PKGCONFIG_INSTALL_REPLACE += pclib_replace
-+
-+ pkgconfig_include_replace.match = $$rplbase/include
-+ pkgconfig_include_replace.replace = "\$$\\{includedir}"
-+ pkgconfig_include_replace.CONFIG = path
-+ QMAKE_PKGCONFIG_INSTALL_REPLACE += pkgconfig_include_replace
- }
- !lib_bundle:unix {
- CONFIG += create_libtool
-@@ -271,6 +276,12 @@ load(qt_targets)
- ltlib_replace.replace = $$QMAKE_LIBTOOL_LIBDIR
- ltlib_replace.CONFIG = path
- QMAKE_LIBTOOL_INSTALL_REPLACE += ltlib_replace
-+
-+ # drop -L/usr/lib in .prl files
-+ prl_replace.match = "-L\$${libdir}"
-+ prl_replace.replace = ""
-+ prl_replace.CONFIG = path
-+ QMAKE_PRL_INSTALL_REPLACE += prl_replace
- }
-
- contains(QT_PRODUCT, OpenSource.*):DEFINES *= QT_OPENSOURCE
--
-1.9.1
+2.7.1
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 30168f43..32a6459d 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -47,6 +47,7 @@ COMPATIBLE_MACHINE_x86 = "(.*)"
COMPATIBLE_MACHINE_x86-64 = "(.*)"
COMPATIBLE_MACHINE_armv6 = "(.*)"
COMPATIBLE_MACHINE_armv7a = "(.*)"
+COMPATIBLE_MACHINE_armv7ve = "(.*)"
inherit qmake5
inherit gettext
diff --git a/recipes-qt/qt5/qtwebkit/0004-Fix-linking-with-libpthread.patch b/recipes-qt/qt5/qtwebkit/0004-Fix-linking-with-libpthread.patch
new file mode 100644
index 00000000..c5e6ac52
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0004-Fix-linking-with-libpthread.patch
@@ -0,0 +1,33 @@
+From 5dd4bb67cfce812fd7686e43616e2069f354a7df Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
+Date: Mon, 22 Feb 2016 10:57:32 +0100
+Subject: [PATCH] Fix linking with libpthread
+
+WebKit use libpthread directly but is depending on other qt modules
+causing it to be linked against, which might break unless -lpthread
+is last. Instead just add it explicitly after the static libraries.
+
+Upstream-Status: Backport from 5.7 branch
+
+Change-Id: I2b95cff2c96373f8dce6f95052c4fccbe1982b33
+Reviewed-by: Simon Hausmann <simon.hausmann@theqtcompany.com>
+Signed-off-by: Jonathan Liu <net147@gmail.com>
+---
+ Tools/qmake/mkspecs/features/default_post.prf | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Tools/qmake/mkspecs/features/default_post.prf b/Tools/qmake/mkspecs/features/default_post.prf
+index 67276b7..39bb3f7 100644
+--- a/Tools/qmake/mkspecs/features/default_post.prf
++++ b/Tools/qmake/mkspecs/features/default_post.prf
+@@ -201,6 +201,7 @@ needToLink() {
+ linkAgainstLibrary($$library, $$eval(WEBKIT.$${library_identifier}.root_source_dir))
+ LIBS += $$eval(WEBKIT.$${library_identifier}.dependent_libs)
+ }
++ posix:!darwin: LIBS += -lpthread
+ }
+
+ creating_module {
+--
+2.7.1
+
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 9044d4fb..04cefada 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -22,6 +22,7 @@ SRC_URI += "\
file://0001-qtwebkit-fix-QA-issue-bad-RPATH.patch \
file://0002-Remove-TEXTREL-tag-in-x86.patch \
file://0003-Exclude-backtrace-API-for-non-glibc-libraries.patch \
+ file://0004-Fix-linking-with-libpthread.patch \
"
PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel"