aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2017-01-25 13:26:13 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-20 14:40:16 +0100
commitac0d613302db8f7f013bbb0c72b30cdea4bb72c3 (patch)
treec399e22cd5391f11d2fd1c26316112e359df45f8
parent2b1871f0d139dc3caaa779a32a1931409c245a36 (diff)
cmake_qt5.bbclass: add qtbase-native to DEPENDS
When building with recipe-specific-sysroot's, qmake can't be found: | CMake Error at WORKDIR/recipe-sysroot/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:32 (message): | The imported target Qt5::Core references the file | | WORKDIR/recipe-sysroot-native/usr/bin/qt5/qmake | | but this file does not exist. Possible reasons include: | | * The file was deleted, renamed, or moved to another location. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and contained | | WORKDIR/recipe-sysroot/usr/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake | | but not all the files it references. | | Call Stack (most recent call first): | WORKDIR/recipe-sysroot/usr/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake:6 (_qt5_Core_check_file_exists) | WORKDIR/recipe-sysroot/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:163 (include) | WORKDIR/recipe-sysroot/usr/lib/cmake/Qt5/Qt5Config.cmake:31 (find_package) | CMakeLists.txt:56 (find_package) | This is solved by adding qtbase-native to the exported DEPENDS. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/cmake_qt5.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/classes/cmake_qt5.bbclass b/classes/cmake_qt5.bbclass
index 3180fd6d..5d605a68 100644
--- a/classes/cmake_qt5.bbclass
+++ b/classes/cmake_qt5.bbclass
@@ -1,7 +1,7 @@
inherit cmake
inherit qmake5_paths
-DEPENDS_prepend = "qtbase "
+DEPENDS_prepend = "qtbase qtbase-native "
EXTRA_OECMAKE_prepend = " \
-DOE_QMAKE_PATH_PREFIX=${OE_QMAKE_PATH_PREFIX} \