aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-06-02 10:06:10 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-06-03 10:51:00 +0000
commitce9a8d9537e3baa7d485128a3f41451d7dca7770 (patch)
tree030caf1f9db4c7764cebffef9a82d56795681c27
parentafb62012ec358e12fcad06e8096be1f6ec13f1ba (diff)
qt5: update submodules
NIS support leftover from Qt 3/4 were removed from qtbase with commit 644d0e75240811212ed9fd0c21e3bd05db3ba5db Change-Id: I335ef269126b89064a5038e0d200faf72a36bddf Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb3
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch68
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtenginio_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch14
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebkit-examples_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
33 files changed, 73 insertions, 76 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index eec21e47..9d276a67 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -150,7 +150,6 @@ do_configure() {
-no-gif \
-no-accessibility \
-no-cups \
- -no-nis \
-no-gui \
-no-qml-debug \
-no-sql-mysql \
@@ -239,4 +238,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "cec15a89d058424794978910cc8da65b43d71606"
+SRCREV = "6bcd27b957a5ffcfe7665b0979679510e3b2ae3d"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index a96b06cf..496051d0 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -27,6 +27,6 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/*/*/*.obj \
"
-SRCREV = "7a208d76ed96bb506899becfe680df06f95451c7"
+SRCREV = "0384f29809186e6a45b13760c9dbb2f8cd3bf251"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 4e093520..65054d28 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -45,7 +45,6 @@ PACKAGECONFIG_CONFARGS = " \
-no-gif \
-no-accessibility \
-no-cups \
- -no-nis \
-no-gui \
-no-qml-debug \
-no-sql-mysql \
@@ -115,4 +114,4 @@ do_install() {
ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
}
-SRCREV = "cec15a89d058424794978910cc8da65b43d71606"
+SRCREV = "6bcd27b957a5ffcfe7665b0979679510e3b2ae3d"
diff --git a/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch b/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch
index bdacb469..edd5d9a9 100644
--- a/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch
+++ b/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch
@@ -1,4 +1,4 @@
-From eb70e52aa796576daa73027c93f2fba77861e4e2 Mon Sep 17 00:00:00 2001
+From 4b7a986512e5f3accbca6010829e7e094d53ac29 Mon Sep 17 00:00:00 2001
From: David Schulz <david.schulz@theqtcompany.com>
Date: Mon, 12 Oct 2015 09:55:30 +0200
Subject: [PATCH] configure: Separate host and build platform.
@@ -51,7 +51,7 @@ index c50bd8b..cfb47de 100755
ARCH=""
diff --git a/config.tests/unix/compile.test b/config.tests/unix/compile.test
-index 598e2a2..b33b74c 100755
+index 598e2a2..f92560f 100755
--- a/config.tests/unix/compile.test
+++ b/config.tests/unix/compile.test
@@ -10,7 +10,9 @@ OUTDIR=$5
@@ -76,10 +76,10 @@ index 598e2a2..b33b74c 100755
-spec "$QMKSPEC" \
"CONFIG+=$QMAKE_CONFIG" \
diff --git a/configure b/configure
-index f833869..0d5cae0 100755
+index d5214bf..0334dfc 100755
--- a/configure
+++ b/configure
-@@ -104,9 +104,11 @@ QT_CONFIG=
+@@ -105,9 +105,11 @@ QT_CONFIG=
SUPPORTED=
QMAKE_VARS_FILE=.qmake.vars
DEVICE_VARS_FILE=.device.vars
@@ -91,7 +91,7 @@ index f833869..0d5cae0 100755
#-------------------------------------------------------------------------------
# utility functions
-@@ -195,15 +197,15 @@ expandQMakeConf()
+@@ -196,15 +198,15 @@ expandQMakeConf()
echo "WARNING: Unable to find file $conf_file" >&2
continue
fi
@@ -110,7 +110,7 @@ index f833869..0d5cae0 100755
;;
*)
echo "$line"
-@@ -336,7 +338,7 @@ macSDKify()
+@@ -337,7 +339,7 @@ macSDKify()
getQMakeConf()
{
if [ -z "$specvals" ]; then
@@ -119,7 +119,7 @@ index f833869..0d5cae0 100755
if [ "$BUILD_ON_MAC" = "yes" ]; then specvals=$(macSDKify "$specvals"); fi
fi
getSingleQMakeVariable "$1" "$specvals"
-@@ -355,7 +357,7 @@ getQEvalMakeConf()
+@@ -356,7 +358,7 @@ getQEvalMakeConf()
getXQMakeConf()
{
if [ -z "$xspecvals" ]; then
@@ -128,7 +128,7 @@ index f833869..0d5cae0 100755
if [ "$XPLATFORM_MAC" = "yes" ]; then xspecvals=$(macSDKify "$xspecvals"); fi
fi
getSingleQMakeVariable "$1" "$xspecvals"
-@@ -498,6 +500,23 @@ resolveDeviceMkspec()
+@@ -514,6 +516,23 @@ resolveDeviceMkspec()
}
#-------------------------------------------------------------------------------
@@ -152,7 +152,7 @@ index f833869..0d5cae0 100755
# operating system detection
#-------------------------------------------------------------------------------
-@@ -522,12 +541,10 @@ BUILD_ON_MAC=no
+@@ -538,12 +557,10 @@ BUILD_ON_MAC=no
if [ -d /System/Library/Frameworks/Carbon.framework ]; then
BUILD_ON_MAC=yes
fi
@@ -165,7 +165,7 @@ index f833869..0d5cae0 100755
DEV_NULL=/tmp/empty-file
echo "" > $DEV_NULL
relpath=`(cd "$relpath"; pwd -W)`
-@@ -932,6 +949,7 @@ while [ "$#" -gt 0 ]; do
+@@ -948,6 +965,7 @@ while [ "$#" -gt 0 ]; do
-hostlibdir| \
-extprefix| \
-sysroot| \
@@ -173,7 +173,7 @@ index f833869..0d5cae0 100755
-depths| \
-make| \
-nomake| \
-@@ -940,6 +958,7 @@ while [ "$#" -gt 0 ]; do
+@@ -956,6 +974,7 @@ while [ "$#" -gt 0 ]; do
-xplatform| \
-device| \
-device-option| \
@@ -181,7 +181,7 @@ index f833869..0d5cae0 100755
-sdk| \
-arch| \
-host-arch| \
-@@ -1259,6 +1278,10 @@ while [ "$#" -gt 0 ]; do
+@@ -1275,6 +1294,10 @@ while [ "$#" -gt 0 ]; do
gcc-sysroot)
CFG_GCC_SYSROOT="$VAL"
;;
@@ -192,7 +192,7 @@ index f833869..0d5cae0 100755
bindir)
QT_INSTALL_BINS="$VAL"
;;
-@@ -1433,6 +1456,11 @@ while [ "$#" -gt 0 ]; do
+@@ -1449,6 +1472,11 @@ while [ "$#" -gt 0 ]; do
DEV_VAL=`echo $VAL | cut -d '=' -f 2-`
DeviceVar set $DEV_VAR "$DEV_VAL"
;;
@@ -204,7 +204,7 @@ index f833869..0d5cae0 100755
qpa)
QT_QPA_DEFAULT_PLATFORM="$VAL"
;;
-@@ -2683,6 +2711,8 @@ Additional options:
+@@ -2699,6 +2727,8 @@ Additional options:
-device-option <key=value> ... Add device specific options for the device mkspec
(experimental)
@@ -213,7 +213,7 @@ index f833869..0d5cae0 100755
* -no-separate-debug-info . Do not store debug information in a separate file.
-separate-debug-info .... Strip debug information into a separate file.
-@@ -2714,6 +2744,9 @@ Additional options:
+@@ -2730,6 +2760,9 @@ Additional options:
-sysroot <dir> ...... Sets <dir> as the target compiler's and qmake's sysroot and also sets pkg-config paths.
-no-gcc-sysroot ..... When using -sysroot, it disables the passing of --sysroot to the compiler
@@ -223,7 +223,7 @@ index f833869..0d5cae0 100755
-no-feature-<feature> Do not compile in <feature>.
-feature-<feature> .. Compile in <feature>. The available features
are described in src/corelib/global/qfeatures.txt
-@@ -3280,7 +3313,7 @@ if [ -d "$XPLATFORM" ]; then
+@@ -3296,7 +3329,7 @@ if [ -d "$XPLATFORM" ]; then
else
XQMAKESPEC="$relpath/mkspecs/${XPLATFORM}"
fi
@@ -232,17 +232,17 @@ index f833869..0d5cae0 100755
QT_CROSS_COMPILE=yes
QMAKE_CONFIG="$QMAKE_CONFIG cross_compile"
QTCONFIG_CONFIG="$QTCONFIG_CONFIG cross_compile"
-@@ -4059,7 +4092,8 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
- EXTRA_LFLAGS="\$(QMAKE_LFLAGS_RPATH)\"$rpath\" $EXTRA_LFLAGS"
- done
+@@ -4069,7 +4102,8 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
+ EXTRA_CXXFLAGS="$EXTRA_CXXFLAGS \$(QMAKE_CXXFLAGS_DEBUG)"
fi
+
- if [ "$BUILD_ON_MSYS" = "yes" ]; then
+ case `basename "$PLATFORM"` in
+ win32-g++*)
EXTRA_CFLAGS="$EXTRA_CFLAGS -DUNICODE"
EXTRA_CXXFLAGS="$EXTRA_CXXFLAGS -DUNICODE"
EXTRA_OBJS="qfilesystemengine_win.o \
-@@ -4078,7 +4112,8 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
+@@ -4088,7 +4122,8 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
\"\$(SOURCE_PATH)/tools/shared/windows/registry.cpp\""
EXTRA_LFLAGS="$EXTRA_LFLAGS -static -s -lole32 -luuid -ladvapi32 -lkernel32"
EXEEXT=".exe"
@@ -252,7 +252,7 @@ index f833869..0d5cae0 100755
EXTRA_OBJS="qfilesystemengine_unix.o \
qfilesystemiterator_unix.o \
qfsfileengine_unix.o \
-@@ -4088,8 +4123,8 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
+@@ -4098,8 +4133,8 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
\"\$(SOURCE_PATH)/src/corelib/io/qfsfileengine_unix.cpp\" \
\"\$(SOURCE_PATH)/src/corelib/tools/qlocale_unix.cpp\""
EXEEXT=
@@ -263,15 +263,15 @@ index f833869..0d5cae0 100755
if [ "$BUILD_ON_MAC" = "yes" ]; then
echo "COCOA_LFLAGS =-framework Foundation -framework CoreServices" >>"$mkfile"
echo "CARBON_LFLAGS =-framework ApplicationServices" >>"$mkfile"
-@@ -4110,6 +4145,7 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
- if [ '!' -z "$D_FLAGS" ]; then
- EXTRA_CFLAGS="$EXTRA_CFLAGS $D_FLAGS"
+@@ -4117,6 +4152,7 @@ if true; then ###[ '!' -f "$outpath/bin/qmake" ];
+ \"\$(SOURCE_PATH)/src/corelib/kernel/qcore_mac.cpp\" \
+ \"\$(SOURCE_PATH)/src/corelib/kernel/qcore_mac_objc.mm\""
fi
+
echo >>"$mkfile"
adjrelpath=`echo "$relpath" | sed 's/ /\\\\\\\\ /g'`
adjoutpath=`echo "$outpath" | sed 's/ /\\\\\\\\ /g'`
-@@ -4179,7 +4215,81 @@ QTCONFFILE="$outpath/bin/qt.conf"
+@@ -4186,7 +4222,81 @@ QTCONFFILE="$outpath/bin/qt.conf"
cat > "$QTCONFFILE" <<EOF
[EffectivePaths]
Prefix=..
@@ -353,7 +353,7 @@ index f833869..0d5cae0 100755
if [ x"$relpath" != x"$outpath" ]; then
cat >> "$QTCONFFILE" <<EOF
[EffectiveSourcePaths]
-@@ -4187,6 +4297,9 @@ Prefix=$relpath
+@@ -4194,6 +4304,9 @@ Prefix=$relpath
EOF
fi
@@ -363,7 +363,7 @@ index f833869..0d5cae0 100755
#-------------------------------------------------------------------------------
# write out device config before we run the test.
#-------------------------------------------------------------------------------
-@@ -4199,9 +4312,20 @@ else
+@@ -4206,9 +4319,20 @@ else
fi
#-------------------------------------------------------------------------------
@@ -385,7 +385,7 @@ index f833869..0d5cae0 100755
if [ $? != "0" ]; then
echo "Failed to process makespec for platform '$XPLATFORM'"
if [ "$OPT_VERBOSE" = "yes" ]; then
-@@ -4217,7 +4341,7 @@ fi
+@@ -4224,7 +4348,7 @@ fi
#-------------------------------------------------------------------------------
if [ -z "$PKG_CONFIG" ]; then
# See if PKG_CONFIG is set in the mkspec:
@@ -394,7 +394,7 @@ index f833869..0d5cae0 100755
[ -n "$PKG_CONFIG" ] && [ "$OPT_VERBOSE" = "yes" ] && echo "Found pkg-config from mkspec: $PKG_CONFIG"
fi
if [ -z "$PKG_CONFIG" ]; then
-@@ -4292,7 +4416,7 @@ compileTest()
+@@ -4299,7 +4423,7 @@ compileTest()
if [ "$CFG_SHARED" = "no" ]; then
test_config="$QMAKE_CONFIG static"
fi
@@ -403,7 +403,7 @@ index f833869..0d5cae0 100755
}
compileTestWithPkgConfig()
-@@ -4341,7 +4465,7 @@ compileTestWithPkgConfig()
+@@ -4348,7 +4472,7 @@ compileTestWithPkgConfig()
# Use config.tests/arch/arch.pro to have the compiler tell us what the target architecture is
OUTFILE=$outpath/arch.result
@@ -412,7 +412,7 @@ index f833869..0d5cae0 100755
if [ $? -eq 0 ]; then
eval `cat "$OUTFILE"`
else
-@@ -4354,7 +4478,7 @@ rm -f "$OUTFILE" 2>/dev/null
+@@ -4361,7 +4485,7 @@ rm -f "$OUTFILE" 2>/dev/null
if [ "$QMAKESPEC" != "$XQMAKESPEC" ]; then
# Do the same test again, using the host compiler
@@ -421,7 +421,7 @@ index f833869..0d5cae0 100755
if [ $? -eq 0 ]; then
eval `cat "$OUTFILE"`
else
-@@ -4570,7 +4694,7 @@ fi
+@@ -4577,7 +4701,7 @@ fi
# detect mips_dsp support
if [ "$CFG_ARCH" = "mips" ] && [ "${CFG_MIPS_DSP}" = "auto" ]; then
@@ -430,7 +430,7 @@ index f833869..0d5cae0 100755
CFG_MIPS_DSP=yes
else
CFG_MIPS_DSP=no
-@@ -4581,7 +4705,7 @@ fi
+@@ -4588,7 +4712,7 @@ fi
# detect mips_dspr2 support
if [ "$CFG_ARCH" = "mips" ] && [ "${CFG_MIPS_DSPR2}" = "auto" ]; then
@@ -439,7 +439,7 @@ index f833869..0d5cae0 100755
CFG_MIPS_DSPR2=yes
else
CFG_MIPS_DSPR2=no
-@@ -7471,7 +7595,7 @@ rm -f "$QMAKE_VARS_FILE" 2>/dev/null
+@@ -7482,7 +7606,7 @@ rm -f "$QMAKE_VARS_FILE" 2>/dev/null
cd ..
fi
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index d0809c31..c99eddd2 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -123,7 +123,6 @@ PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev"
PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
PACKAGECONFIG[alsa] = "-alsa,-no-alsa,alsa-lib"
PACKAGECONFIG[pulseaudio] = "-pulseaudio,-no-pulseaudio,pulseaudio"
-PACKAGECONFIG[nis] = "-nis,-no-nis"
PACKAGECONFIG[widgets] = "-widgets,-no-widgets"
PACKAGECONFIG[libproxy] = "-libproxy,-no-libproxy,libproxy"
PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"
@@ -249,4 +248,4 @@ sysroot_stage_dirs_append() {
rm -rf $to${OE_QMAKE_PATH_QT_FONTS}
}
-SRCREV = "cec15a89d058424794978910cc8da65b43d71606"
+SRCREV = "6bcd27b957a5ffcfe7665b0979679510e3b2ae3d"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 5b12d1a7..b28bab0c 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "791ddce7d41b126ba4744a6701597f49dbf99f3b"
+SRCREV = "1a19a68e76205650b55fea48477deb95bf328412"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 03990d85..a4686729 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -25,4 +25,4 @@ do_configure_prepend() {
sed -i 's/^qtCompileTest(bluez)/OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtconnectivity.pro
}
-SRCREV = "dedff12a896d51c469d2af82664b86a10f8fa7fe"
+SRCREV = "a084e2160a345162681af984d9c265f619be7124"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index fb957bb5..f44be8b6 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -39,6 +39,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "26ff8f9029107877bfbfdc2f099f9b11861183ed"
+SRCREV = "dbf7efde1e04ac0ff445f64438078d87eb035b68"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtenginio_git.bb b/recipes-qt/qt5/qtenginio_git.bb
index 04f5a79d..0f37e9a5 100644
--- a/recipes-qt/qt5/qtenginio_git.bb
+++ b/recipes-qt/qt5/qtenginio_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
-SRCREV = "cf717b99fdb1b7221dd556bf3be32feba0ed8afe"
+SRCREV = "d5aec18177acc122b0b7c39a90fbb09d388a01b3"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 606b873a..9e2d5e6d 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -17,4 +17,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "6523d7c4843e1d4176035c46e1514c39bdcfc3bf"
+SRCREV = "35179f6b3116f1cee4586faa7c4f751e6d2e00af"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 573b3303..9cc7a3c7 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -28,4 +28,4 @@ EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'jasper', 'CONFIG+
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'libtiff', 'CONFIG+=OE_LIBTIFF_ENABLED', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'libwebp', 'CONFIG+=OE_LIBWEBP_ENABLED', '', d)}"
-SRCREV = "bf5b49878d75d316f31225f76152e8381a3d5f0f"
+SRCREV = "6415dae76eb8586f6e520961a76996df2425476d"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 8a41551b..b6f6af0b 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -29,4 +29,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'geoclue', 'CONFIG+=OE_GEOCLUE_ENABLED', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'gypsy', 'CONFIG+=OE_GYPSY_ENABLED', '', d)}"
-SRCREV = "d1f66746ab0b77b4f3300cbeeaafe61d25d78e98"
+SRCREV = "f897775850dfbe0e668e9c8b428537e8bb096c01"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 328fdd74..5c176d07 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -35,4 +35,4 @@ SRC_URI += "\
file://0001-Initial-porting-effort-to-GStreamer-1.0.patch \
"
-SRCREV = "2170a3b0fcda613daf76a337fa45cb97e0714cdf"
+SRCREV = "6d5f375644624b977b168928ae09227a9d28547f"
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index 61b02a17..d5239749 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -23,4 +23,4 @@ do_configure_prepend() {
sed -i 's#^qtHaveModule(webkitwidgets):#enable-webkit:qtHaveModule(webkitwidgets):#g' ${S}/src/imports/imports.pro
}
-SRCREV = "563ce3888f3c04abcc96ba236b20c7a822bc88e2"
+SRCREV = "212653fea189ad1f5203fe2b5c12caba6f13c72a"
diff --git a/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch b/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch
index c57943d9..9ad92a1c 100644
--- a/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch
+++ b/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch
@@ -1,4 +1,4 @@
-From d5faf29f8a41b0e28132fb23828cff8043174cb8 Mon Sep 17 00:00:00 2001
+From 00bb7694b9287f23d4d059ae134e9409db69673e Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Thu, 31 Mar 2016 19:57:01 -0400
Subject: [PATCH] texteditor: fix invalid use of incomplete type 'class QDebug'
@@ -7,14 +7,14 @@ Upstream-Status: Pending
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
---
- examples/quick/controls/texteditor/src/documenthandler.cpp | 1 +
+ examples/quickcontrols/controls/texteditor/src/documenthandler.cpp | 1 +
1 file changed, 1 insertion(+)
-diff --git a/examples/quick/controls/texteditor/src/documenthandler.cpp b/examples/quick/controls/texteditor/src/documenthandler.cpp
-index 2e03f74..3d1b3c8 100644
---- a/examples/quick/controls/texteditor/src/documenthandler.cpp
-+++ b/examples/quick/controls/texteditor/src/documenthandler.cpp
-@@ -44,6 +44,7 @@
+diff --git a/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp b/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp
+index bdecf5b..811a761 100644
+--- a/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp
++++ b/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp
+@@ -54,6 +54,7 @@
#include <QtGui/QTextCursor>
#include <QtGui/QFontDatabase>
#include <QtCore/QFileInfo>
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index e3c580fe..22316297 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -12,4 +12,4 @@ DEPENDS += "qtdeclarative"
FILES_${PN}-qmlplugins += "${libdir}/qt5/qml/Qt"
-SRCREV = "ac152bfcd37f94453e9705b57ca6520ad30bade0"
+SRCREV = "f3212709f2cb19f61f09ba551934101800586d1a"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 7a5ca233..0912169f 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "01e52200e2a76ec51c3bb9710617ac0c249a78bc"
+SRCREV = "7e33119c487b6ce7ee1b7e8fc7b9b862adba1c91"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 565ca843..d3d421fb 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -27,4 +27,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "b16873afea798d08799d7a0b255b8d200337f35b"
+SRCREV = "76b5b0c3598a595c61f0cb274b392feeaf3e8dc3"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 16c20956..4d6dfa88 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "0b00ee6f6c311a7f5c0b4f2441dad97a454d172e"
+SRCREV = "6189199557a2b8eb981f37e6370b47c25b224b4e"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 4139db1f..d2dd424f 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "9a70ee2389d3302f6a4262325f8a76e4d867b478"
+SRCREV = "9c9255eda50af191636ff9f18df35567c307dd8c"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 6c300e5b..49b7c38f 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "e02df9c098b4d304b34c0ff65806a0576e45ed1a"
+SRCREV = "600ae02bce34b5cd56c1ddc99553bf661ae96b1a"
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 8cbe0e0c..656895ef 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -33,4 +33,4 @@ QT_MODULE_BRANCH = "dev"
# qtsystems wasn't released yet, last tag before this SRCREV is 5.0.0-beta1
# qt5-git PV is only to indicate that this recipe is compatible with qt5 5.6
-SRCREV = "236b6b544fd2049eb46e8f79d13bb7aa35ba002f"
+SRCREV = "cc2077700bd5503d1fcf53aef83cbb76975e745a"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index e0b23b4b..bc06d7fa 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -31,6 +31,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}"
-SRCREV = "e33532e048fa12ee32429ca83ee31aa8f065147d"
+SRCREV = "ec575c44637744413b106388cd0ed1d399fc7871"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 93b147d8..0f30e9b6 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -114,4 +114,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "13f1f2f12ddfc9b84535361d77a5f0f0ec8c3e0f"
+SRCREV = "674d2ca9f7c51f3621c9e2b36c9f02528dd23d40"
diff --git a/recipes-qt/qt5/qtwayland-native_git.bb b/recipes-qt/qt5/qtwayland-native_git.bb
index 1fd51685..6122db41 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bb
+++ b/recipes-qt/qt5/qtwayland-native_git.bb
@@ -25,4 +25,4 @@ do_install() {
oe_runmake install INSTALL_ROOT=${D}
}
-SRCREV = "26e27845a43319d0ecad0c6392f05d1ed50da2a2"
+SRCREV = "d9132f078bb168a9a013b97493c219596cc8c6b2"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index a1cee864..63913b57 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -36,4 +36,4 @@ SRC_URI += " \
file://0001-examples-wayland-include-server-buffer-only-when-bui.patch \
"
-SRCREV = "26e27845a43319d0ecad0c6392f05d1ed50da2a2"
+SRCREV = "d9132f078bb168a9a013b97493c219596cc8c6b2"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index 79c6b23f..7288b0ad 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "64a106da72796377bbff5cce0ecc5a379b105498"
+SRCREV = "bec50124b893c4632829d9806f49f64c4debf936"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index bc358ef5..a20c0b7f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -119,8 +119,8 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "643aa579fc94933eefa8eb20af6729e2140cf480"
-SRCREV_chromium = "8252b18aa3efa52138e91f9756945afb142a1c8c"
+SRCREV_qtwebengine = "f531565348e550bc2e03917874009331556f0d66"
+SRCREV_chromium = "19e3d1d3af80efee4377a4e5fcb9c214dba5be4e"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb
index 933220de..3f1ab500 100644
--- a/recipes-qt/qt5/qtwebkit-examples_git.bb
+++ b/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -19,4 +19,4 @@ DEPENDS += "qtwebkit qtxmlpatterns"
RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}"
-SRCREV = "1b9a0fc9d1ded4f4f11b04eb0bb7d1de82d6eb34"
+SRCREV = "2a143bf81b2ffb3bd7a5f47cf719e6ed347bf383"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index eb05ce24..753246a2 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -71,4 +71,4 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db
RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }"
export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
-SRCREV = "71136c9621103522e85654c8e144d5f1c961de1c"
+SRCREV = "da5f9d788f96340a44083ed4e28cdf6ea0a393f0"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 66d9d741..f289d26e 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "ba9306ec5a1271275d79b2f48ceb227f79352f33"
+SRCREV = "10cad9ece2cb380e26e03a1c03b900f8e3b4c801"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index d8beb500..ce9e4541 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "f27489d66cc6d8263130451c26c7e4ae40acc6b4"
+SRCREV = "36ae961b08420f14d7ad52ee5dc23ea456accfd9"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index d78df146..9008d700 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -13,6 +13,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "5e6acdb2ea92add793835561e7a2d6b0ed8890f8"
+SRCREV = "64e5f2be2ba63aa1ed04291dc529f2b8edee9a0b"
BBCLASSEXTEND =+ "native nativesdk"