aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-19 11:08:27 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-02 15:16:52 +0200
commit9758a7aff69fde12b7b2cf82f1934edd6abc9e77 (patch)
tree0128a731a8867c1be6fa48311591921660a15df1
parentbf2cafa909a27250f853a823e9d7101307337e7a (diff)
qtbase: Remove unsupported options xvideo, xinerama, xinput, gtkstyle
* xvideo and xinerama were removed in: commit e824abd987d77efaa085fe1f9fb514d270798d55 Author: Alexander Volkov <a.volkov@rusbitech.ru> Date: Tue Oct 13 18:43:25 2015 +0300 configure: Remove unused options -xvideo and -xinerama -xvideo was not used even by Qt 4 for a long time. -xinerama was used by the xlib plugin which was dropped by e6a7a6a381c0b61a93a642b425ecbcd714fd1c29. * xinput was removed in: commit fa8dbbff8895e7e1fdf1e6b0a9f3d821cd2caf2f Author: Alexander Volkov <a.volkov@rusbitech.ru> Date: Thu Oct 8 18:19:39 2015 +0300 configure: Remove -xinput option It's obsolete since e6a7a6a381c0b61a93a642b425ecbcd714fd1c29 (Remove xlib plugin) and a2337f79ffd229aa1e91f6bfec6294570eb3fe44 (Remove Windows and X11 from src/widgets/platforms). The actual option is -xinput2. * gtkstyle was removed (partially replaced with gtk) in: commit 899a815414e95da8d9429a4a4f4d7094e49cfc55 Author: Dmitry Shachnev <mitya57@gmail.com> Date: Thu Jul 30 21:32:43 2015 +0300 Remove gtk2 style from qtbase, it will be moved to qtstyleplugins This will allow us to drop gtk2 support from qtbase in future, while still providing the gtk2 style for those who want to use it. Also with moving to qtstyleplugins, the code can be simplified because we can directly link to libraries we need, instead of using QLibrary. [ChangeLog][QtWidgets] Remove QGtkStyle, it is now provided in qtstyleplugins repository. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 051ec89d..42a57e84 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -36,7 +36,7 @@ RDEPENDS_${PN}-tools += "perl"
PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
-PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xvideo xsync xshape xrender xrandr xfixes xinput2 xinput xinerama xcursor glib gtkstyle xkb', '', d)}"
+PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xsync xshape xrender xrandr xfixes xinput2 xcursor glib xkb', '', d)}"
PACKAGECONFIG_FONTS ?= ""
PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib"
PACKAGECONFIG_MULTIMEDIA ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
@@ -96,15 +96,12 @@ PACKAGECONFIG[sql-db2] = "-sql-db2,-no-sql-db2"
PACKAGECONFIG[sql-sqlite2] = "-sql-sqlite2,-no-sql-sqlite2,sqlite"
PACKAGECONFIG[sql-sqlite] = "-sql-sqlite -system-sqlite,-no-sql-sqlite,sqlite3"
PACKAGECONFIG[xcursor] = "-xcursor,-no-xcursor,libxcursor"
-PACKAGECONFIG[xinerama] = "-xinerama,-no-xinerama,libxinerama"
-PACKAGECONFIG[xinput] = "-xinput,-no-xinput"
PACKAGECONFIG[xinput2] = "-xinput2,-no-xinput2,libxi"
PACKAGECONFIG[xfixes] = "-xfixes,-no-xfixes,libxfixes"
PACKAGECONFIG[xrandr] = "-xrandr,-no-xrandr,libxrandr"
PACKAGECONFIG[xrender] = "-xrender,-no-xrender,libxrender"
PACKAGECONFIG[xshape] = "-xshape,-no-xshape"
PACKAGECONFIG[xsync] = "-xsync,-no-xsync"
-PACKAGECONFIG[xvideo] = "-xvideo,-no-xvideo"
PACKAGECONFIG[openvg] = "-openvg,-no-openvg"
PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv"
PACKAGECONFIG[xkb] = "-xkb,-no-xkb -no-xkbcommon,libxkbcommon"
@@ -113,7 +110,7 @@ PACKAGECONFIG[evdev] = "-evdev,-no-evdev"
PACKAGECONFIG[mtdev] = "-mtdev,-no-mtdev,mtdev"
# depends on glib
PACKAGECONFIG[fontconfig] = "-fontconfig,-no-fontconfig,fontconfig"
-PACKAGECONFIG[gtkstyle] = "-gtkstyle,-no-gtkstyle,gtk+"
+PACKAGECONFIG[gtk] = "-gtk,-no-gtk,gtk+"
PACKAGECONFIG[directfb] = "-directfb,-no-directfb,directfb"
PACKAGECONFIG[linuxfb] = "-linuxfb,-no-linuxfb"
PACKAGECONFIG[mitshm] = "-mitshm,-no-mitshm,mitshm"