aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Pointner <johannes.pointner@br-automation.com>2016-08-10 16:50:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-31 19:11:59 +0200
commitc2ddf663e22937cb64a7fb343892806d473b978f (patch)
tree4f45cae6cd6308fe05c52b09084fc044e172aeaa
parentd9cd5ede502ddf04767d5531340b12050ee7f899 (diff)
qtbase: Fix build with QT_NO_OPENGL
This fixes the build of qtbase without opengl support Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch33
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch b/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch
new file mode 100644
index 00000000..7b681dce
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0013-Fix-build-with-QT_NO_OPENGL.patch
@@ -0,0 +1,33 @@
+From 2e176e3d10535e4fdaa6ecc919538f66f4a2930d Mon Sep 17 00:00:00 2001
+From: Andy Nichols <andy.nichols@qt.io>
+Date: Mon, 11 Jul 2016 09:18:33 +0200
+Subject: QWidgetBackingStore: Fix build with QT_NO_OPENGL
+
+A define moved out of the #ifndef QT_NO_OPENGL scope.
+
+Change-Id: I41c943b97f165b5171581e01f3a4b2d3fb25747e
+Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
+
+Upstream-Status: Backport
+Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com>
+---
+ src/widgets/kernel/qwidgetbackingstore.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/widgets/kernel/qwidgetbackingstore.cpp b/src/widgets/kernel/qwidgetbackingstore.cpp
+index 32aabce..242e625 100644
+--- a/src/widgets/kernel/qwidgetbackingstore.cpp
++++ b/src/widgets/kernel/qwidgetbackingstore.cpp
+@@ -67,7 +67,9 @@ QT_BEGIN_NAMESPACE
+
+ extern QRegion qt_dirtyRegion(QWidget *);
+
++#ifndef QT_NO_OPENGL
+ Q_GLOBAL_STATIC(QPlatformTextureList, qt_dummy_platformTextureList)
++#endif
+
+ /**
+ * Flushes the contents of the \a backingStore into the screen area of \a widget.
+--
+cgit v1.0-4-g1e03
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index f69c33cb..c82195db 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -26,6 +26,7 @@ SRC_URI += "\
file://0008-configure-paths-for-target-qmake-properly.patch \
file://0009-Reorder-EGL-libraries-from-pkgconfig-and-defaults.patch \
file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
+ file://0013-Fix-build-with-QT_NO_OPENGL.patch \
"
DEPENDS += "qtbase-native"