aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-05-31 13:27:32 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-06-05 09:15:35 +0000
commit0aa7c99d444a8ff492dd1dba8bc72e7ffdf00fa0 (patch)
treee91dcbbc001af1d75b0ecdaa91adcfdfd9ee51e5
parente91e6a01a6623225290059073e806217f23e1f07 (diff)
qtwebview: add recipe for Qt WebView
Task-number: QTBUG-61124 Change-Id: I20be287aba9d0dc3bf2c62eed103ab3dd19fbf7c Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch22
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb16
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch b/recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch
new file mode 100644
index 00000000..82087b9a
--- /dev/null
+++ b/recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch
@@ -0,0 +1,22 @@
+From b946b6ea4a2a30bd12ecd036e40c9ef671681ba8 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Fri, 2 Jun 2017 13:12:18 +0300
+Subject: [PATCH] Add missing include for qWarning
+
+Change-Id: I7c7699e7a2b7ce59e4f659d460ec835f59bba439
+---
+ src/webview/qquickwebview.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/webview/qquickwebview.cpp b/src/webview/qquickwebview.cpp
+index d760564..fbbbfd6 100644
+--- a/src/webview/qquickwebview.cpp
++++ b/src/webview/qquickwebview.cpp
+@@ -39,6 +39,7 @@
+ #include <QtWebView/private/qwebviewloadrequest_p.h>
+ #include <QtQml/qqmlengine.h>
+ #include <QtCore/qmutex.h>
++#include <QtCore/QDebug>
+
+ namespace {
+
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
new file mode 100644
index 00000000..2229cb10
--- /dev/null
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -0,0 +1,16 @@
+LICENSE = "GFDL-1.3 & BSD & ( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+ file://LICENSE.GPLv2;md5=c96076271561b0e3785dad260634eaa8 \
+ file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
+ file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
+"
+
+require qt5.inc
+require qt5-git.inc
+
+SRC_URI += "file://0001-Add-missing-include-for-qWarning.patch"
+
+DEPENDS += "qtbase qtwebengine"
+
+SRCREV = "6e55abf3b6a5f373cd4b649c2318a45c49b40589"