aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-06-07 16:15:53 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-06-08 10:34:00 +0000
commit15a2e1643239b40ee1bc2ee32dd3b91ec6960dbf (patch)
tree70344c1ecaa9639ca2b765d262e0c62dce167791
parent0aa7c99d444a8ff492dd1dba8bc72e7ffdf00fa0 (diff)
qtlocation: make mapbox-gl plugin a PACKAGECONFIG option
mapbox-gl-native won't compile on ARMv5 or older, so make it optional Change-Id: I464b0653edd11297856510c6a848a71d9de4ce85 Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
-rw-r--r--recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch27
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
new file mode 100644
index 00000000..49fcff6b
--- /dev/null
+++ b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
@@ -0,0 +1,27 @@
+From f7c76b91e726a0e63e5226eb6e89b13e0c3509b7 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Wed, 7 Jun 2017 13:29:29 +0300
+Subject: [PATCH] Make mapbox-gl build configurable
+
+mapbox-gl-native won't compile for ARMv5 or older, so disable the
+build by default.
+
+Task-number: QTBUG-61289
+Change-Id: I5f26200f2735b363c3c322f9035b331b9159c47b
+---
+ src/plugins/geoservices/geoservices.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/plugins/geoservices/geoservices.pro b/src/plugins/geoservices/geoservices.pro
+index 0810d39..03fc119 100644
+--- a/src/plugins/geoservices/geoservices.pro
++++ b/src/plugins/geoservices/geoservices.pro
+@@ -6,7 +6,7 @@ qtConfig(concurrent) {
+ SUBDIRS += osm
+ }
+
+-qtConfig(c++14):!win32|mingw:!qnx {
++mapboxgl:qtConfig(c++14):!win32|mingw:!qnx {
+ !exists(../../3rdparty/mapbox-gl-native/CMakeLists.txt) {
+ warning("Submodule mapbox-gl-native does not exist. Run 'git submodule update --init' on qtlocation.")
+ } else {
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index af295769..ea24fe44 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -13,11 +13,15 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtquickcontrols"
+SRC_URI += "file://0001-Make-mapbox-gl-build-configurable.patch"
+
PACKAGECONFIG ??= ""
# older geoclue 0.12.99 is needed
PACKAGECONFIG[geoclue] = ",,geoclue"
PACKAGECONFIG[gypsy] = "-feature-gypsy,-no-feature-gypsy,gconf gypsy"
+PACKAGECONFIG[mapboxgl] = ""
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'mapboxgl', 'CONFIG+=mapboxgl', '', d)}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
SRC_URI += " \