aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-07-12 12:58:41 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-12 10:25:04 +0200
commit2c1d6b1e9377d10d1c66ae2a4f9b15b3781e96d8 (patch)
tree665b0b20ca0c689b35e0d204f61dfb63143bcddf
parent1eac990617e80cdcc1aa0f5faed59b0e7112488c (diff)
qtquick1: add ptest
Add ptest for qttools by using provided testsuite in qtquick1. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtquick1/run-ptest6
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb1
2 files changed, 7 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtquick1/run-ptest b/recipes-qt/qt5/qtquick1/run-ptest
new file mode 100644
index 00000000..044f834d
--- /dev/null
+++ b/recipes-qt/qt5/qtquick1/run-ptest
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+for x in ` awk '{print $1}' tst_list `;do
+ ./${x};
+done
+
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index e9b6185e..d41b8382 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -1,5 +1,6 @@
require qt5.inc
require qt5-git.inc
+require qt5-ptest.inc
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \