aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-10-09 13:19:26 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-10-09 11:30:45 +0000
commit6b7b1293d94f2c0ac8292520a1d324181e14c834 (patch)
treef29be960f6b4755fb40fca06081be701c04db283
parent88a25de90d720d824b8a4e932ff2ff8faa2b6615 (diff)
qtdeclarative: remove upstreamed patch
Change-Id: Ide24ad4bfcb1700ab2a91264ef33c6ece6ccb352 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch35
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
2 files changed, 0 insertions, 39 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch b/recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch
deleted file mode 100644
index 050a914e..00000000
--- a/recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From f9dcbf008b430aadd464985b7a618eca8173d264 Mon Sep 17 00:00:00 2001
-From: Robert Griebl <robert.griebl@pelagicore.com>
-Date: Thu, 23 Feb 2017 15:11:13 +0100
-Subject: [PATCH 1/3] Fix QQmlExpression leaking QQmlError objects
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-If the user doesn't clear any potential errors manually via clearError(),
-then do it automatically in the destructor. Found with valgrind.
-
-[ChangeLog][QtQml][QQmlExpression] Fixed memory leak
-
-Change-Id: If5b1181850c7463c939a7ba536d74e7054c53d60
-Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
-Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com>
----
- src/qml/qml/qqmlexpression.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/qml/qml/qqmlexpression.cpp b/src/qml/qml/qqmlexpression.cpp
-index 6afbd05..5cb3d4d 100644
---- a/src/qml/qml/qqmlexpression.cpp
-+++ b/src/qml/qml/qqmlexpression.cpp
-@@ -200,6 +200,7 @@ QQmlExpression::QQmlExpression(QQmlContextData *ctxt, QObject *scope,
- */
- QQmlExpression::~QQmlExpression()
- {
-+ clearError();
- }
-
- /*!
---
-2.9.3
-
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 67d6b910..cda7b3ad 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -11,10 +11,6 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-SRC_URI += " \
- file://0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch \
-"
-
DEPENDS += "qtbase"
PACKAGECONFIG ??= "qtxmlpatterns"