aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-07-25 09:30:23 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-08 20:44:12 +0200
commit6e9892aa3c675c74e32f3039ab5d210634ab878d (patch)
treec69bbf55902a0c48c7da2d4f8f9399a9814ad675
parent8960831c154848e42bc433871a7424d7d39ddbdc (diff)
qtbase: add ptest
Add ptest for qtbase by using provided testsuite. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch28
-rw-r--r--recipes-qt/qt5/qtbase/run-ptest6
-rw-r--r--recipes-qt/qt5/qtbase_git.bb17
3 files changed, 50 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch
new file mode 100644
index 00000000..975cd28d
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0001-Delete-qlonglong-and-qulonglong.patch
@@ -0,0 +1,28 @@
+From c67a4af2e5db4c1e2213961e6392b59affd1959f Mon Sep 17 00:00:00 2001
+From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
+Date: Wed, 7 Jun 2017 21:00:49 +0900
+Subject: [PATCH] Delete qlonglong and qulonglong
+
+Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
+---
+ tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro b/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro
+index 09458bd..59a120e 100644
+--- a/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro
++++ b/tests/auto/corelib/thread/qatomicinteger/qatomicinteger.pro
+@@ -5,10 +5,8 @@ SUBDIRS=\
+ char32_t \
+ int \
+ long \
+- qlonglong \
+ qptrdiff \
+ quintptr \
+- qulonglong \
+ schar \
+ short \
+ uchar \
+--
+2.7.4
+
diff --git a/recipes-qt/qt5/qtbase/run-ptest b/recipes-qt/qt5/qtbase/run-ptest
new file mode 100644
index 00000000..044f834d
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/run-ptest
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+for x in ` awk '{print $1}' tst_list `;do
+ ./${x};
+done
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 5cfbcfa9..8464873b 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -23,8 +23,12 @@ SRC_URI += "\
file://0005-configure-bump-path-length-from-256-to-512-character.patch \
file://0009-Disable-all-unknown-features-instead-of-erroring-out.patch \
file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
+ file://0001-Delete-qlonglong-and-qulonglong.patch \
+ file://run-ptest \
"
+inherit ptest
+
# only for target qtbase
SRC_URI += "\
file://0008-configure-paths-for-target-qmake-properly.patch \
@@ -48,7 +52,7 @@ PACKAGECONFIG_DISTRO ?= ""
PACKAGECONFIG_RELEASE ?= "release"
# This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency
# PACKAGECONFIG_OPENSSL ?= "openssl"
-PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype"
+PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests"
PACKAGECONFIG ?= " \
${PACKAGECONFIG_RELEASE} \
@@ -171,6 +175,17 @@ do_configure() {
${QT_CONFIG_FLAGS}
}
+fakeroot do_install_ptest() {
+ mkdir -p ${D}${PTEST_PATH}
+ t=${D}${PTEST_PATH}
+ for var in ` find ${B}/tests/auto/ -name tst_*`; do
+ if [ not ` echo ${var##*/} | grep '\.'` ]; then
+ echo ${var##*/} >> ${t}/tst_list
+ install -m 0644 ${var} ${t}
+ fi
+ done
+}
+
do_install_append() {
# Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri