aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-04-24 06:09:42 +0000
committerThe Qt Project <gerrit-noreply@qt-project.org>2017-04-24 06:09:42 +0000
commitba9b52e8438e59c8db7e22ff0015a7236c51ffd5 (patch)
tree017e13305ebe16a2091eea414599d94480ccc966
parent881ef630a78a8e3279df5d093cc853b6aa37137e (diff)
parent046dfb7d3689006927fa788fb935a26c02b81b31 (diff)
Merge "Merge remote-tracking branch 'qtyocto/upstream/master' into 5.9" into 5.9
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch35
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
-rw-r--r--recipes-qt/qt5/qttools/run-ptest4
-rw-r--r--recipes-qt/qt5/qttools_git.bb17
-rw-r--r--recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch35
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb5
6 files changed, 99 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch b/recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch
new file mode 100644
index 00000000..050a914e
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch
@@ -0,0 +1,35 @@
+From f9dcbf008b430aadd464985b7a618eca8173d264 Mon Sep 17 00:00:00 2001
+From: Robert Griebl <robert.griebl@pelagicore.com>
+Date: Thu, 23 Feb 2017 15:11:13 +0100
+Subject: [PATCH 1/3] Fix QQmlExpression leaking QQmlError objects
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+If the user doesn't clear any potential errors manually via clearError(),
+then do it automatically in the destructor. Found with valgrind.
+
+[ChangeLog][QtQml][QQmlExpression] Fixed memory leak
+
+Change-Id: If5b1181850c7463c939a7ba536d74e7054c53d60
+Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
+Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com>
+---
+ src/qml/qml/qqmlexpression.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/qml/qml/qqmlexpression.cpp b/src/qml/qml/qqmlexpression.cpp
+index 6afbd05..5cb3d4d 100644
+--- a/src/qml/qml/qqmlexpression.cpp
++++ b/src/qml/qml/qqmlexpression.cpp
+@@ -200,6 +200,7 @@ QQmlExpression::QQmlExpression(QQmlContextData *ctxt, QObject *scope,
+ */
+ QQmlExpression::~QQmlExpression()
+ {
++ clearError();
+ }
+
+ /*!
+--
+2.9.3
+
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 1ff6aa82..d4c711e0 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -14,6 +14,10 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
+SRC_URI += " \
+ file://0001-Fix-QQmlExpression-leaking-QQmlError-objects.patch \
+"
+
DEPENDS += "qtbase"
PACKAGECONFIG ??= "qtxmlpatterns"
diff --git a/recipes-qt/qt5/qttools/run-ptest b/recipes-qt/qt5/qttools/run-ptest
new file mode 100644
index 00000000..5cd5e27e
--- /dev/null
+++ b/recipes-qt/qt5/qttools/run-ptest
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+./tst_qtdiag
+./tst_qtattributionsscanner
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index e8393096..51963027 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -14,9 +14,12 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
+inherit ptest
+
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
SRC_URI += " \
+ file://run-ptest \
file://0003-add-noqtwebkit-configuration.patch \
file://0004-linguist-tools-cmake-allow-overriding-the-location-f.patch \
"
@@ -32,3 +35,17 @@ EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'C
SRCREV = "5c7b771829c52400ddd8f441972b37ce92da3b78"
BBCLASSEXTEND = "native nativesdk"
+
+do_compile_ptest() {
+ export PATH=${STAGING_DIR_NATIVE}/usr/include/qt5:$PATH
+ cd ${S}/tests
+ qmake -o Makefile tests.pro
+ oe_runmake
+}
+
+do_install_ptest() {
+ mkdir -p ${D}${PTEST_PATH}
+ t=${D}${PTEST_PATH}
+ cp ${S}/tests/auto/qtdiag/tst_tdiag $t
+ cp ${S}/tests/auto/qtattributionsscanner/tst_qtattributionsscanner $t
+}
diff --git a/recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch b/recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch
new file mode 100644
index 00000000..29c9180c
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0002-Fix-initial-window-property-values-being-propagated.patch
@@ -0,0 +1,35 @@
+From 3d30fd8df9b55449844207295ad3d51cc8bb44b1 Mon Sep 17 00:00:00 2001
+From: Robert Griebl <robert.griebl@pelagicore.com>
+Date: Thu, 15 Dec 2016 17:43:00 +0100
+Subject: [PATCH 2/2] Fix initial window property values being propagated
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This was broken since the the shell-surface refactoring.
+
+Change-Id: I130b7396e85c570a9d11d609af6b3016e3f706f0
+Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
+Reviewed-by: Paul Olav Tvete <paul.tvete@qt.io>
+Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com>
+---
+ src/client/qwaylandwindow.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/client/qwaylandwindow.cpp b/src/client/qwaylandwindow.cpp
+index c8be9c1..b6f16f0 100644
+--- a/src/client/qwaylandwindow.cpp
++++ b/src/client/qwaylandwindow.cpp
+@@ -176,6 +176,9 @@ void QWaylandWindow::initWindow()
+ mShellSurface->setAppId(appId);
+ }
+ }
++ // the user may have already set some window properties, so make sure to send them out
++ for (auto it = m_properties.cbegin(); it != m_properties.cend(); ++it)
++ mShellSurface->sendProperty(it.key(), it.value());
+ }
+
+ // Enable high-dpi rendering. Scale() returns the screen scale factor and will
+--
+2.9.3
+
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 29b1b4a4..2ed11ec4 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,6 +44,9 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
SRCREV = "c26f8dbd5c5ff15167e90db529845091705cbe46"
# From https://bugreports.qt.io/browse/QTBUG-57767
-SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch"
+SRC_URI += " \
+ file://0001-fix-build-without-xkbcommon-evdev.patch \
+ file://0002-Fix-initial-window-property-values-being-propagated.patch \
+"
BBCLASSEXTEND =+ "native nativesdk"