aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-06 08:07:33 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-06 08:07:33 +0300
commit7d0ec758e43f46f067464da0a4f4f94dbfec9556 (patch)
treea7f3d2c0b284ab8d52bd7ee229e0052394cf98ed
parent1716c294770b10e41af1b11cbe820ca857168556 (diff)
parentc1deb9aafe5fe20de1175944ed863e6d94dad71b (diff)
Merge remote-tracking branch 'qtyocto/5.12' into 5.13
* qtyocto/5.12: ogl-runtime: Fix format-security issues ogl-runtime: fix build errors qtvirtualkeyboard: update supported layouts qt3d-runtime: update to ogl-runtime v2.4 qtbase: update module qt5: update submodules qt5: update submodules qtbase: fix build with gcc-9 qtlocation: add PACKAGECONFIGs for geoservices qmake5_base.bbclass: Don't expand find -name search patterns qt5: update submodules Change-Id: Id6648d939ba54df0719660ace40d45fa3f1e1fbe
-rw-r--r--classes/qmake5_base.bbclass6
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb8
-rw-r--r--recipes-qt/qt5/ogl-runtime/0001-Fix-examples-build-error.patch62
-rw-r--r--recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch75
-rw-r--r--recipes-qt/qt5/ogl-runtime_git.bb27
-rw-r--r--recipes-qt/qt5/qt3d-runtime_git.bb16
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb10
-rw-r--r--recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0017-Always-build-uic-and-qvkgen.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch (renamed from recipes-qt/qt5/qtbase/0018-Avoid-renameeat2-for-native-sdk-builds.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch)2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb5
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb22
13 files changed, 207 insertions, 32 deletions
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index fb5f9364..3f1bba23 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -242,17 +242,17 @@ qmake5_base_do_install() {
qmake5_base_fix_install ${STAGING_DIR_NATIVE}
# Replace host paths with qmake built-in properties
- find ${D} \( -name *.pri -or -name *.prl \) -exec \
+ find ${D} \( -name "*.pri" -or -name "*.prl" \) -exec \
sed -i -e 's|${STAGING_DIR_NATIVE}|$$[QT_HOST_PREFIX/get]|g' \
-e 's|${STAGING_DIR_HOST}|$$[QT_SYSROOT]|g' {} \;
# Replace host paths with pkg-config built-in variable
- find ${D} -name *.pc -exec \
+ find ${D} -name "*.pc" -exec \
sed -i -e 's|prefix=${STAGING_DIR_HOST}|prefix=|g' \
-e 's|${STAGING_DIR_HOST}|${pc_sysrootdir}|g' {} \;
# Replace resolved lib path with the lib name
- find ${D} -name *.cmake -exec \
+ find ${D} -name "*.cmake" -exec \
sed -i -e 's@/[^;]*/lib\([^;]*\)\.\(so\|a\)@\1@g' {} \;
}
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 739c12bf..9688c380 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.7
+# 5.12.meta-qt5-shared.8
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -45,10 +45,10 @@ SRC_URI += "\
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.7
+# 5.12.meta-qt5-native.8
SRC_URI += " \
- file://0017-Always-build-uic-and-qvkgen.patch \
- file://0018-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0018-Always-build-uic-and-qvkgen.patch \
+ file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/ogl-runtime/0001-Fix-examples-build-error.patch b/recipes-qt/qt5/ogl-runtime/0001-Fix-examples-build-error.patch
new file mode 100644
index 00000000..0d2f165f
--- /dev/null
+++ b/recipes-qt/qt5/ogl-runtime/0001-Fix-examples-build-error.patch
@@ -0,0 +1,62 @@
+From 4fa69c1c5396bded20edccb2a1dd9b61f0b1140d Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Fri, 2 Aug 2019 12:39:50 +0300
+Subject: [PATCH] Fix examples build error
+
+Add workaround for QTBUG-77288 which causes examples to fail to build
+
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ examples/studio3d/cppdatainput/cppdatainput.pro | 1 +
+ examples/studio3d/dynamicelement/dynamicelement.pro | 1 +
+ examples/studio3d/qmldatainput/qmldatainput.pro | 1 +
+ examples/studio3d/simpleqml/simpleqml.pro | 1 +
+ 4 files changed, 4 insertions(+)
+
+diff --git a/examples/studio3d/cppdatainput/cppdatainput.pro b/examples/studio3d/cppdatainput/cppdatainput.pro
+index 20b5c68..bbb403a 100644
+--- a/examples/studio3d/cppdatainput/cppdatainput.pro
++++ b/examples/studio3d/cppdatainput/cppdatainput.pro
+@@ -1,5 +1,6 @@
+ CONFIG += c++11
+ QT += widgets qml quick studio3d
++QMAKE_LIBS += $$QMAKE_LIBS_3DSQMLSTREAMER $$QMAKE_LIBS_3DSOPENGL
+
+ target.path = $$[QT_INSTALL_EXAMPLES]/studio3d/$$TARGET
+ INSTALLS += target
+diff --git a/examples/studio3d/dynamicelement/dynamicelement.pro b/examples/studio3d/dynamicelement/dynamicelement.pro
+index 1b804fd..ae3c005 100644
+--- a/examples/studio3d/dynamicelement/dynamicelement.pro
++++ b/examples/studio3d/dynamicelement/dynamicelement.pro
+@@ -1,6 +1,7 @@
+ TEMPLATE = app
+
+ QT += qml quick studio3d
++QMAKE_LIBS += $$QMAKE_LIBS_3DSQMLSTREAMER $$QMAKE_LIBS_3DSOPENGL
+
+ SOURCES += \
+ demo.cpp \
+diff --git a/examples/studio3d/qmldatainput/qmldatainput.pro b/examples/studio3d/qmldatainput/qmldatainput.pro
+index 9bafed5..496c2c1 100644
+--- a/examples/studio3d/qmldatainput/qmldatainput.pro
++++ b/examples/studio3d/qmldatainput/qmldatainput.pro
+@@ -1,6 +1,7 @@
+ TEMPLATE = app
+
+ QT += widgets qml quick studio3d
++QMAKE_LIBS += $$QMAKE_LIBS_3DSQMLSTREAMER $$QMAKE_LIBS_3DSOPENGL
+
+ integrity: DEFINES += USE_EMBEDDED_FONTS
+
+diff --git a/examples/studio3d/simpleqml/simpleqml.pro b/examples/studio3d/simpleqml/simpleqml.pro
+index 62afa78..1a0784b 100644
+--- a/examples/studio3d/simpleqml/simpleqml.pro
++++ b/examples/studio3d/simpleqml/simpleqml.pro
+@@ -1,6 +1,7 @@
+ TEMPLATE = app
+
+ QT += widgets qml quick studio3d
++QMAKE_LIBS += $$QMAKE_LIBS_3DSQMLSTREAMER $$QMAKE_LIBS_3DSOPENGL
+
+ SOURCES += \
+ main.cpp
diff --git a/recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch b/recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch
new file mode 100644
index 00000000..fcf6915d
--- /dev/null
+++ b/recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch
@@ -0,0 +1,75 @@
+From c80b588cc3e11a80ffedd778fab3f19c686552f7 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Mon, 5 Aug 2019 14:24:44 +0300
+Subject: [PATCH] Fix format-security issues
+
+format not a string literal and no format arguments [-Wformat-security]
+
+Change-Id: I04c1d1598948b664b9d85036030c6f89fcf3c8b7
+---
+ src/render/backends/gl/Q3DSRenderBackendGLES2.cpp | 4 ++--
+ src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp | 8 ++++----
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp b/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp
+index ac5b992..02046ac 100644
+--- a/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp
++++ b/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp
+@@ -663,7 +663,7 @@ NVRenderBackendGLES2Impl::CreateRenderbuffer(NVRenderRenderBufferFormats::Enum s
+ // check for error
+ GLenum error = m_glFunctions->glGetError();
+ if (error != GL_NO_ERROR) {
+- qCCritical(GL_ERROR, GLConversion::processGLError(error));
++ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
+ QT3DS_ASSERT(false);
+ GL_CALL_EXTRA_FUNCTION(glDeleteRenderbuffers(1, &bufID));
+ bufID = 0;
+@@ -699,7 +699,7 @@ bool NVRenderBackendGLES2Impl::ResizeRenderbuffer(NVRenderBackendRenderbufferObj
+ // check for error
+ GLenum error = m_glFunctions->glGetError();
+ if (error != GL_NO_ERROR) {
+- qCCritical(GL_ERROR, GLConversion::processGLError(error));
++ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
+ QT3DS_ASSERT(false);
+ success = false;
+ }
+diff --git a/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp b/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp
+index 0fe6e0f..5dfe9d1 100644
+--- a/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp
++++ b/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp
+@@ -604,7 +604,7 @@ NVRenderBackendGLBase::CreateBuffer(size_t size, NVRenderBufferBindFlags bindFla
+ } else {
+ GL_CALL_FUNCTION(glDeleteBuffers(1, &bufID));
+ bufID = 0;
+- qCCritical(GL_ERROR, GLConversion::processGLError(target));
++ qCCritical(GL_ERROR) << GLConversion::processGLError(target);
+ }
+ }
+
+@@ -832,7 +832,7 @@ NVRenderBackendGLBase::CreateRenderbuffer(NVRenderRenderBufferFormats::Enum stor
+ // check for error
+ GLenum error = m_glFunctions->glGetError();
+ if (error != GL_NO_ERROR) {
+- qCCritical(GL_ERROR, GLConversion::processGLError(error));
++ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
+ QT3DS_ASSERT(false);
+ GL_CALL_FUNCTION(glDeleteRenderbuffers(1, &bufID));
+ bufID = 0;
+@@ -869,7 +869,7 @@ bool NVRenderBackendGLBase::ResizeRenderbuffer(NVRenderBackendRenderbufferObject
+ // check for error
+ GLenum error = m_glFunctions->glGetError();
+ if (error != GL_NO_ERROR) {
+- qCCritical(GL_ERROR, GLConversion::processGLError(error));
++ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
+ QT3DS_ASSERT(false);
+ success = false;
+ }
+@@ -1306,7 +1306,7 @@ bool NVRenderBackendGLBase::compileSource(GLuint shaderID, NVConstDataRef<QT3DSI
+ GLenum binaryError = m_glFunctions->glGetError();
+ if (binaryError != GL_NO_ERROR) {
+ shaderStatus = GL_FALSE;
+- qCCritical(GL_ERROR, GLConversion::processGLError(binaryError));
++ qCCritical(GL_ERROR) << GLConversion::processGLError(binaryError);
+ }
+ }
+
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb
new file mode 100644
index 00000000..ecc8ba2b
--- /dev/null
+++ b/recipes-qt/qt5/ogl-runtime_git.bb
@@ -0,0 +1,27 @@
+require qt5.inc
+require qt5-git.inc
+
+LICENSE = "GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+"
+
+DEPENDS += "qtbase qtdeclarative qtquickcontrols2"
+
+QT_MODULE_BRANCH = "2.4"
+QT_MODULE_BRANCH_EASTL = "master"
+QT_GIT_PROJECT = "qt3dstudio"
+PV = "2.4+git${SRCPV}"
+
+SRC_URI += " \
+ ${QT_GIT}/qt3dstudio-eastl.git;name=EASTL;branch=${QT_MODULE_BRANCH_EASTL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/EASTL \
+ file://0001-Fix-examples-build-error.patch \
+ file://0002-Fix-format-security-issues.patch \
+"
+
+SRCREV_ogl-runtime = "a41270dced230d90e0e07f2ebb880e4f97317a7f"
+SRCREV_EASTL = "31697c758f2ed19bd7c6bbe61f1b91f9e12035b5"
+SRCREV = "${SRCREV_ogl-runtime}"
+
+SRCREV_FORMAT = "ogl-runtime_EASTL"
diff --git a/recipes-qt/qt5/qt3d-runtime_git.bb b/recipes-qt/qt5/qt3d-runtime_git.bb
deleted file mode 100644
index fb018e58..00000000
--- a/recipes-qt/qt5/qt3d-runtime_git.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require qt5.inc
-require qt5-git.inc
-
-LICENSE = "GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = " \
- file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
-"
-
-DEPENDS += "qtbase qtdeclarative qt3d"
-
-QT_MODULE_BRANCH = "2.3"
-QT_GIT_PROJECT = "qt3dstudio"
-PV = "2.3+git${SRCPV}"
-
-SRCREV = "5e0bfe934b9930b7e41d457b4f88fce91342a0ea"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index d917595a..0cde79b5 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.7
+# 5.12.meta-qt5-shared.8
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -40,15 +40,15 @@ SRC_URI += "\
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.7
+# 5.12.meta-qt5-native.8
SRC_URI += " \
- file://0017-Always-build-uic-and-qvkgen.patch \
- file://0018-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0018-Always-build-uic-and-qvkgen.patch \
+ file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0019-Bootstrap-without-linkat-feature.patch \
+ file://0020-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0017-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
index 69410925..7ae15d0a 100644
--- a/recipes-qt/qt5/qtbase/0017-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 4b0ca5d85afd944d1e5a3df545ba99566207c184 Mon Sep 17 00:00:00 2001
+From 0db28cf06f557a714f8cffafbfcdbe68378c8f8a Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0018-Avoid-renameeat2-for-native-sdk-builds.patch b/recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch
index 0ca038f5..b3c2c767 100644
--- a/recipes-qt/qt5/qtbase/0018-Avoid-renameeat2-for-native-sdk-builds.patch
+++ b/recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch
@@ -1,4 +1,4 @@
-From 69aeac9c7233e0d76a8a00b1a45c53c1670c9b49 Mon Sep 17 00:00:00 2001
+From 0c79a6761e75441f433fd397bc3b79e78b6c5ef8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 14 Apr 2019 13:27:58 +0200
Subject: [PATCH] Avoid renameeat2 for native(sdk) builds
diff --git a/recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
index a1d08236..e681bfbb 100644
--- a/recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 703f89e35aaaec5ad781c222ae2dcd30f31320e9 Mon Sep 17 00:00:00 2001
+From d52010c7d58f1a25f51a909b3179df656ed9d9c4 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 5e4a89b2..b44b3d49 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.7
+# 5.12.meta-qt5-shared.8
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 62c76b06..2b73bf9b 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -17,6 +17,11 @@ PACKAGECONFIG ??= ""
# older geoclue 0.12.99 is needed
PACKAGECONFIG[geoclue] = ",,geoclue"
PACKAGECONFIG[gypsy] = "-feature-gypsy,-no-feature-gypsy,gconf gypsy"
+PACKAGECONFIG[geoservices_here] = "-feature-geoservices_here,-no-feature-geoservices_here"
+PACKAGECONFIG[geoservices_mapbox] = "-feature-geoservices_mapbox,-no-feature-geoservices_mapbox"
+PACKAGECONFIG[geoservices_esri] = "-feature-geoservices_esri,-no-feature-geoservices_esri"
+PACKAGECONFIG[geoservices_itemsoverlay] = "-feature-geoservices_itemsoverlay,-no-feature-geoservices_itemsoverlay"
+PACKAGECONFIG[geoservices_osm] = "-feature-geoservices_osm,-no-feature-geoservices_osm"
PACKAGECONFIG[geoservices_mapboxgl] = "-feature-geoservices_mapboxgl,-no-feature-geoservices_mapboxgl"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index b8026230..c83d8d4b 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -19,23 +19,45 @@ PACKAGECONFIG[t9write] = "CONFIG+=t9write"
PACKAGECONFIG[lipi-toolkit] = "CONFIG+=lipi-toolkit"
PACKAGECONFIG[lang-all] = "CONFIG+=lang-all"
PACKAGECONFIG[lang-ar_AR] = "CONFIG+=lang-ar_AR"
+PACKAGECONFIG[lang-bg_BG] = "CONFIG+=lang-bg_BG"
+PACKAGECONFIG[lang-cs_CZ] = "CONFIG+=lang-cs_CZ"
PACKAGECONFIG[lang-da_DK] = "CONFIG+=lang-da_DK"
PACKAGECONFIG[lang-de_DE] = "CONFIG+=lang-de_DE"
+PACKAGECONFIG[lang-el_GR] = "CONFIG+=lang-el_GR"
PACKAGECONFIG[lang-en_GB] = "CONFIG+=lang-en_GB"
+PACKAGECONFIG[lang-en_US] = "CONFIG+=lang-en_US"
PACKAGECONFIG[lang-es_ES] = "CONFIG+=lang-es_ES"
+PACKAGECONFIG[lang-es_MX] = "CONFIG+=lang-es_MX"
+PACKAGECONFIG[lang-et_EE] = "CONFIG+=lang-et_EE"
PACKAGECONFIG[lang-fa_FA] = "CONFIG+=lang-fa_FA"
PACKAGECONFIG[lang-fi_FI] = "CONFIG+=lang-fi_FI"
+PACKAGECONFIG[lang-fr_CA] = "CONFIG+=lang-fr_CA"
PACKAGECONFIG[lang-fr_FR] = "CONFIG+=lang-fr_FR"
+PACKAGECONFIG[lang-he_IL] = "CONFIG+=lang-he_IL"
PACKAGECONFIG[lang-hi_IN] = "CONFIG+=lang-hi_IN"
+PACKAGECONFIG[lang-hr_HR] = "CONFIG+=lang-hr_HR"
+PACKAGECONFIG[lang-hu_HU] = "CONFIG+=lang-hu_HU"
+PACKAGECONFIG[lang-id_ID] = "CONFIG+=lang-id_ID"
PACKAGECONFIG[lang-it_IT] = "CONFIG+=lang-it_IT"
PACKAGECONFIG[lang-ja_JP] = "CONFIG+=lang-ja_JP"
PACKAGECONFIG[lang-ko_KR] = "CONFIG+=lang-ko_KR"
+PACKAGECONFIG[lang-ms_MY] = "CONFIG+=lang-ms_MY"
PACKAGECONFIG[lang-nb_NO] = "CONFIG+=lang-nb_NO"
+PACKAGECONFIG[lang-nl_NL] = "CONFIG+=lang-nl_NL"
PACKAGECONFIG[lang-pl_PL] = "CONFIG+=lang-pl_PL"
+PACKAGECONFIG[lang-pt_BR] = "CONFIG+=lang-pt_BR"
PACKAGECONFIG[lang-pt_PT] = "CONFIG+=lang-pt_PT"
PACKAGECONFIG[lang-ro_RO] = "CONFIG+=lang-ro_RO"
PACKAGECONFIG[lang-ru_RU] = "CONFIG+=lang-ru_RU"
+PACKAGECONFIG[lang-sk_SK] = "CONFIG+=lang-sk_SK"
+PACKAGECONFIG[lang-sl_SI] = "CONFIG+=lang-sl_SI"
+PACKAGECONFIG[lang-sq_AL] = "CONFIG+=lang-sq_AL"
+PACKAGECONFIG[lang-sr_SP] = "CONFIG+=lang-sr_SP"
PACKAGECONFIG[lang-sv_SE] = "CONFIG+=lang-sv_SE"
+PACKAGECONFIG[lang-th_TH] = "CONFIG+=lang-th_TH"
+PACKAGECONFIG[lang-tr_TR] = "CONFIG+=lang-tr_TR"
+PACKAGECONFIG[lang-uk_UA] = "CONFIG+=lang-uk_UA"
+PACKAGECONFIG[lang-vi_VN] = "CONFIG+=lang-vi_VN"
PACKAGECONFIG[lang-zh_CN] = "CONFIG+=lang-zh_CN"
PACKAGECONFIG[lang-zh_TW] = "CONFIG+=lang-zh_TW"