aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 20:58:35 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 21:01:43 +0100
commitca1042b8feb8cac2ac1ca835ac67d0ad6d373d0c (patch)
treef665add1e78a6343d66fc263d4405d39112749fc
parentacbb72d884aecb02de29006081fa55efe8cac9f8 (diff)
qtwebengine: fix executing config tests instead of ignoring libcap test failure
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch26
-rw-r--r--recipes-qt/qt5/qtwebengine.inc11
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch26
-rw-r--r--recipes-qt/qt5/qtwebengine_5.4.1.bb1
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
5 files changed, 6 insertions, 59 deletions
diff --git a/recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch b/recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch
deleted file mode 100644
index 6a2162f4..00000000
--- a/recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 7d20d5e4584abce2353557c90e79ee0b3cdc330e Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Fri, 27 Feb 2015 19:51:55 +0100
-Subject: [PATCH 4/4] configure.prf: don't fail when libcap test fails
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- tools/qmake/mkspecs/features/configure.prf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/qmake/mkspecs/features/configure.prf b/tools/qmake/mkspecs/features/configure.prf
-index 6e74b55..b91fde8 100644
---- a/tools/qmake/mkspecs/features/configure.prf
-+++ b/tools/qmake/mkspecs/features/configure.prf
-@@ -20,7 +20,7 @@ defineTest(runConfigure) {
- qtCompileTest($$test)
- }
- # libcap-dev package doesn't ship .pc files on Ubuntu.
-- linux:!config_libcap:skipBuild("libcap appears to be missing")
-+ #linux:!config_libcap:skipBuild("libcap appears to be missing")
- contains(QT_CONFIG, xcb) {
- for(package, $$list("libdrm xcomposite xi xrandr")) {
- !packagesExist($$package):skipBuild("Unmet dependency: $$package")
---
-2.3.1
-
diff --git a/recipes-qt/qt5/qtwebengine.inc b/recipes-qt/qt5/qtwebengine.inc
index 46060c08..a9c7005a 100644
--- a/recipes-qt/qt5/qtwebengine.inc
+++ b/recipes-qt/qt5/qtwebengine.inc
@@ -35,11 +35,12 @@ export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja"
do_configure() {
# replace LD with CXX, to workaround a possible gyp inheritssue?
- LD="${CXX}" export LD
- CC="${CC}" export CC
- CXX="${CXX}" export CXX
- CC_host="gcc" export CC_host
- CXX_host="g++" export CXX_host
+ export LD="${CXX}"
+ export CC="${CC}"
+ export CXX="${CXX}"
+ export CC_host="gcc"
+ export CXX_host="g++"
+ export QMAKE_MAKE_ARGS="${EXTRA_OEMAKE}"
# qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as
# arguments here
diff --git a/recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch b/recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch
deleted file mode 100644
index 71ee4fe7..00000000
--- a/recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 1306df17fccb672e95911398740d48408488035a Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Fri, 27 Feb 2015 19:51:55 +0100
-Subject: [PATCH 4/4] configure.prf: don't fail when libcap test fails
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- tools/qmake/mkspecs/features/configure.prf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/qmake/mkspecs/features/configure.prf b/tools/qmake/mkspecs/features/configure.prf
-index 6e74b55..b91fde8 100644
---- a/tools/qmake/mkspecs/features/configure.prf
-+++ b/tools/qmake/mkspecs/features/configure.prf
-@@ -20,7 +20,7 @@ defineTest(runConfigure) {
- qtCompileTest($$test)
- }
- # libcap-dev package doesn't ship .pc files on Ubuntu.
-- linux:!config_libcap:skipBuild("libcap appears to be missing")
-+ #linux:!config_libcap:skipBuild("libcap appears to be missing")
- contains(QT_CONFIG, xcb) {
- for(package, $$list("libdrm xcomposite xi xrandr")) {
- !packagesExist($$package):skipBuild("Unmet dependency: $$package")
---
-2.3.1
-
diff --git a/recipes-qt/qt5/qtwebengine_5.4.1.bb b/recipes-qt/qt5/qtwebengine_5.4.1.bb
index 4b21f32c..92e8c048 100644
--- a/recipes-qt/qt5/qtwebengine_5.4.1.bb
+++ b/recipes-qt/qt5/qtwebengine_5.4.1.bb
@@ -8,6 +8,5 @@ SRC_URI += " \
file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \
file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \
- file://0004-configure.prf-don-t-fail-when-libcap-test-fails.patch \
file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \
"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 450609d7..b451c37e 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -9,7 +9,6 @@ SRC_URI += " \
file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \
file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \
- file://0004-configure.prf-don-t-fail-when-libcap-test-fails.patch \
file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \
"
SRCREV_qtwebengine = "4eceed9ac0b646238e76d77569a619d4dc515ba5"