aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-12 14:55:37 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-12 15:03:21 +0100
commitb8a236df79c25802c1f2eb2525e8a534e73e608e (patch)
treef558c77d3fe1d8957d2e73e183596ca666c4acf3
parent0b4bdeb6c195b3e1abf32e96354e4401d596ec0a (diff)
qt5: Fix cmake config files
* without syncqt cmake config files have empty PRIVATE_INCLUDE_DIRS remove pregenerated header files and create .git dir to let qmake call syncqt and generate headers like when building from git recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-native.inc7
-rw-r--r--recipes-qt/qt5/qt5.inc8
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb21
3 files changed, 15 insertions, 21 deletions
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qt5-native.inc
index 76816027..85350288 100644
--- a/recipes-qt/qt5/qt5-native.inc
+++ b/recipes-qt/qt5/qt5-native.inc
@@ -10,3 +10,10 @@ OE_QMAKE_PATH_DOCS = "${OE_QMAKE_PATH_QT_DOCS}"
OE_QMAKE_PATH_SETTINGS = "${OE_QMAKE_PATH_QT_SETTINGS}"
OE_QMAKE_PATH_EXAMPLES = "${OE_QMAKE_PATH_QT_EXAMPLES}"
OE_QMAKE_PATH_TESTS = "${OE_QMAKE_PATH_QT_TESTS}"
+
+# Regenerate header files when they are included in source tarball
+# Otherwise cmake files don't set PRIVATE_HEADERS correctly
+do_configure_prepend() {
+ rm -rf ${S}/include
+ mkdir -p ${S}/.git || true
+}
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index 57ffe098..7e739c54 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -32,6 +32,14 @@ python __anonymous() {
d.setVar("PACKAGE_ARCH", tarch)
}
+
+# Regenerate header files when they are included in source tarball
+# Otherwise cmake files don't set PRIVATE_HEADERS correctly
+do_configure_prepend() {
+ rm -rf ${S}/include
+ mkdir -p ${S}/.git || true
+}
+
PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmlplugins ${PN}-tools ${PN}-plugins ${PN}-mkspecs ${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-dbg ${PN}-examples "
# extra -dbg packages
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index ce823d26..471d95b3 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -1,27 +1,6 @@
require qt5-git.inc
require ${PN}.inc
-# common with target version
-SRC_URI = "\
- git://qt.gitorious.org/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \
- file://0001-Add-linux-oe-g-platform.patch \
- file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
- file://0003-Add-external-hostbindir-option.patch \
- file://0004-qt_functions-temporary-remove-isEmpty-check.patch \
- file://0005-configureapp-Prefix-default-LIBDIRS-and-INCDIRS-with.patch \
- file://0006-qt_module-Fix-pkgconfig-replacement.patch \
- file://0007-qt_module-Fix-paths-in-.prl-files.patch \
- file://0008-wayland-scanner-disable-silent-rules.patch \
- file://0009-configure-don-t-export-SYSTEM_VARIABLES-to-.qmake.va.patch \
- file://0010-configure.prf-Allow-to-add-extra-arguments-to-make.patch \
- file://0011-configure-make-pulseaudio-a-configurable-option.patch \
- file://0012-configure-make-alsa-a-configurable-option.patch \
- file://0013-configure-make-freetype-a-configurable-option.patch \
- file://0014-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-determine-pa.patch \
-"
-
-SRC_URI += "file://0015-Always-build-uic.patch"
-
do_install_append() {
# for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
# e.g. qt3d, qtwayland