aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-23 19:37:20 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-23 19:44:50 +0100
commit6e60bd51f145573beaf496a69428fb693bd2e15e (patch)
tree19cd49599b4af21faec6db522d150127548ad172
parentbcd8564f5c9b7954eca9d425fe90b174ea821ab9 (diff)
python-pyqt5, qtwebengine, qtwebkit, qt-kiosk-browser: skip without meta-python2
Neither of these actually builds with python3, skip them when meta-python2 isn't included until real fix is available. qtwebkit might not get the support for python3 at all qtwebengine I have some changes for the initial build, but there are many more needed as shown in upstream chromium: https://bugs.chromium.org/p/chromium/issues/detail?id=942720 https://bugs.chromium.org/p/chromium/issues/list?q=label%3AProj-Python3Migration&can=2 python-pyqt5 is already blacklisted because of sip Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb7
-rw-r--r--recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb9
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb9
4 files changed, 26 insertions, 3 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index b8b1d086..e051b156 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -1,6 +1,11 @@
require python-pyqt5.inc
-inherit pythonnative python-dir
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative python-dir", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
DEPENDS += "sip sip-native python"
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
index 44bdf18c..8ae0e9ef 100644
--- a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
+++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
@@ -4,6 +4,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
LICENSE = "GPLv3"
DEPENDS = "qtwebengine"
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('qtwebengine dependency requires meta-python2 to be present.')
+}
SRC_URI = " \
git://github.com/OSSystems/qt-kiosk-browser;protocol=https \
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index e42cf491..c00120b3 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -79,10 +79,17 @@ COMPATIBLE_MACHINE_aarch64 = "(.*)"
inherit qmake5
inherit gettext
-inherit pythonnative
inherit perlnative
inherit features_check
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
+
+
# Static builds of QtWebEngine aren't supported.
CONFLICT_DISTRO_FEATURES = "qt5-static"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 6cc789f0..942e733a 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -18,7 +18,14 @@ SRC_URI += "\
file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
"
-inherit cmake_qt5 perlnative pythonnative
+inherit cmake_qt5 perlnative
+
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
# qemuarm build fails with:
# | {standard input}: Assembler messages: