aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-11-26 09:06:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-15 16:46:42 +0100
commit13f73a2adc8b2992bf2549376d503389431cb927 (patch)
treeb7a257029ae2b35ba98e9705408c905088008774
parent593c47aa37837a725b392c33011f3962da7c1539 (diff)
align target qmake paths/mkspec
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb5
-rw-r--r--recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch76
-rw-r--r--recipes-qt/qt5/qtbase/0009-Always-build-uic.patch (renamed from recipes-qt/qt5/qtbase/0008-Always-build-uic.patch)0
-rw-r--r--recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch (renamed from recipes-qt/qt5/qtbase/0009-Add-external-hostbindir-option-for-native-sdk.patch)0
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
6 files changed, 82 insertions, 4 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index f712af72..3d4900eb 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -33,8 +33,8 @@ SRC_URI += "\
# common for qtbase-native and nativesdk-qtbase
SRC_URI += " \
- file://0008-Always-build-uic.patch \
- file://0009-Add-external-hostbindir-option-for-native-sdk.patch \
+ file://0009-Always-build-uic.patch \
+ file://0010-Add-external-hostbindir-option-for-native-sdk.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index e27d34bf..14e85165 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -23,12 +23,13 @@ SRC_URI += "\
file://0005-configure-bump-path-length-from-256-to-512-character.patch \
file://0006-QOpenGLPaintDevice-sub-area-support.patch \
file://0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
+ file://0008-configure-paths-for-target-qmake-properly.patch \
"
# common for qtbase-native and nativesdk-qtbase
SRC_URI += " \
- file://0008-Always-build-uic.patch \
- file://0009-Add-external-hostbindir-option-for-native-sdk.patch \
+ file://0009-Always-build-uic.patch \
+ file://0010-Add-external-hostbindir-option-for-native-sdk.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch b/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch
new file mode 100644
index 00000000..efd27a55
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch
@@ -0,0 +1,76 @@
+From fb519b08f564a8a640b1b2f2b6a3bd54a83e19e8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Fri, 13 Nov 2015 12:36:11 +0100
+Subject: [PATCH] configure paths/mkspecs for target qmake properly
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+to use this patch in all qtbase/qtbase-native(sdk) changes ore made
+conditionally based on QT_CROSS_COMPILE
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ configure | 23 +++++++++++++++++++----
+ 1 file changed, 19 insertions(+), 4 deletions(-)
+
+diff --git a/configure b/configure
+index 6edfffd..de74a29 100755
+--- a/configure
++++ b/configure
+@@ -3857,8 +3857,13 @@ if [ "$CFG_COMPILE_EXAMPLES" = "yes" ]; then
+ QMAKE_CONFIG="$QMAKE_CONFIG compile_examples"
+ fi
+
+-shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
+-shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
++if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
++ shortxspec=linux-g++
++ shortspec=linux-g++
++else
++ shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
++ shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
++fi
+
+ QT_CONFIGURE_STR_OFF=0
+
+@@ -3891,7 +3896,11 @@ QT_CONFIGURE_STRS_ALL=$QT_CONFIGURE_STRS
+
+ QT_CONFIGURE_STR_OFFSETS=
+ QT_CONFIGURE_STRS=
+-addConfStr "$CFG_SYSROOT"
++if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
++ addConfStr ""
++else
++ addConfStr "$CFG_SYSROOT"
++fi
+ addConfStr "$QT_REL_HOST_BINS"
+ addConfStr "$QT_REL_HOST_LIBS"
+ addConfStr "$QT_REL_HOST_DATA"
+@@ -3903,6 +3912,12 @@ addConfStr "$shortspec"
+ #-------------------------------------------------------------------------------
+ [ -d "$outpath/src/corelib/global" ] || mkdir -p "$outpath/src/corelib/global"
+
++if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
++ QT_TARGET_PREFIX=$QT_EXT_PREFIX
++else
++ QT_TARGET_PREFIX=$QT_HOST_PREFIX
++fi
++
+ cat > "$outpath/src/corelib/global/qconfig.cpp.new" <<EOF
+ /* License Info */
+ static const char qt_configure_licensee_str [256 + 12] = "qt_lcnsuser=$Licensee";
+@@ -3915,7 +3930,7 @@ static const char qt_configure_installation [12+11] = "qt_instdate=2
+ static const char qt_configure_prefix_path_str [512 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
+ #ifdef QT_BUILD_QMAKE
+ static const char qt_configure_ext_prefix_path_str [512 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
+-static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
++static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_TARGET_PREFIX";
+ #endif
+
+ static const short qt_configure_str_offsets[] = {
+--
+2.1.0
+
diff --git a/recipes-qt/qt5/qtbase/0008-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
index 359be5fb..359be5fb 100644
--- a/recipes-qt/qt5/qtbase/0008-Always-build-uic.patch
+++ b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
diff --git a/recipes-qt/qt5/qtbase/0009-Add-external-hostbindir-option-for-native-sdk.patch b/recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch
index 4d654a44..4d654a44 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-external-hostbindir-option-for-native-sdk.patch
+++ b/recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e504ab7f..7ee5f562 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -19,6 +19,7 @@ SRC_URI += "\
file://0005-configure-bump-path-length-from-256-to-512-character.patch \
file://0006-QOpenGLPaintDevice-sub-area-support.patch \
file://0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
+ file://0008-configure-paths-for-target-qmake-properly.patch \
"
DEPENDS += "qtbase-native"