aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-07 15:30:56 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-07 15:57:48 +0200
commitae45cb478fbfacc7e2e23eb365c1f740ad325335 (patch)
tree07ccb55679d65126635ba9410d449d03d49810bd
parentc87998953133d7b9a5a8ba55b00fa1803b937337 (diff)
qt5module: drop it and include only qt5.inc
* not all modules depend on qtbase, qtbase-native dependency is added by qmake5.bbclass: QT5TOOLSDEPENDS ?= "qtbase-native " DEPENDS_prepend = "${QT5TOOLSDEPENDS}" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt3d.inc2
-rw-r--r--recipes-qt/qt5/qt5module.inc3
-rw-r--r--recipes-qt/qt5/qtdeclarative.inc2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects.inc2
-rw-r--r--recipes-qt/qt5/qtimageformats.inc4
-rw-r--r--recipes-qt/qt5/qtjsbackend.inc4
-rw-r--r--recipes-qt/qt5/qtjsondb.inc2
-rw-r--r--recipes-qt/qt5/qtlocation.inc4
-rw-r--r--recipes-qt/qt5/qtmultimedia.inc2
-rw-r--r--recipes-qt/qt5/qtquick1.inc2
-rw-r--r--recipes-qt/qt5/qtscript.inc4
-rw-r--r--recipes-qt/qt5/qtsensors.inc4
-rw-r--r--recipes-qt/qt5/qtsvg.inc4
-rw-r--r--recipes-qt/qt5/qtsystems.inc4
-rw-r--r--recipes-qt/qt5/qtwayland.inc4
-rw-r--r--recipes-qt/qt5/qtwebkit.inc2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns.inc4
17 files changed, 29 insertions, 24 deletions
diff --git a/recipes-qt/qt5/qt3d.inc b/recipes-qt/qt5/qt3d.inc
index de3548f2..89b378c0 100644
--- a/recipes-qt/qt5/qt3d.inc
+++ b/recipes-qt/qt5/qt3d.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
LICENSE = "GFDL-1.3 & LGPL-2.1 & PREVIEW.COMMERCIAL"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4ac745f4b16b419fa48a24d41e983c40 \
diff --git a/recipes-qt/qt5/qt5module.inc b/recipes-qt/qt5/qt5module.inc
deleted file mode 100644
index bbb05a65..00000000
--- a/recipes-qt/qt5/qt5module.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-require qt5.inc
-
-DEPENDS += "qtbase"
diff --git a/recipes-qt/qt5/qtdeclarative.inc b/recipes-qt/qt5/qtdeclarative.inc
index 8cb21ff1..495e9a98 100644
--- a/recipes-qt/qt5/qtdeclarative.inc
+++ b/recipes-qt/qt5/qtdeclarative.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
DEPENDS += "qtjsbackend qtsvg qtxmlpatterns"
diff --git a/recipes-qt/qt5/qtgraphicaleffects.inc b/recipes-qt/qt5/qtgraphicaleffects.inc
index a6b0fe9d..1845faf1 100644
--- a/recipes-qt/qt5/qtgraphicaleffects.inc
+++ b/recipes-qt/qt5/qtgraphicaleffects.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
DEPENDS += "qtdeclarative"
diff --git a/recipes-qt/qt5/qtimageformats.inc b/recipes-qt/qt5/qtimageformats.inc
index 8c28b2b4..26e06d4d 100644
--- a/recipes-qt/qt5/qtimageformats.inc
+++ b/recipes-qt/qt5/qtimageformats.inc
@@ -1,3 +1,5 @@
-require qt5module.inc
+require qt5.inc
+
+DEPENDS += "qtbase"
INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtjsbackend.inc b/recipes-qt/qt5/qtjsbackend.inc
index 5a4b9027..4479654e 100644
--- a/recipes-qt/qt5/qtjsbackend.inc
+++ b/recipes-qt/qt5/qtjsbackend.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
# doesn't have GFDL-1.3 like qtbase, LICENSE files are missing in 5.0.0 and 5.0.1, this is for 5.0.2 and git
LICENSE = "LGPL-2.1 | GPL-3.0"
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \
file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
"
-DEPENDS += "qtjsbackend-native"
+DEPENDS += "qtbase qtjsbackend-native"
INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtjsondb.inc b/recipes-qt/qt5/qtjsondb.inc
index 0b049dc3..74009d9f 100644
--- a/recipes-qt/qt5/qtjsondb.inc
+++ b/recipes-qt/qt5/qtjsondb.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
DEPENDS += "qtdeclarative ${ICU}"
diff --git a/recipes-qt/qt5/qtlocation.inc b/recipes-qt/qt5/qtlocation.inc
index ae9cb0c4..0bcb3805 100644
--- a/recipes-qt/qt5/qtlocation.inc
+++ b/recipes-qt/qt5/qtlocation.inc
@@ -1,5 +1,5 @@
-require qt5module.inc
+require qt5.inc
-DEPENDS += "qt3d qtdeclarative"
+DEPENDS += "qtbase qt3d qtdeclarative"
INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtmultimedia.inc b/recipes-qt/qt5/qtmultimedia.inc
index c2003fdd..d9fdf793 100644
--- a/recipes-qt/qt5/qtmultimedia.inc
+++ b/recipes-qt/qt5/qtmultimedia.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
DEPENDS += "qtdeclarative gstreamer alsa-lib "
diff --git a/recipes-qt/qt5/qtquick1.inc b/recipes-qt/qt5/qtquick1.inc
index 8befa813..db0bf894 100644
--- a/recipes-qt/qt5/qtquick1.inc
+++ b/recipes-qt/qt5/qtquick1.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
DEPENDS += "qtscript"
diff --git a/recipes-qt/qt5/qtscript.inc b/recipes-qt/qt5/qtscript.inc
index 8c28b2b4..26e06d4d 100644
--- a/recipes-qt/qt5/qtscript.inc
+++ b/recipes-qt/qt5/qtscript.inc
@@ -1,3 +1,5 @@
-require qt5module.inc
+require qt5.inc
+
+DEPENDS += "qtbase"
INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtsensors.inc b/recipes-qt/qt5/qtsensors.inc
index a6b0fe9d..786f603b 100644
--- a/recipes-qt/qt5/qtsensors.inc
+++ b/recipes-qt/qt5/qtsensors.inc
@@ -1,5 +1,5 @@
-require qt5module.inc
+require qt5.inc
-DEPENDS += "qtdeclarative"
+DEPENDS += "qtbase qtdeclarative"
INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtsvg.inc b/recipes-qt/qt5/qtsvg.inc
index 8c28b2b4..26e06d4d 100644
--- a/recipes-qt/qt5/qtsvg.inc
+++ b/recipes-qt/qt5/qtsvg.inc
@@ -1,3 +1,5 @@
-require qt5module.inc
+require qt5.inc
+
+DEPENDS += "qtbase"
INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtsystems.inc b/recipes-qt/qt5/qtsystems.inc
index 2c6d144b..af4eb41a 100644
--- a/recipes-qt/qt5/qtsystems.inc
+++ b/recipes-qt/qt5/qtsystems.inc
@@ -1,6 +1,6 @@
-require qt5module.inc
+require qt5.inc
-DEPENDS += "qtdeclarative qtjsondb udev bluez4 gconf"
+DEPENDS += "qtbase qtdeclarative qtjsondb udev bluez4 gconf"
LICENSE = "BSD & LGPL-2.1 & GFDL-1.3"
# LICENSE files are missing in 5.0.0
diff --git a/recipes-qt/qt5/qtwayland.inc b/recipes-qt/qt5/qtwayland.inc
index 32fb08e9..0c76b993 100644
--- a/recipes-qt/qt5/qtwayland.inc
+++ b/recipes-qt/qt5/qtwayland.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
LICENSE = "BSD & LGPL-2.1 | GPL-3.0"
LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenode.cpp;endline=40;md5=e38eccd7e9a6a149c9e31b6fb47daac1 \
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenod
# make it easier to remove by .bbappend (e.g. for building qtwayland with danny which doesn't
# have libxkbcommon in oe-core).
XKB_DEPENDS = "libxkbcommon"
-DEPENDS += "qtdeclarative wayland wayland-native ${XKB_DEPENDS}"
+DEPENDS += "qtbase qtdeclarative wayland wayland-native ${XKB_DEPENDS}"
INC_PR = "r1"
diff --git a/recipes-qt/qt5/qtwebkit.inc b/recipes-qt/qt5/qtwebkit.inc
index 8f6f9a04..a07fe7e2 100644
--- a/recipes-qt/qt5/qtwebkit.inc
+++ b/recipes-qt/qt5/qtwebkit.inc
@@ -1,4 +1,4 @@
-require qt5module.inc
+require qt5.inc
LICENSE = "BSD & LGPLv2+"
LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
diff --git a/recipes-qt/qt5/qtxmlpatterns.inc b/recipes-qt/qt5/qtxmlpatterns.inc
index 8c28b2b4..26e06d4d 100644
--- a/recipes-qt/qt5/qtxmlpatterns.inc
+++ b/recipes-qt/qt5/qtxmlpatterns.inc
@@ -1,3 +1,5 @@
-require qt5module.inc
+require qt5.inc
+
+DEPENDS += "qtbase"
INC_PR = "r0"