aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-04-03 13:22:08 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2023-04-03 13:24:50 +0200
commitc640179be310129e11a0cec92e0ed1718b107b54 (patch)
tree67e1b0544c1cd6b3d293130687c4684c535c7a63
parentcbc907aea42c8f571d4adadb3a5451fad11f02aa (diff)
qtdeclarative: backport fix for qml examples installation
* Fixes https://github.com/meta-qt5/meta-qt5/issues/318 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch2
-rw-r--r--recipes-qt/qt5/qtdeclarative/0002-Examples-Fix-double-installation-of-.qml-files.patch93
-rw-r--r--recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch (renamed from recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch)11
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb8
4 files changed, 104 insertions, 10 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch b/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch
index 0eb78467..cd7335ce 100644
--- a/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch
+++ b/recipes-qt/qt5/qtdeclarative/0001-Fix-build-with-gcc-11.patch
@@ -1,4 +1,4 @@
-From aca2df64cd0cb6c4a8c03dc564c59f2a805dda7c Mon Sep 17 00:00:00 2001
+From b94e624ddf82c4d25df23ce3681ea6a64df99878 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 4 Mar 2021 14:37:06 -0800
Subject: [PATCH] Fix build with gcc-11
diff --git a/recipes-qt/qt5/qtdeclarative/0002-Examples-Fix-double-installation-of-.qml-files.patch b/recipes-qt/qt5/qtdeclarative/0002-Examples-Fix-double-installation-of-.qml-files.patch
new file mode 100644
index 00000000..ef42abf2
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0002-Examples-Fix-double-installation-of-.qml-files.patch
@@ -0,0 +1,93 @@
+From 621aa22cdac3901200180903433ae443ec94f158 Mon Sep 17 00:00:00 2001
+From: Kai Koehne <kai.koehne@qt.io>
+Date: Wed, 27 May 2020 11:55:05 +0200
+Subject: [PATCH] Examples: Fix double installation of .qml files
+
+qt_example_installs.prf already generates install rules for all example
+sources, including content of .qrc files.
+
+Pick-to: 5.15
+Fixes: QTBUG-84301
+Change-Id: I3454b19849af489c5819c51867781cc97f1eb285
+Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+Upstream-Status: Backport [5.15 https://codereview.qt-project.org/c/qt/qtdeclarative/+/302578]
+
+ .../extending-qml/chapter1-basics/chapter1-basics.pro | 6 +-----
+ .../extending-qml/chapter2-methods/chapter2-methods.pro | 6 +-----
+ .../extending-qml/chapter3-bindings/chapter3-bindings.pro | 6 +-----
+ .../chapter4-customPropertyTypes.pro | 6 +-----
+ .../chapter5-listproperties/chapter5-listproperties.pro | 6 +-----
+ 5 files changed, 5 insertions(+), 25 deletions(-)
+
+diff --git a/examples/qml/tutorials/extending-qml/chapter1-basics/chapter1-basics.pro b/examples/qml/tutorials/extending-qml/chapter1-basics/chapter1-basics.pro
+index 9911e02484..8b862bdae9 100644
+--- a/examples/qml/tutorials/extending-qml/chapter1-basics/chapter1-basics.pro
++++ b/examples/qml/tutorials/extending-qml/chapter1-basics/chapter1-basics.pro
+@@ -8,8 +8,4 @@ RESOURCES += chapter1-basics.qrc
+
+ DESTPATH = $$[QT_INSTALL_EXAMPLES]/qml/tutorials/extending-qml/chapter1-basics
+ target.path = $$DESTPATH
+-
+-qml.files = *.qml
+-qml.path = $$DESTPATH
+-
+-INSTALLS += target qml
++INSTALLS += target
+diff --git a/examples/qml/tutorials/extending-qml/chapter2-methods/chapter2-methods.pro b/examples/qml/tutorials/extending-qml/chapter2-methods/chapter2-methods.pro
+index 7fd850ce36..15b790d24f 100644
+--- a/examples/qml/tutorials/extending-qml/chapter2-methods/chapter2-methods.pro
++++ b/examples/qml/tutorials/extending-qml/chapter2-methods/chapter2-methods.pro
+@@ -8,8 +8,4 @@ RESOURCES += chapter2-methods.qrc
+
+ DESTPATH = $$[QT_INSTALL_EXAMPLES]/qml/tutorials/extending-qml/chapter2-methods
+ target.path = $$DESTPATH
+-
+-qml.files = *.qml
+-qml.path = $$DESTPATH
+-
+-INSTALLS += target qml
++INSTALLS += target
+diff --git a/examples/qml/tutorials/extending-qml/chapter3-bindings/chapter3-bindings.pro b/examples/qml/tutorials/extending-qml/chapter3-bindings/chapter3-bindings.pro
+index 1ae83f71eb..ab1ae7a790 100644
+--- a/examples/qml/tutorials/extending-qml/chapter3-bindings/chapter3-bindings.pro
++++ b/examples/qml/tutorials/extending-qml/chapter3-bindings/chapter3-bindings.pro
+@@ -8,8 +8,4 @@ RESOURCES += chapter3-bindings.qrc
+
+ DESTPATH = $$[QT_INSTALL_EXAMPLES]/qml/tutorials/extending-qml/chapter3-bindings
+ target.path = $$DESTPATH
+-
+-qml.files = *.qml
+-qml.path = $$DESTPATH
+-
+-INSTALLS += target qml
++INSTALLS += target
+diff --git a/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/chapter4-customPropertyTypes.pro b/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/chapter4-customPropertyTypes.pro
+index 12dfbd6280..05ca3495cb 100644
+--- a/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/chapter4-customPropertyTypes.pro
++++ b/examples/qml/tutorials/extending-qml/chapter4-customPropertyTypes/chapter4-customPropertyTypes.pro
+@@ -10,8 +10,4 @@ RESOURCES += chapter4-customPropertyTypes.qrc
+
+ DESTPATH = $$[QT_INSTALL_EXAMPLES]/qml/tutorials/extending-qml/chapter4-customPropertyTypes
+ target.path = $$DESTPATH
+-
+-qml.files = *.qml
+-qml.path = $$DESTPATH
+-
+-INSTALLS += target qml
++INSTALLS += target
+diff --git a/examples/qml/tutorials/extending-qml/chapter5-listproperties/chapter5-listproperties.pro b/examples/qml/tutorials/extending-qml/chapter5-listproperties/chapter5-listproperties.pro
+index 67d1cd35c3..7f9ff55a93 100644
+--- a/examples/qml/tutorials/extending-qml/chapter5-listproperties/chapter5-listproperties.pro
++++ b/examples/qml/tutorials/extending-qml/chapter5-listproperties/chapter5-listproperties.pro
+@@ -10,8 +10,4 @@ RESOURCES += chapter5-listproperties.qrc
+
+ DESTPATH = $$[QT_INSTALL_EXAMPLES]/qml/tutorials/extending-qml/chapter5-listproperties
+ target.path = $$DESTPATH
+-
+-qml.files = *.qml
+-qml.path = $$DESTPATH
+-
+-INSTALLS += target qml
++INSTALLS += target
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch b/recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch
index 6c856b3c..87779667 100644
--- a/recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch
+++ b/recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch
@@ -1,4 +1,4 @@
-From dc94032e6132b41bd6927357e4a57c31436294eb Mon Sep 17 00:00:00 2001
+From 78baea7367cd6a3d7c07861374dbdaac7674b14e Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 26 Nov 2019 21:10:03 -0800
Subject: [PATCH] Use python3 explicitly
@@ -12,7 +12,7 @@ Upstream-Status: Pending
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/qtdeclarative.pro b/qtdeclarative.pro
-index 5b94da9b6..0e3496ce8 100644
+index 5b94da9b69..0e3496ce80 100644
--- a/qtdeclarative.pro
+++ b/qtdeclarative.pro
@@ -2,7 +2,7 @@ CONFIG += tests_need_tools examples_need_tools
@@ -25,7 +25,7 @@ index 5b94da9b6..0e3496ce8 100644
tmp = python_available
CONFIG += $$tmp
diff --git a/src/3rdparty/masm/masm.pri b/src/3rdparty/masm/masm.pri
-index 0e63ac2ce..7a30ab64e 100644
+index 0e63ac2ce5..7a30ab64eb 100644
--- a/src/3rdparty/masm/masm.pri
+++ b/src/3rdparty/masm/masm.pri
@@ -58,7 +58,7 @@ contains(DEFINES, WTF_USE_UDIS86=1) {
@@ -47,7 +47,7 @@ index 0e63ac2ce..7a30ab64e 100644
# Taken from WebKit/Tools/qmake/mkspecs/features/unix/default_post.prf
diff --git a/tests/auto/qml/ecmascripttests/test262.py b/tests/auto/qml/ecmascripttests/test262.py
-index 19551e3ba..bf3f79a45 100755
+index 19551e3ba2..bf3f79a45f 100755
--- a/tests/auto/qml/ecmascripttests/test262.py
+++ b/tests/auto/qml/ecmascripttests/test262.py
@@ -1,4 +1,4 @@
@@ -56,6 +56,3 @@ index 19551e3ba..bf3f79a45 100755
#############################################################################
##
## Copyright (C) 2017 The Qt Company Ltd.
---
-2.24.0
-
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index d05e2f75..0105e05a 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -28,6 +28,10 @@ SRCREV = "824570979e211171f158e7fcab15c599c5e7ca4e"
BBCLASSEXTEND =+ "native nativesdk"
-SRC_URI += "file://0001-Fix-build-with-gcc-11.patch \
- file://0001-Use-python3-explicitly.patch \
+# Patches from https://github.com/meta-qt5/qtdeclarative/commits/b5.12
+# 5.12.meta-qt5.8
+SRC_URI += " \
+ file://0001-Fix-build-with-gcc-11.patch \
+ file://0002-Examples-Fix-double-installation-of-.qml-files.patch \
+ file://0003-Use-python3-explicitly.patch \
"