aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-04-03 13:58:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2023-04-03 13:58:38 +0200
commitd5b3c2b746393958661ada11f2d3a6b2767ae4fc (patch)
tree7ce259610f4ca3c54842457dcc6a9ffcfdcf0123
parentc640179be310129e11a0cec92e0ed1718b107b54 (diff)
qtdeclarative: backport one more fix for qml examples installation
* Fixes https://github.com/meta-qt5/meta-qt5/issues/318 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch3
-rw-r--r--recipes-qt/qt5/qtdeclarative/0004-simplematerial-example-Fix-double-installation-of-ma.patch33
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb3
3 files changed, 37 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch b/recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch
index 87779667..c028f7b1 100644
--- a/recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch
+++ b/recipes-qt/qt5/qtdeclarative/0003-Use-python3-explicitly.patch
@@ -4,8 +4,9 @@ Date: Tue, 26 Nov 2019 21:10:03 -0800
Subject: [PATCH] Use python3 explicitly
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Pending
---
+Upstream-Status: Backport [5.15 has slightly different implementation https://codereview.qt-project.org/c/qt/qtdeclarative/+/300934]
+
qtdeclarative.pro | 2 +-
src/3rdparty/masm/masm.pri | 4 ++--
tests/auto/qml/ecmascripttests/test262.py | 2 +-
diff --git a/recipes-qt/qt5/qtdeclarative/0004-simplematerial-example-Fix-double-installation-of-ma.patch b/recipes-qt/qt5/qtdeclarative/0004-simplematerial-example-Fix-double-installation-of-ma.patch
new file mode 100644
index 00000000..24d4f2a9
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0004-simplematerial-example-Fix-double-installation-of-ma.patch
@@ -0,0 +1,33 @@
+From 0b50d9925f1770a7bcb005732acfc7d13cdd64fd Mon Sep 17 00:00:00 2001
+From: Alexander Volkov <avolkov@astralinux.ru>
+Date: Mon, 22 Jun 2020 13:25:06 +0300
+Subject: [PATCH] simplematerial example: Fix double installation of main.qml
+
+qt_example_installs.prf already generates install rules for all example
+sources, including content of .qrc files.
+
+This commit amends bbb6071dc69a2513d2586faaf9896841bf724786.
+
+Task-number: QTBUG-84301
+Change-Id: Idfef30501dfaaaddebf773aaa690206eedb458fc
+Reviewed-by: Kai Koehne <kai.koehne@qt.io>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+Upstream-Status: Backport [5.15 https://codereview.qt-project.org/c/qt/qtdeclarative/+/305178]
+
+ examples/quick/scenegraph/simplematerial/simplematerial.pro | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/examples/quick/scenegraph/simplematerial/simplematerial.pro b/examples/quick/scenegraph/simplematerial/simplematerial.pro
+index 6ae935f357..12b1c43226 100644
+--- a/examples/quick/scenegraph/simplematerial/simplematerial.pro
++++ b/examples/quick/scenegraph/simplematerial/simplematerial.pro
+@@ -6,7 +6,4 @@ SOURCES += \
+ RESOURCES += simplematerial.qrc
+
+ target.path = $$[QT_INSTALL_EXAMPLES]/quick/scenegraph/simplematerial
+-qml.files = main.qml
+-qml.path = $$[QT_INSTALL_EXAMPLES]/quick/scenegraph/simplematerial
+-
+-INSTALLS += target qml
++INSTALLS += target
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 0105e05a..ca444096 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -29,9 +29,10 @@ SRCREV = "824570979e211171f158e7fcab15c599c5e7ca4e"
BBCLASSEXTEND =+ "native nativesdk"
# Patches from https://github.com/meta-qt5/qtdeclarative/commits/b5.12
-# 5.12.meta-qt5.8
+# 5.12.meta-qt5.9
SRC_URI += " \
file://0001-Fix-build-with-gcc-11.patch \
file://0002-Examples-Fix-double-installation-of-.qml-files.patch \
file://0003-Use-python3-explicitly.patch \
+ file://0004-simplematerial-example-Fix-double-installation-of-ma.patch \
"