aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-12-05 06:38:42 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2022-12-06 16:08:37 +0100
commitc555401feaf6b746d44d52359913a17e652298e3 (patch)
tree05ff483c8768c5f49b5e6f7faff377174b0a85f1
parent2df0f760c200c932cfbb61a0ad684896dfe49e07 (diff)
qtbase: add -DUSE_X11 Flag
Recently Mesa synced egl headers with khronos. Until now eglplatform.h added the xlib headers as long as it hasn't been explicitly disabled with EGL_NO_X11. Now its one step closer to deprecating X11 and the headers are only included if USE_X11 is set. If missing qtbase silently refuses to build the EGL_X11 Plugin. This results e.g. in configure failure for qtwayland, if building with xcomposite-egl PACKAGECONFIG: ERROR: Feature 'xcomposite-egl' was enabled, but the pre-condition 'features.wayland-client && features.opengl && features.egl && features.xlib && libs.xcomposite && features.egl_x11' failed. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index b6b9f1ca..09dfbd48 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -116,7 +116,7 @@ PACKAGECONFIG[no-opengl] = "-no-opengl"
PACKAGECONFIG[tslib] = "-tslib,-no-tslib,tslib"
PACKAGECONFIG[cups] = "-cups,-no-cups,cups"
PACKAGECONFIG[dbus] = "-dbus,-no-dbus,dbus"
-PACKAGECONFIG[xcb] = "-xcb -xcb-xlib -no-bundled-xcb-xinput,-no-xcb,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil libxext"
+PACKAGECONFIG[xcb] = "-xcb -xcb-xlib -no-bundled-xcb-xinput -DUSE_X11=ON,-no-xcb,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil libxext"
PACKAGECONFIG[sql-ibase] = "-sql-ibase,-no-sql-ibase"
PACKAGECONFIG[sql-mysql] = "-sql-mysql -mysql_config ${STAGING_BINDIR_CROSS}/mysql_config,-no-sql-mysql,mysql5"
PACKAGECONFIG[sql-psql] = "-sql-psql,-no-sql-psql,postgresql"