aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-09 20:53:33 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-20 00:55:36 +0000
commit7223816fe8885ec4220f649e13e1f32ad2ca2385 (patch)
tree2f0cb7dc30ac53c7ac05d649b31680733946cc38
parent4c3d66f0b8a1f27c5ccb2027fa612eef2904ef6a (diff)
maliit: Disable tests
They do not build reliably, especially when using clang Fixes | ../../../recipe-sysroot/usr/include/QtTest/qtestcase.h:340:34: error: invalid operands to binary expression ('const MImServerCommonOptions' and 'const MImServerCommonOptions') | return compare_helper(t1 == t2, "Compared values are not the same", | ~~ ^ ~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb4
-rw-r--r--recipes-qt/maliit/maliit-plugins-qt5_git.bb3
2 files changed, 7 insertions, 0 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index fabb43ee..232e8252 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -57,6 +57,10 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=enable-dbus-activation \
CONFIG+=qt5-inputcontext \
"
+
+# tests fail to build with clang
+EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+
EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
do_install_append() {
diff --git a/recipes-qt/maliit/maliit-plugins-qt5_git.bb b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
index 54bc7432..8225cb54 100644
--- a/recipes-qt/maliit/maliit-plugins-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
@@ -23,6 +23,9 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=nodoc \
"
+# tests fail to build with clang
+EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+
FILES_${PN} += "\
${libdir}/maliit \
${datadir} \