aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiulian Gonçalves Vivan <giulian@ossystems.com.br>2014-02-18 17:44:55 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-02-24 09:21:21 -0300
commit0d20b53eb8b4c8d09ee8281efbd045aa1561b08c (patch)
tree838310795c10329b7750c0117dab22f152ecd546
parent9b4dc4d2cf9de6e037df70684d7f6cfee7e4905b (diff)
qsiv: add the qsiv 1.1 example app
This provides a simple image viewer for demonstration purposes. Signed-off-by: Giulian Gonçalves Vivan <giulian@ossystems.com.br>
-rw-r--r--recipes-qt/qsiv/qsiv_1.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qt/qsiv/qsiv_1.1.bb b/recipes-qt/qsiv/qsiv_1.1.bb
new file mode 100644
index 00000000..bb2efa69
--- /dev/null
+++ b/recipes-qt/qsiv/qsiv_1.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Qt Simple Image Viewer"
+DESCRIPTION = "A simple image viewer using a mix of C++ and qml code for demonstration."
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=11c7965a9059e287de5d93b98adf6d1a"
+DEPENDS = "qtdeclarative"
+
+SRCREV = "7b9810b0f02f9ac74fae3ead6e2e9fb5c1382173"
+SRC_URI = "git://code.ossystems.com.br/qt/qsiv;protocol=http"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+EXTRA_QMAKEVARS_PRE += "target.path=${libdir}/${P}"
+
+do_install_append() {
+ install -d ${D}${bindir}
+ echo "#!/bin/sh" > ${D}${bindir}/qsiv
+ echo "export QML_IMPORT_PATH=${libdir}/${P}/qml/qsiv" >> ${D}${bindir}/qsiv
+ echo "export QML2_IMPORT_PATH=${libdir}/${P}/qml/qsiv" >> ${D}${bindir}/qsiv
+ echo "${libdir}/${P}/qsiv \$* " >> ${D}${bindir}/qsiv
+ chmod +x ${D}${bindir}/qsiv
+}
+
+FILES_${PN} += "${libdir}/${P}"
+RDEPENDS_${PN} += "qtdeclarative-qmlplugins"
+
+FILES_${PN}-dbg += "${libdir}/${P}/.debug"