aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-11-25 23:33:37 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-12 16:32:02 +0100
commit512c859380a36b753b5fcca21a31aea4d85a1737 (patch)
tree5e49e55226c24b5bd8e2fda7758fa5ed176e06cd
parent7b898fdc664ca04d50becddb7f57570436bd717e (diff)
nativesdk-qttools: add nativesdk version of qttools necessary for SDK tools
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qttools.inc25
-rw-r--r--recipes-qt/qt5/nativesdk-qttools_5.1.1.bb7
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qttools.inc b/recipes-qt/qt5/nativesdk-qttools.inc
new file mode 100644
index 00000000..e9b29498
--- /dev/null
+++ b/recipes-qt/qt5/nativesdk-qttools.inc
@@ -0,0 +1,25 @@
+DEPENDS = "nativesdk-qtbase qtbase-native"
+
+QT_MODULE = "qttools"
+
+require nativesdk-qt5.inc
+
+SRC_URI += "file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch"
+
+PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
+
+FILES_${PN}-dbg = " \
+ ${OE_QMAKE_PATH_BINS}/.debug \
+"
+
+FILES_${PN} = " \
+ ${OE_QMAKE_PATH_BINS}/* \
+"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S} CONFIG+=linguistonly
+}
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
diff --git a/recipes-qt/qt5/nativesdk-qttools_5.1.1.bb b/recipes-qt/qt5/nativesdk-qttools_5.1.1.bb
new file mode 100644
index 00000000..b56f430b
--- /dev/null
+++ b/recipes-qt/qt5/nativesdk-qttools_5.1.1.bb
@@ -0,0 +1,7 @@
+require qt5-${PV}.inc
+require ${PN}.inc
+
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/qttools-${PV}:"
+
+SRC_URI[md5sum] = "022073d32ff9d408de0182b5d1f01781"
+SRC_URI[sha256sum] = "2b42c6d5feeccffb67e890b86a150bae64dd2ff550be39a3cc449ee0e95462b6"