aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-06-30 15:04:28 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:45 +0200
commit164f9aa413ce3dc93ebc5cfedecb366bcd984091 (patch)
tree0500854604feb7cb5233189913370a5374e45125
parent9f802b01e54709773e0a070beefb78d8f9d5c01f (diff)
qt5everywheredemo: Create recipe to demonstrate qt5 example.
Qt5 Everywhere Demo provides a quick tour of Qt 5.0, primarily focusing on its graphical capabilities. This recipe originated from the wandboard wiki page http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/examples/qt5everywheredemo_1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-qt/examples/qt5everywheredemo_1.0.bb b/recipes-qt/examples/qt5everywheredemo_1.0.bb
new file mode 100644
index 00000000..4f7022c6
--- /dev/null
+++ b/recipes-qt/examples/qt5everywheredemo_1.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Qt5 everywhere demo"
+DESCRIPTION = "Quick tour of Qt 5.0, primarily focusing on its graphical capabilities."
+HOMEPAGE = "https://qt.gitorious.org/qt-labs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://main.cpp;md5=1187cb795a0f96bce64e63dd1a67dc2b"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRCREV = "9a868f96ee63c21ceda890d8dfc9d33f093d1b6d"
+SRC_URI = "git://gitorious.org/qt-labs/qt5-everywhere-demo.git"
+
+S = "${WORKDIR}/git/QtDemo"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/QtDemo ${D}${datadir}/${P}
+ cp -a ${S}/qml ${D}${datadir}/${P}
+}
+
+FILES_${PN}-dbg += "${datadir}/${P}/.debug"
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"