aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-09-05 15:16:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 14:43:51 +0200
commitfbf33d6d9e283e4d05add5b746b8b94b549c2213 (patch)
tree96816925100401990596e435461197a06a681953
parent284020d9344b6fbd88d9c6d5ff6fbaef430a775b (diff)
cmake: disable test for Qt5Core
| CMake Error at tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:27 (message): | The imported target "Qt5::Core" references the file | | "/qmake" | | but this file does not exist. Possible reasons include: | | * The file was deleted, renamed, or moved to another location. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and contained | | "tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake" | | but not all the files it references. | | Call Stack (most recent call first): | tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake:6 (_qt5_Core_check_file_exists) | tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:130 (include) | Tests/RunCMake/CMakeLists.txt:80 (find_package) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-devtools/cmake/cmake_2.8.11.2.bbappend7
2 files changed, 8 insertions, 1 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 2aee9a55..3b47b7f7 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -12,7 +12,7 @@
BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/*/recipes-*/*/*.bbappend"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "qt5-layer"
BBFILE_PATTERN_qt5-layer := "^${LAYERDIR}/"
diff --git a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
new file mode 100644
index 00000000..0ad2d2fb
--- /dev/null
+++ b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
@@ -0,0 +1,7 @@
+# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
+# and possibly missing qmake binary (qtbase-native can be removed from sysroot
+# e.g. in order to upgrade it, even when there is target qtbase)
+
+do_configure_prepend() {
+ sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt
+}