aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-10-08 12:10:10 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-08 15:49:09 +0200
commit39e3e180960f4d16ab0917a465da84fbab9fc637 (patch)
tree3e2322f82c16e102b4618f1a93ea82eee374d7b9
parent0d73b7f2892862030af0b6f5341c9eb9051c5255 (diff)
qtjsondb: Remove unsupported module
* https://bugreports.qt-project.org/browse/QTBUG-31741 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase-native_5.1.1.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtjsondb.inc10
-rw-r--r--recipes-qt/qt5/qtjsondb_git.bb22
4 files changed, 2 insertions, 34 deletions
diff --git a/recipes-qt/qt5/qtbase-native_5.1.1.bb b/recipes-qt/qt5/qtbase-native_5.1.1.bb
index 2ee644c0..612553c6 100644
--- a/recipes-qt/qt5/qtbase-native_5.1.1.bb
+++ b/recipes-qt/qt5/qtbase-native_5.1.1.bb
@@ -3,7 +3,7 @@ require ${PN}.inc
do_install_append() {
# for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
- # e.g. qt3d, qtjsondb, qtwayland
+ # e.g. qt3d, qtwayland
ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
}
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 0db74da8..96e7c298 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -3,7 +3,7 @@ require ${PN}.inc
do_install_append() {
# for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
- # e.g. qt3d, qtjsondb, qtwayland
+ # e.g. qt3d, qtwayland
ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
}
diff --git a/recipes-qt/qt5/qtjsondb.inc b/recipes-qt/qt5/qtjsondb.inc
deleted file mode 100644
index 33816de3..00000000
--- a/recipes-qt/qt5/qtjsondb.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-require qt5.inc
-
-DEPENDS += "qtdeclarative ${ICU}"
-
-LICENSE = "BSD & LGPL-2.1 & GFDL-1.3"
-# this is for latest SRCREV:
-LIC_FILES_CHKSUM = "file://${S}/doc/src/qtjsondb.qdoc;endline=26;md5=757f4eda130ceff3ca0985dde715af07 \
- file://${S}/examples/jsondb-client/example.qml;endline=39;md5=5213e8171c07d54db7107f29ac2f7b5e \
- file://${S}/src/client/qjsondbglobal.h;endline=40;md5=34f5660524f0d70941d0416511ef49a0 \
-"
diff --git a/recipes-qt/qt5/qtjsondb_git.bb b/recipes-qt/qt5/qtjsondb_git.bb
deleted file mode 100644
index 012bf9a3..00000000
--- a/recipes-qt/qt5/qtjsondb_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-require qt5-git.inc
-require ${PN}.inc
-
-# qtjsondb wasn't released yet, last tag before this SRCREV isn't even 5.0.0-beta1, but lets use it for now
-PV = "4.999+5.0.0-beta1+git${SRCPV}"
-
-QT_MODULE_BRANCH = "master"
-
-SRCREV = "27a2b5d9a0f081f71c26a1716721411606f8dedf"
-
-do_configure_prepend() {
- # Temporary hack to get qtjsondb build for Qt 5.1.0
- if ! grep -q MODULE_VERSION ${S}/.qmake.conf; then
- echo "MODULE_VERSION = 5.1.0" >> ${S}/.qmake.conf
- fi
-}
-
-do_configure_append() {
- # work around for this issue:
- # http://www.mail-archive.com/ci-reports@qt-project.org/msg09692.html
- sed -i '/^INCPATH/s#-I\.$#-I. -I../../include/QtJsonDbPartition#g' ${B}/src/client/Makefile
-}