aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-25 17:45:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-25 17:45:18 +0200
commitbb4c8adeeb3107074fbf63bddf292059b370afa5 (patch)
treef45618693446f651c7bbb69569e5949af47f63ef
parent07301a163688682b5b3e5dddada6da63593917b0 (diff)
qtwayland: demote 5.1.0+git version a bit
* 5.0.2+git should stay default for people without qt5-versions.inc * make sure that % isn't appended twice in qt5-versions.inc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/distro/include/qt5-versions.inc6
-rw-r--r--recipes-qt/qt5/qtwayland_5.1.0+git.bb3
2 files changed, 8 insertions, 1 deletions
diff --git a/conf/distro/include/qt5-versions.inc b/conf/distro/include/qt5-versions.inc
index b946a6a6..35dd211a 100644
--- a/conf/distro/include/qt5-versions.inc
+++ b/conf/distro/include/qt5-versions.inc
@@ -17,4 +17,8 @@ PREFERRED_VERSION_qtscript = "${QT5_VERSION}"
PREFERRED_VERSION_qtsvg = "${QT5_VERSION}"
PREFERRED_VERSION_qtwebkit = "${QT5_VERSION}"
PREFERRED_VERSION_qtxmlpatterns = "${QT5_VERSION}"
-PREFERRED_VERSION_qtwayland = "${QT5_VERSION}%"
+
+# append % only if it isn't included already
+# 5.1.0+git%% won't work and it's exactly where we need to overcome DEFAULT_PREFERENCE with PREFERRED_VERSION
+QT5_VERSION_WAYLAND = "${@base_contains('QT5_VERSION', '5.1.0+git%', '${QT5_VERSION}', '${QT5_VERSION}%', d)}"
+PREFERRED_VERSION_qtwayland = "${QT5_VERSION_WAYLAND}"
diff --git a/recipes-qt/qt5/qtwayland_5.1.0+git.bb b/recipes-qt/qt5/qtwayland_5.1.0+git.bb
index aaa439cf..31ed85c3 100644
--- a/recipes-qt/qt5/qtwayland_5.1.0+git.bb
+++ b/recipes-qt/qt5/qtwayland_5.1.0+git.bb
@@ -5,6 +5,9 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/${BPN}-5.1.0+git:"
DEPENDS += "qtwayland-native"
+# qtwayland_git has -1 and should be default
+DEFAULT_PREFERRENCE = "-2"
+
# qtwayland wasn't released yet, last tag before this SRCREV is 5.0.0-beta1
# this PV is only to indicate that this recipe is compatible with qt5 5.1.0
# while qtwayland_git stays compatible with 5.0.2