aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-23 10:10:14 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-23 08:10:07 +0000
commit000ffe6066219e749c95269dd72edb9b662d4b63 (patch)
treee1dd5577a045865d46df747af95882422ff6128c
parent6deab79316572faceaadc72c36796384eb20fea9 (diff)
qt5: Disable ltcg for host_build
debug-prefix-map does not work correctly for static libraries when using ltcg, and since host_build compilations link agaist the libQt5Bootstrap.a library, it breaks source file packaging into debug packages. Task-number: QTBUG-71230 Change-Id: I33a3f2314594ca0d2520c6c289bf0505e11c189c Reviewed-by: Ville Voutilainen <ville.voutilainen@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch26
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index dac1e9b2..01fa84fa 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -38,6 +38,7 @@ SRC_URI += "\
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
+ file://0015-Disable-ltcg-for-host_build.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index f2e56327..67dfc27d 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -33,6 +33,7 @@ SRC_URI += "\
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
+ file://0015-Disable-ltcg-for-host_build.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch
new file mode 100644
index 00000000..8b961e60
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0015-Disable-ltcg-for-host_build.patch
@@ -0,0 +1,26 @@
+From 94383531bde019ba113cc416b5cf3627e18ffef3 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Tue, 23 Oct 2018 09:54:57 +0300
+Subject: [PATCH] Disable ltcg for host_build
+
+debug-prefix-map does not work correctly for static libraries
+when using ltcg, and since host_build compilations link agaist
+the libQt5Bootstrap.a library, it breaks source file packaging
+into debug packages.
+
+Task-number: QTBUG-71230
+Upstream-Status: Inappropriate [embedded specific]
+---
+ mkspecs/features/ltcg.prf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf
+index ccf0226272..482e5b573d 100644
+--- a/mkspecs/features/ltcg.prf
++++ b/mkspecs/features/ltcg.prf
+@@ -1,4 +1,4 @@
+-CONFIG(release, debug|release) {
++CONFIG(release, debug|release):!host_build {
+ # We need fat object files when creating static libraries on some platforms
+ # so the linker will know to load a particular object from the library
+ # in the first place. On others, we have special ar and nm to create the symbol
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 7c17c474..b563684b 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -29,6 +29,7 @@ SRC_URI += "\
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
+ file://0015-Disable-ltcg-for-host_build.patch \
"