aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-02 14:03:06 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2022-02-22 13:15:13 +0000
commit42022cad58e8c671fb1852ecaa06a604587f2d66 (patch)
treedf69fc895aeb0e2871f3ed2f169740f6d1ec291e
parent525bd8f18aea0eb174317e7a035a7224d694d03a (diff)
qtbase: Fix build with gcc-11
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch48
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index c8beb108..5422e422 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -43,6 +43,7 @@ SRC_URI += "\
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-eglfs-Prevent-printing-a-warning-in-every-widget-bas.patch \
file://0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch \
+ file://0021-qfloat16-Include-limits-header.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index cc2a106d..6de15ab8 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -38,6 +38,7 @@ SRC_URI += "\
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-eglfs-Prevent-printing-a-warning-in-every-widget-bas.patch \
file://0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch \
+ file://0021-qfloat16-Include-limits-header.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch b/recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch
new file mode 100644
index 00000000..e781392d
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch
@@ -0,0 +1,48 @@
+From f680222892b44b3c1de129dc086613c6fe025c2d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 2 Mar 2021 13:18:47 -0800
+Subject: [PATCH] qfloat16: Include <limits> header
+
+gcc11 complains
+ error: 'numeric_limits' is not a class template
+ | 344 | template<> class numeric_limits<const QT_PREPEND_NAMESPACE(qfloat16)>
+
+This is because its missing right header which perhaps is included
+implicitly in older compilers
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/corelib/global/qfloat16.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/corelib/global/qfloat16.h
++++ b/src/corelib/global/qfloat16.h
+@@ -44,6 +44,7 @@
+ #include <QtCore/qglobal.h>
+ #include <QtCore/qmetatype.h>
+ #include <string.h>
++#include <limits>
+
+ #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
+ // All processors that support AVX2 do support F16C too. That doesn't mean
+--- a/src/corelib/text/qbytearraymatcher.h
++++ b/src/corelib/text/qbytearraymatcher.h
+@@ -40,6 +40,7 @@
+ #ifndef QBYTEARRAYMATCHER_H
+ #define QBYTEARRAYMATCHER_H
+
++#include <limits>
+ #include <QtCore/qbytearray.h>
+
+ QT_BEGIN_NAMESPACE
+--- a/src/corelib/tools/qoffsetstringarray_p.h
++++ b/src/corelib/tools/qoffsetstringarray_p.h
+@@ -55,6 +55,7 @@
+
+ #include <tuple>
+ #include <array>
++#include <limits>
+
+ QT_BEGIN_NAMESPACE
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e41275f7..e0fd1b92 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -34,6 +34,7 @@ SRC_URI += "\
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-eglfs-Prevent-printing-a-warning-in-every-widget-bas.patch \
file://0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch \
+ file://0021-qfloat16-Include-limits-header.patch \
file://0022-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \
file://0023-eglfs-kms-Query-the-current-mode-correctly-via-the-e.patch \
file://0024-eglfs_kms-Do-not-skip-the-initial-SetCrtc.patch \