aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-19 17:51:37 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-20 10:42:50 +0100
commit47fb26deddabe331514d54a5884bb319839d7de8 (patch)
tree46f02a46dd87c4b9433facf35455f2b5b0613a87
parent4060f68d52c91c6b0a9f3cbaaff602262f37bd1e (diff)
recipes: Use python3 during build
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index b8b1d086..690757be 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -1,6 +1,6 @@
require python-pyqt5.inc
-inherit pythonnative python-dir
+inherit python3native python3-dir
DEPENDS += "sip sip-native python"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index e42cf491..30b283c3 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -79,7 +79,7 @@ COMPATIBLE_MACHINE_aarch64 = "(.*)"
inherit qmake5
inherit gettext
-inherit pythonnative
+inherit python3native
inherit perlnative
inherit features_check
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 6cc789f0..5c3247dc 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -18,7 +18,7 @@ SRC_URI += "\
file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
"
-inherit cmake_qt5 perlnative pythonnative
+inherit cmake_qt5 perlnative python3native
# qemuarm build fails with:
# | {standard input}: Assembler messages: