aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingde (Matthew) Zeng <matthew.zeng@windriver.com>2020-05-20 01:48:22 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2020-11-03 17:01:34 +0100
commit6bfe6132d7f728b148653c6029ea3207da5deaee (patch)
tree98f63989828762991f989c109f4a9cdb1786b088
parent298bcbb73896f828f3488be793d9a032703df8b5 (diff)
qt5-creator_git: add x11 and opengl to REQUIRED_DISTRO_FEATURES
Signed-off-by: Mingde (Matthew) Zeng <matthew.zeng@windriver.com> (cherry picked from commit 098b9aca232b07b53bc4db0c7f5274a627670a75)
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 000e135e..d046110b 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -83,3 +83,6 @@ RRECOMMENDS_${PN} += " \
# ERROR: qt5-creator-4.5.1-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: '/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qt5-creator/4.5.1-r0/packages-split/qt5-creator/usr/lib/qt5/qtcreator/libqbscore.so.1.10.1'
INSANE_SKIP_${PN} += "ldflags"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES ?= "x11 opengl"