aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-02-19 19:18:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-02-19 19:59:08 +0100
commitb2a958a4cda20b03c8debc89963fbef469ef5574 (patch)
tree73e24809045b80273846284ef37e4c8fc5da440f
parentabb423512d10d7554e0d62b3a593ce5e436f2756 (diff)
python-pyqt5: disable whole PyQt_OpenGL and QtWidgets, QtQuickWidgets, QtQuick modules without opengl in DISTRO_FEATURES
* fixes: sip: QOpenGLFramebufferObject is undefined in default nodistro setup without opengl in DISTRO_FEATURES Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-python/pyqt5/python-pyqt5.inc4
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5.inc b/recipes-python/pyqt5/python-pyqt5.inc
index b830c9a9..47bf5b9d 100644
--- a/recipes-python/pyqt5/python-pyqt5.inc
+++ b/recipes-python/pyqt5/python-pyqt5.inc
@@ -24,11 +24,11 @@ export STAGING_LIBDIR
PARALLEL_MAKEINST = ""
-DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
+DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '', 'PyQt_OpenGL', d)}"
DISABLED_FEATURES_append_arm = " PyQt_qreal_double"
-PYQT_MODULES = "QtCore QtGui QtNetwork QtWidgets QtXml QtNetwork QtQml QtQuick QtQuickWidgets"
+PYQT_MODULES = "QtCore QtGui QtNetwork QtXml QtNetwork QtQml ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'QtQuick QtWidgets QtQuickWidgets', '', d)}"
do_configure_prepend() {
cd ${S}
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index e051b156..389686c9 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -10,5 +10,3 @@ python() {
DEPENDS += "sip sip-native python"
RDEPENDS_${PN} += "python-core python-sip"
-
-PNBLACKLIST[python-pyqt5] = "Sip fails in do_configure sip: QOpenGLFramebufferObject is undefined"