aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-18 11:32:17 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2020-11-03 17:01:34 +0100
commit298bcbb73896f828f3488be793d9a032703df8b5 (patch)
tree455a0101769df91770211e6bac718bdaf5a461fb
parentb39d7973dd8566bd9a6670f29b3a483f182d3395 (diff)
qt5-creator: Upgrade to 4.12 branch
This fixes build with - qt 5.15 QPainterPath changes - Clang-10 Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit abed512f82ee96c37d98fdd3011f32e6456f03bf)
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-clangformat-AllowShortIfStatementsOnASingleLine-is-n.patch53
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb7
2 files changed, 3 insertions, 57 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0001-clangformat-AllowShortIfStatementsOnASingleLine-is-n.patch b/recipes-qt/qt5/qt5-creator/0001-clangformat-AllowShortIfStatementsOnASingleLine-is-n.patch
deleted file mode 100644
index 7338f02b..00000000
--- a/recipes-qt/qt5/qt5-creator/0001-clangformat-AllowShortIfStatementsOnASingleLine-is-n.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 453c075b67b9d9254bf7331e1e3be287f240a9e0 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 3 Sep 2019 13:31:12 -0700
-Subject: [PATCH] clangformat: AllowShortIfStatementsOnASingleLine is not
- boolean anymore
-
-https://reviews.llvm.org/D59087 has implemented multiple states for AllowShortIfStatementsOnASingleLine
-
-Fixes
-../../../../git/src/plugins/clangformat/clangformatutils.cpp:63:49: error: assigning to 'clang::format::FormatStyle::ShortIfStyle' from incompatible type 'bool'
- style.AllowShortIfStatementsOnASingleLine = false;
- ^~~~~
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/plugins/clangformat/clangformatutils.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/src/plugins/clangformat/clangformatutils.cpp
-+++ b/src/plugins/clangformat/clangformatutils.cpp
-@@ -57,10 +57,18 @@ static clang::format::FormatStyle qtcSty
- style.AlignOperands = true;
- style.AlignTrailingComments = true;
- style.AllowAllParametersOfDeclarationOnNextLine = true;
-+#if Q_CC_CLANG < 1000
- style.AllowShortBlocksOnASingleLine = false;
-+#else
-+ style.AllowShortBlocksOnASingleLine = FormatStyle::SBS_Never;
-+#endif
- style.AllowShortCaseLabelsOnASingleLine = false;
- style.AllowShortFunctionsOnASingleLine = FormatStyle::SFS_Inline;
-+#if Q_CC_CLANG < 900
- style.AllowShortIfStatementsOnASingleLine = false;
-+#else
-+ style.AllowShortIfStatementsOnASingleLine = FormatStyle::SIS_Never;
-+#endif
- style.AllowShortLoopsOnASingleLine = false;
- style.AlwaysBreakAfterReturnType = FormatStyle::RTBS_None;
- style.AlwaysBreakBeforeMultilineStrings = false;
-@@ -68,7 +76,11 @@ static clang::format::FormatStyle qtcSty
- style.BinPackArguments = false;
- style.BinPackParameters = false;
- style.BraceWrapping.AfterClass = true;
-+#if Q_CC_CLANG < 1000
- style.BraceWrapping.AfterControlStatement = false;
-+#else
-+ style.BraceWrapping.AfterControlStatement = FormatStyle::BWACS_Never;
-+#endif
- style.BraceWrapping.AfterEnum = false;
- style.BraceWrapping.AfterFunction = true;
- style.BraceWrapping.AfterNamespace = false;
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 3c3420ca..000e135e 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -18,14 +18,13 @@ DEPENDS += "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qtto
DEPENDS_append_toolchain-clang = " clang llvm-common"
DEPENDS_append_libc-musl = " libexecinfo"
-SRCREV = "8181363fa90eb651591bf71e1a840e1c998429f4"
-PV = "4.9.2+git${SRCPV}"
+SRCREV = "9e057a55368286058023510efc328f68250ecb5e"
+PV = "4.12.0+git${SRCPV}"
# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2
# 4.9.2.meta-qt5.1
SRC_URI = " \
- git://code.qt.io/qt-creator/qt-creator.git;branch=4.9 \
- file://0001-clangformat-AllowShortIfStatementsOnASingleLine-is-n.patch \
+ git://code.qt.io/qt-creator/qt-creator.git;branch=4.12 \
"
SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"