aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2023-02-24 09:20:00 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2023-02-24 11:14:44 +0200
commita09725171e6f7d339f9cc387435d464658dd6493 (patch)
treed271823a38ad319365a7c16e3706feb97a1f45c3
parentfcbebae5c89122c8b9434928532c43e477e43312 (diff)
qt5: update submodules
Update to latest content in lts-5.15.13 branch. Task-number: QTBUG-109768 Change-Id: I2e761ae24dcf789bd69412eaaf317e78411cf365 Reviewed-by: Tarja Sundqvist <tarja.sundqvist@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qt5-lts.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb4
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch8
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
15 files changed, 20 insertions, 20 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 6368dd50..a35e5e3f 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -202,4 +202,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "cc641080d4f3803f2d9683c2a9181fee7c4bd12a"
+SRCREV = "a13fd415d689be046c13cc562cbbbb5df0e6506a"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 93b44427..431e1c2d 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -44,7 +44,7 @@ do_configure:prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV_qt3d = "7671dec2f30b94f62b52f7490f1496713b1ed589"
+SRCREV_qt3d = "9f2d212416c3c718a5661a09438fb413f9cc53b6"
SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
SRCREV_FORMAT = "qt3d_assimp"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index ea9f6b65..4db3a6d5 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2022 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.15"
+QT_MODULE_BRANCH ?= "5.15.13"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
QT_MODULE_REPO ?= "${QT_MODULE}.git"
diff --git a/recipes-qt/qt5/qt5-lts.inc b/recipes-qt/qt5/qt5-lts.inc
index af611ce4..23c3624a 100644
--- a/recipes-qt/qt5/qt5-lts.inc
+++ b/recipes-qt/qt5/qt5-lts.inc
@@ -4,6 +4,6 @@ QT_LTS_GIT ?= "git://codereview.qt-project.org/${QT_GIT_PROJECT}"
QT_GIT = "${QT_LTS_GIT}"
QT_LTS_GIT_PROTOCOL ?= "ssh"
QT_GIT_PROTOCOL = "${QT_LTS_GIT_PROTOCOL}"
-QT_MODULE_BRANCH = "tqtc/lts-5.15"
+QT_MODULE_BRANCH = "tqtc/lts-5.15.13"
QT_LTS_MODULE_REPO ?= "tqtc-${QT_MODULE}.git"
QT_MODULE_REPO = "${QT_LTS_MODULE_REPO}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index f026ed07..ca8ef34b 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -145,4 +145,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "cc641080d4f3803f2d9683c2a9181fee7c4bd12a"
+SRCREV = "a13fd415d689be046c13cc562cbbbb5df0e6506a"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 36befe60..61d8f01e 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -309,4 +309,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "cc641080d4f3803f2d9683c2a9181fee7c4bd12a"
+SRCREV = "a13fd415d689be046c13cc562cbbbb5df0e6506a"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index ce80326a..c44a0b68 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "c0ad9cef21e2716b002992d7db0cc93ac4f721c3"
+SRCREV = "934bf80e55bf02e16b337272f6b1e598a5de6322"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 3047ff77..ff60da1d 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "a39a1864583c5c78fd25fd33b40128062baf727c"
+SRCREV = "c2fa8ee0ca5e1c8e1fe16fc735fd4614435c80a5"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index d2de34ea..b8693bf7 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -53,6 +53,6 @@ do_install:append:class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "6dc7fa90efa592dc555008b0e8d666c72801f31d"
+SRCREV = "261624e2d44ce9db0cb81abb230942becdb32af8"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 6a8d081a..ec60fb93 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -40,7 +40,7 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS:append:x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "6681426b573125e8a4b0abac45acb10f79a7be65"
+SRCREV = "8d17f204d8aa06f03b5cc17764db28e959073c2a"
# Temporary work around for Qt5MultimediaConfig.cmake referencing non-existent videoeglvideonode directory
do_install:append() {
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index 57ce841b..6a98bd4c 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -180,8 +180,8 @@ SRC_URI:append:libc-musl = "\
file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "ee9794c7263b8b5cb85cd9648c68687e08805aca"
-SRCREV_chromium = "87897ba0a5f5676633c6d44e002c5a7f306a91d7"
+SRCREV_qtwebengine = "c20d3e32c0b033dcc9de82a2548d6f6192e821a3"
+SRCREV_chromium = "f7860adb852a797ad68ce9f5f0d1622633775a2f"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 10f23f6a..567c8552 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -71,4 +71,4 @@ FILES:${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "6ba4bb942fdd477ec178fbf36a80c50434819725"
+SRCREV = "539d89ab7bfd4958aff28364d52e325af59466ff"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 40f6aa4d..56abe4d5 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -48,7 +48,7 @@ PACKAGECONFIG[wayland-vulkan-server-buffer] = "-feature-wayland-vulkan-server-bu
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "4a8dc948412112202e235eb27f9eb35d7b3b8c3b"
+SRCREV = "28a0b1dc46d1324356e8bcad7004303171c3f1a6"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch
index 4cb7c6ea..d0430dba 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch
@@ -1,4 +1,4 @@
-From 03e9ff9a00ea85e84faeb6267d60fb9ed7c0a598 Mon Sep 17 00:00:00 2001
+From 56807e21eb47e3d2567f7772d37d5b19afe860fa Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 16 May 2022 20:01:49 +0000
Subject: [PATCH] chromium: skia: Fix build with gcc-12
@@ -49,7 +49,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+)
diff --git a/chromium/third_party/skia/src/utils/SkParseColor.cpp b/chromium/third_party/skia/src/utils/SkParseColor.cpp
-index 7260365b2c6..cd07eb48650 100644
+index 0dc3497062f..f63f1800501 100644
--- a/chromium/third_party/skia/src/utils/SkParseColor.cpp
+++ b/chromium/third_party/skia/src/utils/SkParseColor.cpp
@@ -7,6 +7,7 @@
@@ -58,5 +58,5 @@ index 7260365b2c6..cd07eb48650 100644
#include "include/utils/SkParse.h"
+#include <vector>
- static constexpr const char* gColorNames[] = {
- "aliceblue",
+ #include <algorithm> // std::lower_bound
+ #include <iterator>
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 1370215f..14c3ce97 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -198,8 +198,8 @@ SRC_URI:append:libc-musl = "\
file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "ee9794c7263b8b5cb85cd9648c68687e08805aca"
-SRCREV_chromium = "87897ba0a5f5676633c6d44e002c5a7f306a91d7"
+SRCREV_qtwebengine = "c20d3e32c0b033dcc9de82a2548d6f6192e821a3"
+SRCREV_chromium = "f7860adb852a797ad68ce9f5f0d1622633775a2f"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"