aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagnagianfranco@yahoo.it>2020-04-15 11:33:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-07-20 16:57:58 +0200
commit5144a99a696a8a72c0765ea0e8be8ceafaa78f85 (patch)
treec11f95c6ee6c1cf99627bfa9f9bcd7f1979b789f
parent8f6ee3a11a53d5cbf841bbe5fbe42b9c0c10f3d4 (diff)
maliit-framework-qt5: fix postinst/postrm scripts
ERROR: do_rootfs: Postinstall scriptlets of ['maliit-framework-qt5'] have failed. If the intention is to defer them to first boot, then please place them into pkg_postinst_ontarget_${PN} (). Deferring to first boot via 'exit 1' is no longer supported. Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> Signed-off-by: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org>
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 1f0dc8d6..72e6be5f 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -75,12 +75,9 @@ do_install_append() {
install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications
}
-pkg_postinst_${PN} () {
+pkg_postinst_ontarget_${PN} () {
#!/bin/sh
# should run online
-if [ "x$D" != "x" ]; then
- exit 1
-fi
echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile
ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop
}
@@ -89,12 +86,11 @@ pkg_postrm_${PN} () {
#!/bin/sh
# should run online
if [ "x$D" = "x" ]; then
- exit 1
-fi
-if [ -e "/etc/xprofile" ]; then
- sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+ if [ -e "/etc/xprofile" ]; then
+ sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+ fi
+ rm -f /etc/xdg/autostart/maliit-server.desktop
fi
-rm -f /etc/xdg/autostart/maliit-server.desktop
}
S = "${WORKDIR}/git"