aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-01-27 19:16:27 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-01-27 20:18:56 +0100
commit9029ee42db92464fc5081ef8e3ab96c2d35adb28 (patch)
tree6dc00dc95d73f00b5f6a67bdf5b2bc153bbbdbd9
parent7520e38d187cba6685848e12b3203f805c8f31a3 (diff)
qt5-native.inc, nativesdk-qt5.inc, nativesdk-packagegroup-qt5-toolchain-host: reorder inherits to fix new QA check
* fixes: WARNING: meta-qt5/recipes-qt/qt5/qtbase-native_git.bb: QA Issue: qtbase-native: native/nativesdk class is not inherited last, this can result in unexpected behaviour. [native-last] WARNING: meta-qt5/recipes-qt/qt5/nativesdk-qtbase_git.bb: QA Issue: nativesdk-qtbase: native/nativesdk class is not inherited last, this can result in unexpected behaviour. [native-last] WARNING: meta-qt5/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb: QA Issue: nativesdk-packagegroup-qt5-toolchain-host: native/nativesdk class is not inherited last, this can result in unexpected behaviour. [native-last] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb2
-rw-r--r--recipes-qt/qt5/nativesdk-qt5.inc2
-rw-r--r--recipes-qt/qt5/qt5-native.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
index de0527c5..3a4d25ac 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
@@ -3,7 +3,7 @@
SUMMARY = "Host packages for the Qt5 standalone SDK or external toolchain"
LICENSE = "MIT"
-inherit nativesdk packagegroup
+inherit packagegroup nativesdk
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
diff --git a/recipes-qt/qt5/nativesdk-qt5.inc b/recipes-qt/qt5/nativesdk-qt5.inc
index 2eb8c142..5472012c 100644
--- a/recipes-qt/qt5/nativesdk-qt5.inc
+++ b/recipes-qt/qt5/nativesdk-qt5.inc
@@ -1,4 +1,4 @@
-inherit nativesdk qmake5_base
+inherit qmake5_base nativesdk
# we don't want conflicts with qt4
OE_QMAKE_PATH_HEADERS = "${OE_QMAKE_PATH_QT_HEADERS}"
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qt5-native.inc
index 76816027..3afc3f28 100644
--- a/recipes-qt/qt5/qt5-native.inc
+++ b/recipes-qt/qt5/qt5-native.inc
@@ -1,4 +1,4 @@
-inherit native qmake5_base
+inherit qmake5_base native
# we don't want conflicts with qt4
OE_QMAKE_PATH_HEADERS = "${OE_QMAKE_PATH_QT_HEADERS}"