aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-31 13:09:04 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2020-11-03 17:01:57 +0100
commita72c04ee797ca70d73784e6bc2fb0701b3ff8a7c (patch)
tree6ca997163a58f695db1b1da831238d683dacaff1
parent1d946dc8f467a37494d3d96a1fa8153199288aff (diff)
qtwebkit: Fix build with python 3.9
backport a fix to build with python 3.9 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch32
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch b/recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch
new file mode 100644
index 00000000..4eef3451
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch
@@ -0,0 +1,32 @@
+From df9f6a8c9d59996b52bfdc5ea6f780de517905e5 Mon Sep 17 00:00:00 2001
+From: Konstantin Tokarev <annulen@yandex.ru>
+Date: Wed, 3 Jun 2020 15:01:42 +0300
+Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to
+ json.load()
+
+In Python 2.7 UTF-8 is assumed by default, while in Python 3 this argument
+is not supported.
+
+Upstream-Status: Backport [https://github.com/qtwebkit/qtwebkit/commit/78360c01c796b6260bf828bc9c8a0ef73c5132fd]
+Change-Id: Ic459d60a6b20bc1838d8771bc36ac41614fe61a9
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Source/JavaScriptCore/generate-bytecode-files | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/JavaScriptCore/generate-bytecode-files b/Source/JavaScriptCore/generate-bytecode-files
+index c5dab429c..af3431275 100644
+--- a/Source/JavaScriptCore/generate-bytecode-files
++++ b/Source/JavaScriptCore/generate-bytecode-files
+@@ -163,7 +163,7 @@ if __name__ == "__main__":
+ initBytecodesFile = openOrExit(initASMFileName, "w")
+
+ try:
+- bytecodeSections = json.load(bytecodeFile, encoding = "utf-8")
++ bytecodeSections = json.load(bytecodeFile)
+ except:
+ print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info()))
+
+--
+2.29.2
+
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index ce7d1b85..9ce948e0 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -18,6 +18,7 @@ SRC_URI += "\
file://0005-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
file://0006-Fix-build-with-bison37.patch \
file://0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \
+ file://0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch \
"
inherit cmake_qt5 perlnative