aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2022-03-03 05:06:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2022-03-10 09:27:03 +0100
commit6f82e21d60318ea9e4208470a10cc547b3b91dae (patch)
tree4e62e4b03559d48b3227e61bca5395c4542bf2f8
parent347fcfb15a3009901f77a8e70e21933464b0cf10 (diff)
qtwebengine: Add missing libxkbfile dependency
The libxkbfile is a new dependency of qtwebengine 5.15.8 updated in commit d38470c2 ("qtwebengine: upgrade to v5.15.8 and use the same SRCREVs as qtpdf") Without libxkbfile dependency, the build fails with: ``` sed: can't read /.../qtwebengine/5.15.8+gitAUTOINC+73e76f9e86_48a205f9e0-r0/image/usr/lib/pkgconfig/Qt5WebEngineCore.pc: No such file or directory ``` The sed failure is fatal, but doesn't show what's wrong, log.do_configure shows it nicely: ``` QtWebEngine required system libraries for qpa-xcb: x11 .................................. yes libdrm ............................... yes xcomposite ........................... yes xcursor .............................. yes xi ................................... yes xproto (glproto) ..................... yes xtst ................................. yes xkbfile .............................. no ... Note: The following modules are not being compiled in this configuration: webenginecore webengine webenginewidgets WARNING: Could not find all necessary libraries for qpa-xcb support in QtWebEngine. WARNING: QtWebEngine will not be built. ``` And it happens only with x11 in DISTRO_FEATURES <- that's why I wasn't seeing it in my builds before. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 735ede41..0f88430f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -23,7 +23,7 @@ DEPENDS += " \
qtwebchannel \
qtbase qtdeclarative qtxmlpatterns qtquickcontrols qtquickcontrols2 \
qtlocation \
- libdrm libxkbcommon fontconfig pixman openssl pango cairo pciutils nss \
+ libdrm libxkbcommon libxkbfile fontconfig pixman openssl pango cairo pciutils nss \
libcap \
jpeg-native \
freetype-native \