aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-04 14:39:11 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2021-03-04 23:48:49 +0100
commit29024f1e40d2890685aa07e771afe6b17d2875bd (patch)
tree705694abf377add97ab4c209466d0976ca9f5b03
parent36f4a9ccd15f5b12ba321f501306919427e42717 (diff)
qtdeclarative: Another fix for gcc11
This was left out since v1 not v2 of the prior patch was merged. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch30
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch b/recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch
new file mode 100644
index 00000000..d803a294
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch
@@ -0,0 +1,30 @@
+From ab263a3e79a36d3e6536adc900b296cdf27f09ae Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 4 Mar 2021 14:37:06 -0800
+Subject: [PATCH] qmldebug: Include limits header
+
+this is needed to solve
+qmldebug/qqmlprofilerevent_p.h:314:65: error: 'numeric_limits' is not a member of 'std'
+
+Its exposed bu gcc11
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/qmldebug/qqmlprofilerevent_p.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/qmldebug/qqmlprofilerevent_p.h b/src/qmldebug/qqmlprofilerevent_p.h
+index a7e37d1964..f778628f8c 100644
+--- a/src/qmldebug/qqmlprofilerevent_p.h
++++ b/src/qmldebug/qqmlprofilerevent_p.h
+@@ -47,6 +47,7 @@
+ #include <QtCore/qvarlengtharray.h>
+ #include <QtCore/qmetatype.h>
+
++#include <limits>
+ #include <initializer_list>
+ #include <type_traits>
+
+--
+2.30.1
+
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 05f6327c..1bbcb57c 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -17,6 +17,7 @@ LIC_FILES_CHKSUM = " \
SRC_URI += " \
file://0001-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-locate-qmlca.patch \
file://0001-yarr-Include-limits-for-numeric_limits.patch \
+ file://0001-qmldebug-Include-limits-header.patch \
"
LDFLAGS_append_riscv64 = " -pthread"