aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-01 17:36:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:45 +0200
commit26b7fee65a3c23a9c2447d549668f373bfa76bae (patch)
treefca7565930f8d7705cb5d96c5bc5ce6d7e561a0c
parent0663bcdddf0311329e607416cd51ce55b9557240 (diff)
qtwebengine: Add 2 more patches to fix do_configure and fix QA warning
* otherwise moc generated files have the same basename and do_configure fails with: core_generated.gyp:QtWebEngineCore#target has several files with the same basename: | javascript_dialog_controller: javascript_dialog_controller.cpp | /OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOINC+21f6ce84ec-r0/git/src/core/.moc/moc_/OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOI.moc+21f6ce84ec-r0/git/src/core/javascript_dialog_controller.cpp ... Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine.inc3
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch (renamed from recipes-qt/qt5/qtwebengine/0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch)6
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch (renamed from recipes-qt/qt5/qtwebengine/0001-Drop-build-time-only-dependency-on-x11-libraries.patch)10
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch (renamed from recipes-qt/qt5/qtwebengine/0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch)8
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch29
-rw-r--r--recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch34
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb8
7 files changed, 85 insertions, 13 deletions
diff --git a/recipes-qt/qt5/qtwebengine.inc b/recipes-qt/qt5/qtwebengine.inc
index b6f56ae2..060faa7b 100644
--- a/recipes-qt/qt5/qtwebengine.inc
+++ b/recipes-qt/qt5/qtwebengine.inc
@@ -41,4 +41,7 @@ do_configure() {
QMAKE_AR="${OE_QMAKE_AR}"
}
+do_install_append() {
+ rmdir ${D}${OE_QMAKE_PATH_PLUGINS}/${BPN} ${D}${OE_QMAKE_PATH_PLUGINS} || true
+}
PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
diff --git a/recipes-qt/qt5/qtwebengine/0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch b/recipes-qt/qt5/qtwebengine/0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch
index c64b32a4..397929f4 100644
--- a/recipes-qt/qt5/qtwebengine/0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch
@@ -1,7 +1,7 @@
-From 2fe53c4c28f91941ee3b446e88f519feb2edc457 Mon Sep 17 00:00:00 2001
+From daf8cd1ccd533d5546ff3a11d19710e0f155cc68 Mon Sep 17 00:00:00 2001
From: Simon Busch <morphis@gravedo.de>
Date: Fri, 20 Jun 2014 09:09:12 +0200
-Subject: [PATCH 2/2] Use ninja supplied by environment variable NINJA_PATH
+Subject: [PATCH 1/3] Use ninja supplied by environment variable NINJA_PATH
Signed-off-by: Simon Busch <morphis@gravedo.de>
---
@@ -32,5 +32,5 @@ index 4dcd8ed..8725fd2 100644
+ return($$NINJA_PATH)
}
--
-1.9.1
+2.0.0
diff --git a/recipes-qt/qt5/qtwebengine/0001-Drop-build-time-only-dependency-on-x11-libraries.patch b/recipes-qt/qt5/qtwebengine/0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch
index 7ee38d0c..abd351a6 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Drop-build-time-only-dependency-on-x11-libraries.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch
@@ -1,11 +1,13 @@
-From f5c8e973f0a246691b71c256361bfa82619ee2ef Mon Sep 17 00:00:00 2001
+From 0c59430e6b919d4ffec80bfa6b50b9ce9953ac21 Mon Sep 17 00:00:00 2001
From: Simon Busch <morphis@gravedo.de>
Date: Fri, 20 Jun 2014 09:05:12 +0200
-Subject: [PATCH 1/2] Drop build time only dependency on x11 libraries
+Subject: [PATCH 1/2] <chromium> Drop build time only dependency on x11
+ libraries
Signed-off-by: Simon Busch <morphis@gravedo.de>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
- src/3rdparty/chromium/build/linux/system.gyp | 114 ---------------------------
+ chromium/build/linux/system.gyp | 114 ----------------------------------------
1 file changed, 114 deletions(-)
diff --git a/src/3rdparty/chromium/build/linux/system.gyp b/src/3rdparty/chromium/build/linux/system.gyp
@@ -133,5 +135,5 @@ index 9911317..85016b8 100644
],
}
--
-1.9.1
+2.0.0
diff --git a/recipes-qt/qt5/qtwebengine/0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch b/recipes-qt/qt5/qtwebengine/0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch
index 6b315985..0cbe7aa4 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch
+++ b/recipes-qt/qt5/qtwebengine/0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch
@@ -1,7 +1,8 @@
-From 7a3179fee9c88ce3dd018b2f159e1b5df74fc7cc Mon Sep 17 00:00:00 2001
+From faaba972642f1966b4e38394b022d79de114c71e Mon Sep 17 00:00:00 2001
From: Simon Busch <morphis@gravedo.de>
Date: Fri, 20 Jun 2014 19:04:14 +0200
-Subject: [PATCH] Strip unwanted "@echo compiling &&" prefix from ${CC}
+Subject: [PATCH 2/2] <chromium> Strip unwanted "@echo compiling &&" prefix
+ from ${CC}
Causes problems when called from a perl script:
@@ -15,6 +16,7 @@ Traceback (most recent call last):
AssertionError
Signed-off-by: Simon Busch <morphis@gravedo.de>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
.../WebKit/Source/build/scripts/action_useragentstylesheets.py | 3 +++
1 file changed, 3 insertions(+)
@@ -34,5 +36,5 @@ index c0712b3..8460637 100644
# assert.
returnCode = subprocess.call(command)
--
-1.9.1
+2.0.0
diff --git a/recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch b/recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch
new file mode 100644
index 00000000..d9b75eb0
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch
@@ -0,0 +1,29 @@
+From fd954d63f62c551c5aeaab662b7ab42a3f2ab527 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Mon, 30 Jun 2014 20:08:17 +0200
+Subject: [PATCH 2/3] functions.prf: Don't match QMAKE_EXT_CPP or QMAKE_EXT_H
+ anywhere in patch, but at the end
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ tools/qmake/mkspecs/features/functions.prf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf
+index 8725fd2..15c2941 100644
+--- a/tools/qmake/mkspecs/features/functions.prf
++++ b/tools/qmake/mkspecs/features/functions.prf
+@@ -40,8 +40,8 @@ defineReplace(findIncludedMocFiles) {
+ defineReplace(mocOutput) {
+ out = $$1
+ # The order is important, since the output of the second replace would end up accidentaly transformed by the first one
+- out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|)), $${QMAKE_CPP_MOD_MOC}\\1$${QMAKE_EXT_CPP_MOC})
+- out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|)), $${QMAKE_H_MOD_MOC}\\1$${first(QMAKE_EXT_CPP)})
++ out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|))$, $${QMAKE_CPP_MOD_MOC}\\1$${QMAKE_EXT_CPP_MOC})
++ out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|))$, $${QMAKE_H_MOD_MOC}\\1$${first(QMAKE_EXT_CPP)})
+ return($$out)
+ }
+
+--
+2.0.0
+
diff --git a/recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch b/recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch
new file mode 100644
index 00000000..bc5a75cc
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0003-functions.prf-Try-to-add-_moc-suffix.patch
@@ -0,0 +1,34 @@
+From 5089c3d10f13874e503f5548f40341d8f59e229f Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 1 Jul 2014 15:58:16 +0200
+Subject: [PATCH 3/3] functions.prf: Try to add _moc suffix
+
+* otherwise moc generated files have the same basename and do_configure fails with:
+ core_generated.gyp:QtWebEngineCore#target has several files with the same basename:
+ | javascript_dialog_controller: javascript_dialog_controller.cpp
+ | /OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOINC+21f6ce84ec-r0/git/src/core/.moc/moc_/OE/build/oe-core/tmp-eglibc/work/i586-oe-linux/qtwebengine/0.9.99+gitAUTOI.moc+21f6ce84ec-r0/git/src/core/javascript_dialog_controller.cpp
+ ...
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ tools/qmake/mkspecs/features/functions.prf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf
+index 15c2941..78b1190 100644
+--- a/tools/qmake/mkspecs/features/functions.prf
++++ b/tools/qmake/mkspecs/features/functions.prf
+@@ -40,8 +40,8 @@ defineReplace(findIncludedMocFiles) {
+ defineReplace(mocOutput) {
+ out = $$1
+ # The order is important, since the output of the second replace would end up accidentaly transformed by the first one
+- out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|))$, $${QMAKE_CPP_MOD_MOC}\\1$${QMAKE_EXT_CPP_MOC})
+- out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|))$, $${QMAKE_H_MOD_MOC}\\1$${first(QMAKE_EXT_CPP)})
++ out = $$replace(out, ^(.*)($$join(QMAKE_EXT_CPP,|))$, $${QMAKE_CPP_MOD_MOC}\\1_moc$${QMAKE_EXT_CPP_MOC})
++ out = $$replace(out, ^(.*)($$join(QMAKE_EXT_H,|))$, $${QMAKE_H_MOD_MOC}\\1_moc$${first(QMAKE_EXT_CPP)})
+ return($$out)
+ }
+
+--
+2.0.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f4964bf7..d06c5214 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -14,9 +14,11 @@ QT_MODULE_BRANCH = "master"
SRC_URI = " \
git://gitorious.org/qt-labs/qtwebengine.git;name=qtwebengine;protocol=git;branch=${QT_MODULE_BRANCH} \
git://gitorious.org/qt-labs/chromium.git;name=chromium;protocol=git;branch=${QT_MODULE_BRANCH};destsuffix=git/src/3rdparty \
- file://0001-Drop-build-time-only-dependency-on-x11-libraries.patch \
- file://0002-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch \
- file://0001-Strip-unwanted-echo-compiling-prefix-from-CC.patch \
+ file://0001-Use-ninja-supplied-by-environment-variable-NINJA_PAT.patch \
+ file://0002-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
+ file://0003-functions.prf-Try-to-add-_moc-suffix.patch \
+ file://0001-chromium-Drop-build-time-only-dependency-on-x11-libr.patch \
+ file://0002-chromium-Strip-unwanted-echo-compiling-prefix-from-C.patch \
"
SRCREV_qtwebengine = "21f6ce84ecca9a4ff2aa980b21d2e5174c78d14b"
SRCREV_chromium = "1f3cc8c2618979b557d60ef1ad984a49dca83bff"