aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-06-30 15:04:29 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:45 +0200
commit655f71d3414696370181bcc531191ed5738502a1 (patch)
treeffedeaa290d5e3e758b3b5b4cb6169abe52f0dd3
parent164f9aa413ce3dc93ebc5cfedecb366bcd984091 (diff)
qtsmarthome: Create recipe to demonstrate qt5 example.
This is the Smarthome QML demo application showing interface to control an automated house. This recipe originated from the wandboard wiki page http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/examples/qtsmarthome_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qt/examples/qtsmarthome_1.0.bb b/recipes-qt/examples/qtsmarthome_1.0.bb
new file mode 100644
index 00000000..944c4dc2
--- /dev/null
+++ b/recipes-qt/examples/qtsmarthome_1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Qt5 smarthome QML demo application"
+DESCRIPTION = "This is the Smarthome QML demo application. It shows some user interfaces for controlling an automated house"
+HOMEPAGE = "http://www.basyskom.com/news/143-demos-qt5-port.html"
+LICENSE = "LGPLv2.1+ & GFDL-1.2"
+LIC_FILES_CHKSUM = "file://COPYING.DOC;md5=ad1419ecc56e060eccf8184a87c4285f \
+ file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://share.basyskom.com/demos/smarthome_src.tar.gz"
+SRC_URI[md5sum] = "883b0376239baec20ebec072e938a995"
+SRC_URI[sha256sum] = "fceaa813c33e462bad6c0383eaef81a6f6e586c15d1fa73898173b517fc1cda6"
+
+S = "${WORKDIR}/smarthome_src"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/smarthome ${D}${datadir}/${P}
+ cp -a ${S}/qml ${D}${datadir}/${P}
+ cp -a ${S}/components ${D}${datadir}/${P}
+}
+
+FILES_${PN}-dbg += "${datadir}/${P}/.debug"
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"