aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-06-30 15:04:30 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:45 +0200
commit74925c7347095aed7af484cf4e59e54cd9390b65 (patch)
treee3d06369063637fd40a880ee65d9310d4761ecf3
parent655f71d3414696370181bcc531191ed5738502a1 (diff)
qt5ledscreen: Create recipe to demonstrate qt5 example.
This is demonstration of simple LedScreen Component utilizing Qt5 QML. This recipe originated from the wandboard wiki page http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/examples/qt5ledscreen_1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/examples/qt5ledscreen_1.0.bb b/recipes-qt/examples/qt5ledscreen_1.0.bb
new file mode 100644
index 00000000..e16c557e
--- /dev/null
+++ b/recipes-qt/examples/qt5ledscreen_1.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "QT5 LedScreen"
+DESCRIPTION = "This is LedScreen Qt5 QML component"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README.txt;md5=fe07f4a0be40fe88f8c7ceaca63a28b5"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/ledscreen_1.0.tgz"
+SRC_URI[md5sum] = "8fc482d5a8b16f43f022c9a282f305b8"
+SRC_URI[sha256sum] = "fa4759b70a5fa148a901a3f9a659f7bd2503d73774022012bded880dffa0d15c"
+
+S = "${WORKDIR}/ledscreen_1.0"
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ #install -m 0755 ${B}/QUItBattery ${D}${datadir}/${P}
+ cp -ar ${S}/* ${D}${datadir}/${P}
+}
+
+FILES_${PN}-dbg += "${datadir}/${P}/.debug"
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"