aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-06-30 15:04:32 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:45 +0200
commit96fb1cadc56709c670ccb416969ebfd1571f941e (patch)
tree02753fbdb0e0abd3d8410345fdc597a11fd1169b
parented02fe97c53d4401b610844106e2f0b29e2c2fb7 (diff)
qt5nmapper: Create recipe to demonstrate qt5 example.
NMapper is a small application to experiment with normal mapping on Qt5. This recipe originated from the wandboard wiki page http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/examples/qt5nmapper_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qt/examples/qt5nmapper_1.0.bb b/recipes-qt/examples/qt5nmapper_1.0.bb
new file mode 100644
index 00000000..9b1b7278
--- /dev/null
+++ b/recipes-qt/examples/qt5nmapper_1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "QT5 NMapper application"
+DESCRIPTION = "NMapper application is demonstrating the normal mapping technique using Qt5"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=47;endline=58;md5=9fb5bf76d564bc53812e40b133ff40dc"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/Qt5_NMapper_1.0.tgz"
+SRC_URI[md5sum] = "dafc425280144d8e286788e75a0dba0f"
+SRC_URI[sha256sum] = "607fbf4c448f00d3c563f9ef8a582bcb6e8fe550e80b56bf8d9127a417faa53b"
+
+S = "${WORKDIR}/Qt5_NMapper_1.0"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/Qt5_NMapper ${D}${datadir}/${P}
+ cp ${S}/Qt5_NMapper.qml ${D}${datadir}/${P}
+ cp -a ${S}/content ${D}${datadir}/${P}
+}
+
+FILES_${PN}-dbg += "${datadir}/${P}/.debug"
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
+